× Warning! This forum is in archival status. New contributions may not work.
[campcaster-dev] Dev Environment not building under Karmic - GCC 4.4 to blame?
  • Hi all,Over the weekend I upgraded my system from Ubuntu Jaunty to Karmic, and since then have not been able to get Campcaster to start. I tried first to 'make start' but that exited with errors. Then I tried rebuilding it, but got another error.I've filed ticket #2354 for this (http://trac.campware.org/campcaster/ticket/2354), and have a suspicion that there's a compatibility problem with GCC 4.4 and some of our files. Anyone got any ideas?doug
  • 2 Comments sorted by
  • Hi Doug,

    This looks like the same issue that Sandro had a couple weeks ago.
    Can you try the things I suggested to him then? (See
    http://lists.campware.org/pipermail/campcaster-support/2009-October/000860.html)

    Thanks,
    Ferenc


    On Mon, Nov 2, 2009 at 1:38 PM, wrote:
    > Hi all,
    >
    > Over the weekend I upgraded my system from Ubuntu Jaunty to Karmic, and
    > since then have not been able to get Campcaster to start. I tried first to
    > 'make start' but that exited with errors. Then I tried rebuilding it, but
    > got another error.
    >
    > I've filed ticket #2354 for this
    > (http://trac.campware.org/campcaster/ticket/2354), and have a suspicion that
    > there's a compatibility problem with GCC 4.4 and some of our files. Anyone
    > got any ideas?
    >
    > doug
    >
  • Hi Ferenc,Thanks for taking a look at this.I've just tried to compile both libodbc++-0.2.4pre4 and libodbc++-0.2.5, but both exit with errors. This is what I get from 0.2.4pre4:In file included from resultset.cpp:28:datastream.h: In member function ‘virtual int odbc::DataStreamBuf::overflow(int)’:datastream.h:58: error: ‘EOF’ was not declared in this scopemake[2]: *** [resultset.lo] Error 1make[2]: Leaving directory `/home/douglas/Desktop/libodbc++-0.2.4pre4/src'make[1]: *** [all-recursive] Error 1make: *** [all] Error 2I'm enclosing the output from both here.doug-----campcaster-dev-bounces@lists.campware.org wrote: -----To: "The Campcaster Developers' Mailing List" <campcaster-dev@lists.campware.org>From: Ferenc Gerlits <fgerlits@gmail.com>Sent by: campcaster-dev-bounces@lists.campware.orgDate: 11/19/2009 05:21PMSubject: Re: [campcaster-dev] Dev Environment not building under Karmic - GCC 4.4 to blame?Hi Doug,This looks like the same issue that Sandro had a couple weeks ago.Can you try the things I suggested to him then?  (Seehttp://lists.campware.org/pipermail/campcaster-support/2009-October/000860.html)Thanks,FerencOn Mon, Nov 2, 2009 at 1:38 PM,  <Douglas.Arellanes@mdlf.org> wrote:> Hi all,>> Over the weekend I upgraded my system from Ubuntu Jaunty to Karmic, and> since then have not been able to get Campcaster to start. I tried first to> 'make start' but that exited with errors. Then I tried rebuilding it, but> got another error.>> I've filed ticket #2354 for this> (http://trac.campware.org/campcaster/ticket/2354), and have a suspicion that> there's a compatibility problem with GCC 4.4 and some of our files. Anyone> got any ideas?>> doug>