× Warning! This forum is in archival status. New contributions may not work.
[campcaster-dev] Fw: compiling campcaster
  • Hi,

    Today via IRC, user 'detonate' has been trying to get Campcaster to compile
    under Debian Lenny. I'm including his comments here, and am also putting
    this up on the Campcaster developers' page
    (http://code.campware.org/projects/campcaster). Maybe some of you have a
    few suggestions for him?



    Hi Doug,

    Trying to compile CampCaster on Debian Lenny, I needed to edit a few
    source files and insert header include statements:

    I had to add #include (as the error was undefined function
    into the following:



    had to add #include into the following:



    Also in

    I amended #include to #include
    as the error was undefined function memcpy()
    This did solve that error, but it then proceeded to produce a lot more
    errors, more fundamental to libodbc++.

    So, I downloaded the latest 0.2.4-pre4.tar.bz2 from sourceforge, and
    overwrote /src/tools/libodbc++/ with the clean copy and that appeared to
    work (without then needing to redo the string.h edit)

    Also on line 96 of ./src/modules/core/src/FileTools.cxx
    I had to add ",1" to the curl_easy_setopt() function call. ie

    - status |= curl_easy_setopt(handle, CURLOPT_HTTPGET);
    + status |= curl_easy_setopt(handle, CURLOPT_HTTPGET,1);

    OK, now the last problem I have is with
    Below is a paste of the output:

    make -C ./src/modules/core all
    make[1]: Entering directory
    g++ -O3 -DHAVE_CONFIG_H -pthread -pedantic -Wall -Wno-long-long
    -I/usr/include -I/campcaster/include/taglib -I/usr/include/libxml++-2.6
    -I/usr/lib/libxml++-2.6/include -I/usr/include/libxml2
    -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include
    -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include
    -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
    -I/campcaster/include -I./include -I./tmp -c -o tmp/AsyncState.o
    /usr/include/c++/4.3/bits/ostream_insert.h: In function
  • 2 Comments sorted by
  • Cheers for posting that Doug.

    I've since been browsing the forums, and what I found was exactly like the first 3 points in this thread:


    Still haven't solved my last issues yet though Sad
  • Forgive the replying to myself, but....

    Fixed it, had to tell src/modules/core/src/AsyncState.cxx
    to #include