Liveblog 3.0 on ubuntu 14.04lts
  • Hi I am trying to install liveblog 3.0, but I am running into some trouble.

    I have been succesful in setting up the docker environment etc. but when i run the demo it will hang up saying:

    superdesk_1 | waiting for mongo on mongodb:27017 ...

    I have tried installing mongodb separately, but it said there was no version 2.6? so i installed the latest version and am running it inside the virtual env. 

    When I go to I get the message about native driver port so MongoDB must be running for sure.. 

    Can someone help me figure this one out?
  • 4 Comments sorted by
  • When trying to boot up the docker container that houses mongodb I get the following error:

    2016-07-28T18:38:22.708+0000 E STORAGE  [initandlisten] WiredTiger (1) [1469731102:708001][1:0x7f2f3b8dac80], connection: /data/db/WiredTiger.wt: handle-open: open: Operation not permitted

    So I guess I need to fix that in order to get mongodb started.
  • Turns out MongoDB was unable to write to the virtual filesystem of docker. setting mongodb to write to the physical drives was a succesful fix for this issue.
  • How did you do that? I have the same problem. But I don't understand how I can change the MongoDB settings in the image that is created by the docker-compose. Some more details to this would be greatly appreciated. 
    Post edited by Philippe Addor at 2016-09-06 12:24:05
  • I think I was able to do it per this description:

    I'm facing another problem now, but seems that the server is starting correctly!