× Warning! This forum is in archival status. New contributions may not work.
broadcast behind schedule
  • I found my airtime 2.5.1 got this issue, the programs sometimes were broadcasted 2 or 3 minutes behind schedule and "on air" button sometimes off, some times on. I upgraded to 2.5.2 (for  Ubuntu 12.04.5 LTS), still got the same problem. uninstalled it and installed many times, still the same.
  • 9 Comments sorted by
  • are you using hardware output or streaming to a server?
  • not using hardware output. yes, streaming to a icecast server.
  • I think it is not a streaming delay (buffered by icecast server or transmission delay), as this kind of delay is just a few seconds or dozens of ( second level). sometimes I heard the problem delay was up to 5 to 7 minutes.
  • a little bit urgent, could somebody help with this issue? thanks a lot in advance!
  • checked /var/log/airtime/pypo/pypo.log, found below message:
    ......
    2016-06-13 23:05:38,199 INFO - [pypoliqqueue.py : main() : line 38] - waiting 272.800197s until next scheduled item
    2016-06-13 23:05:55,348 INFO - [pypoliqqueue.py : main() : line 38] - waiting 255.651426s until next scheduled item
    2016-06-13 23:06:09,881 INFO - [pypoliqqueue.py : main() : line 38] - waiting 241.11837s until next scheduled item
    2016-06-13 23:07:17,154 INFO - [pypoliqqueue.py : main() : line 38] - waiting 173.845854s until next scheduled item
    ......
  • I have the same problem. Not sure what the solution is but you might want to check your time settings.
    See these links:

    https://forum.sourcefabric.org/discussion/16744/scheduled-files-for-playout-are-delayed-by-up-to-a-minute
    https://dev.sourcefabric.org/browse/CC-5909
  • Thanks for Jame's message very much! I have tried to update the ntp services and using the ntp servers closed to my virtual machine, but still got the same result. I don't use sound card in the virtual machine.  I just wanted to know what are the basic troubleshooting steps to find out where is the problem? or narrow down the problem.
  • I still have issues with Airtime 2.5.x timings as well and have to reboot the production server everyday via a cronjob to keep things relatively on schedule!! If it's true what John Chewter  says that "they brought the clock/timezone stuff together" in 2.5.x then it might be worth going back to 2.4.x.

    Either that or try the latest git source to see if there are any improvements there. Let us know how you get on!
    Post edited by James Dunn at 2016-07-11 11:10:41
  • Can confirm this is still an issue on the SaaS so don't expect any help there.