× Warning! This forum is in archival status. New contributions may not work.
Unmet dependencies
  • Hi guys,

    We're running airtime on a dedicated box with Ubuntu 12,04 precise on it. We've just upgraded from 2.5.1 to 2.5.2.1, I say upgraded but opted for a fresh installation (uninstall and then reinstall). During the upgrade we received messages that there were unmet dependencies for several liquidsoap elements;

    The following packages have unmet dependencies:
     liquidsoap-plugin-alsa : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-ao : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-faad : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-flac : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-icecast : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-lame : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-mad : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-ogg : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-portaudio : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-pulseaudio : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-taglib : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-voaacenc : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
     liquidsoap-plugin-vorbis : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
    E: Unable to correct problems, you have held broken packages.

    How can I get around this ? Do I need to compile liquidsoap from source ?

  • 8 Comments sorted by
  • Looks like you have an old version of liquidsoap plugins. You should probably remove all these and then reinstall
  • Try Wheezy, too!
  • Thanks for the input Roger, but that's not relevant to the question. This is a production server with lots of other services installed that I'm trying to upgrade - not reinstall from scratch.

    I don't have liquidsoap-plugins installed, just liquidsoap. When I try to install liquidsoap-plugin-all I get the following; 

    sudo apt-get install liquidsoap liquidsoap-plugin-all
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    liquidsoap is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     liquidsoap-plugin-all : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
                             Depends: liquidsoap-plugin-camlimages but it is not going to be installed
                             Depends: liquidsoap-plugin-dssi but it is not going to be installed
                             Depends: liquidsoap-plugin-gavl but it is not going to be installed
                             Depends: liquidsoap-plugin-gd but it is not going to be installed
                             Depends: liquidsoap-plugin-graphics but it is not going to be installed
                             Depends: liquidsoap-plugin-gstreamer but it is not going to be installed
                             Depends: liquidsoap-plugin-jack but it is not going to be installed
                             Depends: liquidsoap-plugin-ladspa but it is not going to be installed
                             Depends: liquidsoap-plugin-lastfm but it is not going to be installed
                             Depends: liquidsoap-plugin-lo but it is not going to be installed
                             Depends: liquidsoap-plugin-oss but it is not going to be installed
                             Depends: liquidsoap-plugin-samplerate but it is not going to be installed
                             Depends: liquidsoap-plugin-schroedinger but it is not going to be installed
                             Depends: liquidsoap-plugin-sdl but it is not going to be installed
                             Depends: liquidsoap-plugin-soundtouch but it is not going to be installed
                             Depends: liquidsoap-plugin-speex but it is not going to be installed
                             Depends: liquidsoap-plugin-theora but it is not going to be installed
                             Depends: liquidsoap-plugin-xmlplaylist but it is not go ing to be installed
    E: Unable to correct problems, you have held broken packages.

    So, liquidsoap is the latest version in the repo, but it complains because version 1.1.1~precise~sfo-2 is to be installed ?!
  • Why do you have lots of other services installed on the same server as Airtime? Have you gone mad?  8-}
  • Ahh Roger, still as sane and helpful as ever. Are you implying that airtime is dangerously unstable and a threat to anything else running on the same box?
  • Run apt-get install -
  • Vote Up0Vote Down IljanIljan
    Posts: 8Member
    sudo apt-get install -f liquidsoap liquidsoap-plugin-allinstall

    That wil do the trick indeed. 

           -f, --fix-broken
               Fix; attempt to correct a system with broken dependencies in place. This option, when used with install/remove, can omit any packages to permit APT to deduce a likely solution. If packages are specified, these have to completely correct the problem. The option is sometimes necessary when running APT for the first time; APT itself does not allow broken package dependencies to exist on a system. It is possible that a system's dependency structure can be so corrupt as to require manual intervention (which usually means using dpkg --remove to eliminate some of the offending packages). Use of this option together with -m may produce an error in some situations. Configuration Item: APT::Get::Fix-Broken.

  • I use the -f option, but still got error:

    ubuntu@ip-172-31-30-145:~/airtime-airtime-2.5.2.1$ sudo apt-get install -f liquidsoap liquidsoap-plugin-all
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    liquidsoap is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     liquidsoap-plugin-all : Depends: liquidsoap (= 1.0.0-4build1) but 1.1.1~precise~sfo-2 is to be installed
                             Depends: liquidsoap-plugin-camlimages but it is not going to be installed
                             Depends: liquidsoap-plugin-dssi but it is not going to be installed
                             Depends: liquidsoap-plugin-gavl but it is not going to be installed
                             Depends: liquidsoap-plugin-gd but it is not going to be installed
                             Depends: liquidsoap-plugin-graphics but it is not going to be installed
                             Depends: liquidsoap-plugin-gstreamer but it is not going to be installed
                             Depends: liquidsoap-plugin-jack but it is not going to be installed
                             Depends: liquidsoap-plugin-ladspa but it is not going to be installed
                             Depends: liquidsoap-plugin-lastfm but it is not going to be installed
                             Depends: liquidsoap-plugin-lo but it is not going to be installed
                             Depends: liquidsoap-plugin-oss but it is not going to be installed
                             Depends: liquidsoap-plugin-samplerate but it is not going to be installed
                             Depends: liquidsoap-plugin-schroedinger but it is not going to be installed
                             Depends: liquidsoap-plugin-sdl but it is not going to be installed
                             Depends: liquidsoap-plugin-soundtouch but it is not going to be installed
                             Depends: liquidsoap-plugin-speex but it is not going to be installed
                             Depends: liquidsoap-plugin-theora but it is not going to be installed
                             Depends: liquidsoap-plugin-xmlplaylist but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.


    can you please help with this?