Superdesk install
  • Dear Sourcefabric!

    I would like to ask for some help in setting up a demo environment.

    Used your guide from github but i cannot upload media. it writes on frontend "There are failed uploads.Try again". Can i ask you how to make logging output into log files not only to console? Or can you tell me where can i find the exact path of logfiles?
    I can't create "plain text" or "empty package" neither.


  • 5 Comments sorted by
  • hi!
    docker-compose -p sddemo -f ./docker/docker-compose-prebuilt.yml logs > log.txt
    Post edited by Yauhen Kirylau at 2016-02-17 18:16:18
    Innovations developer, Sourcefabric
  • Hi @all,

    installed it today from GIT. Absolutly the same.
    No Upload
    No creation of plain text and packages

    line 105, in _raise_error
    | 17:59:48 rest.1    |     raise HTTP_EXCEPTIONS.get(status_code,
    TransportError)(status_code, error_message, additional_info)

    | 17:59:48 rest.1    |
    elasticsearch.exceptions.RequestError: TransportError(400,
    "ElasticsearchIllegalArgumentException[Alias [superdesk] has more than one
    indices associated with it [[superdesk_a600f3b0, superdesk_fdf5fc4f,
    superdesk_7e989e39, superdesk_b058a7df, superdesk_dbc61465, superdesk_1e31444e,
    superdesk_11fc3e6f, superdesk_2bfb1e79, superdesk_5660cf9c,
    superdesk_ea982a6b]], can't execute a single index op]")

    Post edited by Holger Hammerschlag at 2016-02-18 13:02:08
  • i see something wrong with elastic search indexes, i am not sure what actually caused that, mb few superdesk instances were trying to use the same elastic index or smth like that.

    Try removing `./data/` and running docker-create-user script again
    Innovations developer, Sourcefabric
  • Ok Great... Killed ./data and started create-user again. It solved the problem.

    Thanks for now

    Post edited by Holger Hammerschlag at 2016-02-18 13:34:02
  • Thanks problem solved here to.