web interface stucked
  • Hello,

    After some month of running airtime without big problems (one unexplained crash some weeks), now the web interface hangs when I try to add a new show.  Sometimes, my web explorer talk about the "mutation-summary.js:598" script who's stuck. I've try from linux and windows, with firefox or chromium, always the same problem.
    The logs doesn't show any errors :
    $ cat /var/log/airtime/pypo-liquidsoap/ls_script.log |grep warning
    $ cat /var/log/airtime/pypo-liquidsoap/ls_script.log |grep error
    $ cat /var/log/airtime/pypo/pypo.log |grep warning
    $ cat /var/log/airtime/pypo/pypo.log |grep error
    2016-01-25 15:49:44,876 DEBUG - [api_client.py : get_stream_parameters() : line 504] - {u'stream_params': {u's3': {u'admin_pass': u'bla', u'enable': u'false', u'
    name': u'', u'url': u'', u'type': u'mp3', u'mount': u'bla_mp3', u'liquidsoap_error': u'waiting', u'channels': u'stereo', u'host': u'airtime.radiobla.org', u'a
    dmin_user': u'admin', u'user': u'', u'pass': u'bla', u'genre': u'', u'output': u'icecast', u'bitrate': u'48', u'port': u'8000', u'description': u''}, u's2': {u'a
    dmin_pass': u'bla', u'enable': u'true', u'name': u'Radio bla', u'url': u'http://www.radiobla.org', u'bitrate': u'64', u'mount': u'bla_hd', u'liqui
    dsoap_error': u'OK', u'channels': u'stereo', u'host': u'airtime.radiobla.org', u'admin_user': u'admin', u'user': u'', u'pass': u'bla', u'genre': u"Radio d'\
    xe9ducation populaire", u'output': u'icecast', u'type': u'ogg', u'port': u'8000', u'description': u'bip'}, u's1': {u'admin_pass': u'bla',
     u'enable': u'true', u'name': u'Radio bla', u'url': u'http://www.radiobla.org', u'bitrate': u'64', u'mount': u'bla_ld', u'liquidsoap_error': u'OK', u'cha
    nnels': u'stereo', u'host': u'airtime.radiobla.org', u'admin_user': u'admin', u'user': u'', u'pass': u'bla', u'genre': u"bip", u'
    output': u'icecast', u'type': u'mp3', u'port': u'8000', u'description': u'bip'}}}

    $ airtime-check-system
    AIRTIME_STATUS_URL             = http://airtime.radiobla.org:80/api/status/format/json/api_key/%%api_key%%
    KERNEL_VERSION                 = 3.12.46-guest-39-a97a54c-x86_64
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 1008052
    TOTAL_SWAP_MBYTES              = 524284
    AIRTIME_VERSION                = 2.5.1
    OS                             = Debian GNU/Linux 7.9 (wheezy) x86_64
    CPU                            = Intel(R) Xeon(R) CPU E5-2650 v2 @ 2.60GHz
    WEB_SERVER                     = Apache/2.2.22 (Debian)
    PLAYOUT_ENGINE_MEM_PERC        = 1.8%
    PLAYOUT_ENGINE_CPU_PERC        = 0.0%
    LIQUIDSOAP_PROCESS_ID          = 3222
    LIQUIDSOAP_MEM_PERC            = 2.2%
    LIQUIDSOAP_CPU_PERC            = 5.9%
    MEDIA_MONITOR_MEM_PERC         = 2.2%
    MEDIA_MONITOR_CPU_PERC         = 0.0%
    -- Your installation of Airtime looks OK!

    The server is up to date.

    It's possible the database was "corrupted" (due to hard reboot) without showing error in the posgres log ?

    Thanks for your help !
    Post edited by red0queen at 2016-01-25 11:43:36
  • 12 Comments sorted by
  • What about the PHP / webserver logs. The two places you were looking for errors are not directly related to where you might be having problems. I'm not 100% sure where the 2.5.1 logs are stored since I really started delving into the code post 2.5.2 but I believe it is stored in the zendphp.log there. That might have a more useful error as that is where any errors the web interface might provide are located.
  • Nothing in the apache log.
    About the zendphp.log :
    When I add a new show, my browser crash but I see nothing in the log. The new show is created when I reconnect.
    When I delete a show, just before stuck my bother, a line appear in the log :
    2016-01-27T15:28:26+01:00 INFO (6): [ScheduleController.php : eventFeedPreloadAction() : line 139] - month

    If I search for errors in this log, I find some occurrences like this :
    [index.php : () : line 73] - #0 /usr/share/airtime/application/forms/AddShowWhen.php(274): exception_error_handler(8, 'Undefined varia...', '/usr/share/airt...', 274, Array)

    It's help you to understand ???

  • did you make any changes or modification?
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • On the interface code ? no. The only change I made is applying this script about recording sound without soundcard. I can disable it but I don't think is linked to my problem ?
    Post edited by red0queen at 2016-01-29 03:55:52
  • I'm currently having the same problem right now.
  • Hello, I'm having the same problem. It stucks when I add a show, change metadata of a file, deleting a file, etc...
  • Which version of Airtime is everyone running ? I'm assuming 2.5.1 because that is the version that most people tend to run.
  • Hello,

    I did a backup/reinstall and now it seems to work fine. 

    Here is my config :
    TOTAL_MEMORY_MBYTES :  2012140
    AIRTIME_VERSION :  2.5.1
    OS :  Debian GNU/Linux 7.9 (wheezy) x86_64
    CPU :  Intel Xeon E312xx (Sandy Bridge)
    WEB_SERVER :  Apache/2.2.22 (Debian)
    STATION_NAME : Radio Campus France
    PHONE : 
    EMAIL : 
    NUM_OF_USERS : 3
    NUM_OF_SONGS : 294
    UNIQUE_ID : 6b500d3f9ebea50d2abcad0a2489a665
    INSTALL_METHOD : debian_install
  • I have just had a similar issue today regarding adding a show to be recorded and rebroadcast. The error I had was similar to yours:

    2016-02-04T15:53:02+00:00 INFO (6): [index.php : () : line 71] - Undefined variable: hours
    2016-02-04T15:53:02+00:00 INFO (6): [index.php : () : line 73] - #0 /usr/share/airtime/application/forms/AddShowWhen.php(303): exception_error_handler(8, 'Undefined varia...', '/usr/share/airt...', 303, Array)

    I then compared the AddShowWhen.php file with the latest file on github:


    and noticed there were some differences, specifcally relating to this issue. So I just copied the github file to my server and it solved the issue. You might want to check/diff these files too as it may solve your problem.

  • Hello James Dunn,

    Thanks for your message. I changed the file as you did but my problem was not solved...

    Once i reinstalled it was ok but it's maybe a problem of full disk space. Do you know how many space should be free for airtime works fine ?
  • This is what my server has:

    rootfs 20G 2.3G 17G 13% /

    /dev/sda3 3.6T 1.3T 2.2T 37% /mnt/airtime

    I always have the audio directory on a separate hard drive. If you have a few gigabytes free for the OS you should be fine.

    Post edited by James Dunn at 2016-02-06 12:15:28
  • Like a good old proprietary system, reinstall it have been fixed my problem ;-)