Whoops, looks like something went wrong.
  • Hello.

    I'm trying to install new copy of Newscoop 4.3.1 over ISPConfig managed host. ISPConfig setup by tutorial.
    I'm answer to all questions, it's create base. When i click "Finish" button - it produce:

    Whoops, looks like something went wrong.

    1/1 RuntimeException: The php executable could not be found, add it to your PATH environment variable and try again

    1. in /var/www/clients/client1/web1/web/library/Newscoop/Installer/Services/FinishService.php line 46
    2. at FinishService->generateProxies() in /var/www/clients/client1/web1/web/install/index.php line 344
    3. at {closure}(object(Request))
    4. at call_user_func_array(object(Closure), array(object(Request))) in /var/www/clients/client1/web1/web/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php line 117
    5. at HttpKernel->handleRaw(object(Request), '1') in /var/www/clients/client1/web1/web/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php line 61
    6. at HttpKernel->handle(object(Request), '1', true) in /var/www/clients/client1/web1/web/vendor/silex/silex/src/Silex/Application.php line 538
    7. at Application->handle(object(Request)) in /var/www/clients/client1/web1/web/vendor/silex/silex/src/Silex/Application.php line 515
    8. at Application->run() in /var/www/clients/client1/web1/web/install/index.php line 353

    What i need to do?
  • 2 Comments sorted by
  • I have the same problem. Have you solved it?
    Thanks in advance
  • Hi, this sounds like a permissions error (I have just done a clean install of Newscoop 4.5 and had a couple of problems with folder permissions on Debian 64).

    Have you tried:

    a) granting permissions to the Apache user, www-data for Ubantu or Linux (or another user with privileges other than root for other distributions), i.e:

    sudo chown -R www-data.www-data /var/www/newscoop/


    b) Running the PHP fixer script as this also fixes common permission problems:

    (type the following into Putty or whichever terminal you are using:)

    php scripts/fixer.php

    The installer package is fine and working otherwise.