× Warning! This forum is in archival status. New contributions may not work.
Airtime 2.5.2 fresh install on Debian 7.8 airtime-liquidsoap service fails to start
  • 3rd try at installing 2.5.2 on Debian 7.8 (tried 2 different tin machines and 1 ESXI 5.5 VM)
    Followed the instructions as per the included README but always get the same issue.
    All is great up to "Manual Step 5 of 5 : Start Airtime Services".
    The airtime-liquidsoap service refuses to start :(
  • 10 Comments sorted by
  • It just seems to be that service giving me issues
    1058 x 840 - 52K
  • You didn't specify 32 or 64-bit Debian. Also if you were to look at other threads, you would find that there's an entire thread devoted to a discussion regarding Airtime 2.5.2. I, personally, was unable to get Airtime 2.5.2 running properly on a 32-bit machine running Wheezy, and this included attempting on running the software on a clean install. Everything I tried failed. Sourcefabric apparently only tests their software on 64-bit Wheezy, because, as you know, all 32-bit computers are now soaking up UV rays in e-waste dumps. 2.5.2 should have been released as alpha software or not released at all.

    You may as well stick with 2.5.1 as this version has less issues and more or less works out of the box. If you've already installed 2.5.2, you may as well reformat your root partition as the uninstall script is broken and does a poor job of removing everything it installs. I played around with manually removing files and packages in the run level directories to see how "clean" I could get the system which took a long time, but in the end, a reformat was the only way to get the system back to a clean state. dpkg doesn't handle the uninstall since the install wasn't done using it therefore relying on a broken Bash script written by the Airtime devs.
    Post edited by Bob Larson at 2015-03-31 04:57:49
  • Hi Bob, my attempts were all on x64.
    I have a running system on 2.5.1 that works well, I just like playing with latest versions to see what new features there are and what bugs have been fixed :)
    Yes I saw the 2.5.2 thred but I thought hijacking that with my issue would be bad.
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    it's a problem with the packaged silan version and last debian/ubuntu versions
    debianize the last silan version on github
  • Hi Albert, I am a bit of a n00bie on nix based systems (my day job is MS Systems Engineer)
    Had a quick look but I well out of my depth on this, is it a simple one(ish) line in console or more involved?
  • is it possible not all of the dependencies are installed?  have you tried "sudo apt-get install -f" 
  • Hi Aslan, I have checked that and no updates needed.
  • Vote Up0Vote Down Albert SantoniAlbert Santoni
    Posts: 68Member, Sourcefabric Team, Airtime Moderator
    Hey guys,

    I just uploaded a small update that fixes a couple of the issues that you guys have reported:

    Can you please make sure to run the uninstall script from the new tarball before running the install script? (You need to run uninstall to remove one of the files from Airtime <= 2.5.1 that's in conflict with 2.5.2.)

    Thanks!
    Albert
     
    Airtime Developer @ Sourcefabric
  • Was the issue I was seing the "- Fixed daemons not starting up by default on Debian, better Debian compatibility" bit?

    TBH I will be doing a fresh install as I have a couple of spare laptops to test on, might as well start from scratch
  • Oh sorry, I didnt notice it was update.

    No worries, will try it out in a bit :D