× Warning! This forum is in archival status. New contributions may not work.
Airtime down, airtime-liquidsoap won't start
  • I tried installing version 2.5.2.  A word to the wise: don't.

    I have reverted my system to 2.5.1, and everything seems fine except for one teensy problem: the module airtime-liquidsoap appears not to exist.  Here's what I'm seeing:

    root@server1:/usr/bin# airtime-check-system
    PHP Warning:  Module 'geoip' already loaded in Unknown on line 0
    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = 2.6.32-042stab088.4
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 8589934588
    TOTAL_SWAP_MBYTES              = 0
    AIRTIME_VERSION                = 2.5.1
    OS                             = Debian GNU/Linux 7.6 (wheezy) x86_64
    CPU                            = Intel(R) Xeon(R) CPU E3-1230 v3 @ 3.30GHz
    WEB_SERVER                     = Apache/2.2.22 (Debian)
    PLAYOUT_ENGINE_PROCESS_ID      = 5113
    PLAYOUT_ENGINE_RUNNING_SECONDS = 423
    PLAYOUT_ENGINE_MEM_PERC        = 0.0%
    PLAYOUT_ENGINE_CPU_PERC        = 0.1%
    LIQUIDSOAP_PROCESS_ID          = FAILED
    LIQUIDSOAP_RUNNING_SECONDS     = 0
    LIQUIDSOAP_MEM_PERC            = 0%
    LIQUIDSOAP_CPU_PERC            = 0%
    -- Displaying log file /var/log/airtime/pypo-liquidsoap/ls_script.log
    -- 
    -- 
    MEDIA_MONITOR_PROCESS_ID       = 5003
    MEDIA_MONITOR_RUNNING_SECONDS  = 423
    MEDIA_MONITOR_MEM_PERC         = 0.0%
    MEDIA_MONITOR_CPU_PERC         = 0.0%
    -- There appears to be a problem with your Airtime installation.


    ----------------------------

    When I try to start the process manually, I get this:

    root@server1:/usr/bin# service airtime-liquidsoap start
    * Starting Liquidsoap Playout Engine without Monit process watchdog. To make sure Monit is watching 
    * Liquidsoap, use 'start-with-monit' instead of 'start'.
    Starting Liquidsoap Playout Engine: Traceback (most recent call last):
      File "/usr/bin/airtime-liquidsoap", line 4, in <module>
        import pkg_resources
      File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 3023, in <module>
      File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 614, in _build_master
      File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 920, in require
      File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 807, in resolve
    pkg_resources.DistributionNotFound: airtime-playout==1.0
    Done.

    The file /usr/bin/airtime-liquidsoap is a short Python script that invokes the module, which it obviously can't find.

    What the heck do I do now? I'm off the air till this is fixed, and I'm in dire straits here.
  • 2 Comments sorted by
  • Vote Up0Vote Down Albert SantoniAlbert Santoni
    Posts: 68Member, Sourcefabric Team, Airtime Moderator
    If you're downgrading to 2.5.1, remove /usr/bin/airtime-liquidsoap.
    Airtime Developer @ Sourcefabric
  • I did. 

    I ran 'apt-get remove airtime', then 'apt-get purge airtime', and for good measure I went to /usr/bin and made sure airtime-liquidsoap was gone.

    I then reran 'apt-get install airtime', and it ran the install, and when it got to the end and ran the system check, the 'airtime-liquidsoap' task had failed to start.

    Starting it manually, I got this:

    oot@server1:/usr/bin# service airtime-liquidsoap start
    * Starting Liquidsoap Playout Engine without Monit process watchdog. To make sure Monit is watching 
    * Liquidsoap, use 'start-with-monit' instead of 'start'.
    Starting Liquidsoap Playout Engine: Traceback (most recent call last):
      File "/usr/bin/airtime-liquidsoap", line 4, in <module>
        import pkg_resources
      File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 3023, in <module>
      File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 614, in _build_master
      File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 920, in require
      File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 807, in resolve
    pkg_resources.DistributionNotFound: airtime-playout==1.0
    Done.

    I checked the contents of the newly rewritten /usr/bin/airtime-liquidsoap file, and they read as follows:

    #!/usr/bin/python
    # EASY-INSTALL-SCRIPT: 'airtime-playout==1.0','airtime-liquidsoap'
    __requires__ = 'airtime-playout==1.0'
    import pkg_resources
    pkg_resources.run_script('airtime-playout==1.0', 'airtime-liquidsoap')

    So can you please tell me why this is being recreated?

    So far 2.5.2 has been very destructive.