[SOLVED] apt-get update && apt-get dist-upgrade doesn't work
  • Hello everyone!

    I've been using Airtime for some months now, but I'm currently encountering a strange problem : when I try to update Airtime thanks to apt-get update apt-get dist-upgrade (+ sudo, ofc) Airtime doesn't update. The problem is I'm using 2.5.0, so there should be an update...

    I checked and the sourcefabric repo seems alright ('deb http://apt.sourcefabric.org/ precise main'
     is in /etc/apt/sources.list.d/sourcefabric.list). Here are the lines concerning Sourcefabric when 'apt-get update' :

    Hit http://apt.sourcefabric.org precise/main i386 Packages
    Ign http://apt.sourcefabric.org precise/main TranslationIndex
    Ign http://apt.sourcefabric.org precise/main Translation-en_US
    Ign http://apt.sourcefabric.org precise/main Translation-en

    So, am I missing something?

    Thank you very much for your help.

    Post edited by Maxime at 2014-05-13 16:41:04
  • 11 Comments sorted by
  • Hi Maxine,

    What happens if you follow `apt-get update` with `apt-get --just-print upgrade`, instead of `apt-get dist-upgrade`? 

    I'd be interested in the output of that... Note the --just-print bit stops the upgrade from actually happening, instead reporting what would happen if that flag wasn't provided.

    For testing, I'd recommend running each command separately (i.e. don't join with `&&`. Either hit [enter] after each job, or separate with a semicolon `;`)

    Post edited by Steven McPhillips at 2014-04-16 21:30:50
  • Hi Steven,

    thank you for your answer!

    In fact, I never use the '&&', I always run the commands separately, in order to check every step. Here is the output of  'sudo apt-get --just-print upgrade' run just after 'sudo apt-get update' :

    Reading package lists... Done
    Building dependency tree      
    Reading state information... Done
    The following packages have been kept back:
      sendmail sendmail-base sendmail-bin sendmail-cf
    0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

    Post edited by Maxime at 2014-04-17 13:44:41
  • Hi Maxine,

    Thanks for the extra information. It's interesting that your apt-get update command isn't showing an updated Airtime package - if you look at http://apt.sourcefabric.org/dists/precise/main/binary-i386/Packages, you can see it is currently providing version 2.5.1-1.

    Based on the output of the "--just-print" upgrade command, your system seems to think it has all available updates applied (sendmail notwithstanding). Can I get you to confirm the current version of Airtime installed: dpkg -l airtime should do the trick. If the last line of the output starts with 'ii', the listed version - which should be 2.5.1-1 - is installed correctly. (edit: the dpkg command won't require sudo)
    Post edited by Steven McPhillips at 2014-04-19 22:36:46
  • Hi Steven,

    here's the output of dpkg -l airtime :

    ii  airtime             2.5.1-1             open broadcast software for scheduling and station man...

    The strange part is that the command airtime-check-system returns a different version :

    AIRTIME_STATUS_URL             = http://XXXX:80/api/status/format/json/api_key/%%api_key%%
    KERNEL_VERSION                 = 3.5.0-48-generic
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 4049504
    TOTAL_SWAP_MBYTES              = 3156768
    AIRTIME_VERSION                = 2.5.0
    OS                             = Ubuntu 12.04.4 LTS x86_64
    CPU                            = QEMU Virtual CPU version 0.12.3
    WEB_SERVER                     = Apache/2.2.22 (Ubuntu)
    PLAYOUT_ENGINE_MEM_PERC        = 0.4%
    PLAYOUT_ENGINE_CPU_PERC        = 0.0%
    LIQUIDSOAP_PROCESS_ID          = 2054
    LIQUIDSOAP_MEM_PERC            = 0.9%
    LIQUIDSOAP_CPU_PERC            = 8.9%
    MEDIA_MONITOR_MEM_PERC         = 0.2%
    MEDIA_MONITOR_CPU_PERC         = 0.0%
    -- Your installation of Airtime looks OK!

    (I removed the IP adress for security reasons)

    So, do I have two different versions installed? :s

    Post edited by Maxime at 2014-04-20 10:36:12
  • Hi Maxine,

    OK, I can confirm you've got the latest version. Although airtime-check-system is reporting 2.5.0, dpkg does not lie :)

    Hunting around a bit, I've noticed the version details as available to airtime-check-system
    differ from what dpkg sees. I've notified the package maintainer of this, and we'll see what happens.
    Post edited by Steven McPhillips at 2014-04-20 21:04:41
  • Hi Steven,

    Ok! The Airtime web interface tells me that I'm on 2.5.0 and that a new version of Airtime is available. Is it just the same problem?

    Thank you very much for your help,

  • Hmm, I've had a bit of a poke around the deb source package, and it seems your install should at least be reporting 2.5.1. It might be worthwhile running apt-get install --reinstall airtime to re-apply the airtime package, just in case something went wrong in the original update.

    I would make a backup of your airtime (and apache) config beforehand, especially if you've modified them.

    I'm still waiting to hear back from the package maintainer, so an alternative would be to hold on for their thoughts... when I have more information, I'll post it here.
  • Hi,
    I have problem with install airtime 2.5.1 to Linux Ubuntu 14.04 LTS.
    W: Chyba GPG: http://backports.debian.org squeeze-backports InRelease: Následující podpisy nemohly být ověřeny, protože není dostupný veřejný klíč: NO_PUBKEY 8B48AD6246925553
    W: Selhalo stažení http://apt.sourcefabric.org/dists/trusty/main/binary-i386/Packages  404  Not Found [IP: 80]

    E: Některé indexové soubory se nepodařilo stáhnout. Jsou ignorovány, nebo jsou použity starší verze.
    Help me, please.
  • There is no Available distribution package for Raring and Trusty ( you will get a 404 error)

    These are the only Available Packages



    Good Luck
    Post edited by Voisses Tech at 2014-04-26 13:29:04
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Vote Up0Vote Down MaximeMaxime
    Posts: 7Member
    Hi folks!

    Just to tell you that I solved my problem thanks to apt-get install --reinstall airtime !

    Make sure that you have saved your config files before, and specially icecast files, since they will be cleared.

    Also, you will need to update airtime.ini (db password).

    Thanks a lot for your help Steven !

    Post edited by Maxime at 2014-05-13 18:09:28
  • Glad to hear Maxime - thanks for taking the time to report back and mark the discussion as solved. I'm sure this will prove useful to other Airtime users in the future!