2.5.1 upgrade fails
  • I haven't seen anyone report this but when I do a apt-get install airtime I get the following:

    Setting up airtime (2.5.1-1) ...
    Setting up apache2...
    Site airtime-vhost disabled.
    To activate the new configuration, you need to run:
      service apache2 reload
    Enabling site airtime-vhost.
    To activate the new configuration, you need to run:
      service apache2 reload
    Module rewrite already enabled
    Site 000-default already disabled
    Configuring php5...
    [FAIL] Restarting web server: apache2 failed!
    [warn] The apache2 configtest failed. ... (warning).
    Output of config test was:
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/ports.conf:8
    AH00526: Syntax error on line 13 of /etc/apache2/sites-enabled/airtime-vhost.conf:
    Either all Options must start with + or -, or no Option may.
    Action 'configtest' failed.
    The Apache error log may have more information.
    invoke-rc.d: initscript apache2, action "restart" failed.
    dpkg: error processing package airtime (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    When I check line 13 of /etc/apache2/sites-enabled/airtime-vhost.conf I see a "-" within it.  If I remove the "-" I can restart apache.  With it not removed apache fails when restarted.

    Below is the airtime-vhost.config 

    <VirtualHost *:80>
          ServerName GW1
          #ServerAlias www.example.com

          ServerAdmin root@GW1

          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php

          SetEnv APPLICATION_ENV "production"

          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all

    How do I get this working?

    I'm using Debian jessy and the following is what I did:

    apt-get update
    apt-get dist-upgrade
    apt-get install airtime
    Post edited by Reaz Baksh at 2013-12-28 15:36:02
  • 3 Comments sorted by
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    are you on apache 2.4.6 ?

    apache rules have changed

    search on the forum the thread dedicated to that
  • Thanks for this Albert. I'll go through the link.