"Output Stream Settings" not appearing in AirTime 2.5 from GitHub
  • Hello everyone!

    I am attempting to setup a development environment with Airtime and wanted to address an issue.  I'm using a Mac with VMWare Fusion running Ubuntu Desktop 12.10 LTS.  The installation appears to run successfully, but when I go the "Stream Settings" menu, I am finding that the "Output Stream Settings" is not appearing.

    Here are the steps to recreate:
    1. Checkout the AirTime Github repo (I have my own fork of the code, but for this example, I am using the original source...git clone git@github.com:sourcefabric/Airtime.git)
    2. sudo ~/Airtime/install_full/ubuntu/airtime-full-install
    3. After the installation, log into AirTime
    4. Go to System ->Streams...the Output Stream Settings does not appear.
    I have attached a screenshot and the logs in the zip file.

    I'd appreciate any assistance on this matter.
    Post edited by Dustin Page at 2013-12-01 03:12:05
  • 10 Comments sorted by
  • I have the same - reported as Bug CC-5609

    Post edited by John Chewter at 2013-12-08 06:18:13
    No longer using Airtime or Libretime.
  • It has been fixed on Friday. Update the branch by doing

    git pull origin 2.5.x
  • (Make sure you are in branch 2.5.x)

    Branch cc-5594-.... Has unmerged timezone changes which you can try if you want.
  • Hi, Naomi.

    After finally overcoming my my timezone Show Overlap issue, I further blew up my Airtime by externally editing tags. 
    (at least that's what I was doing when it went kaboom)
    Airtime went the "Off Air" and when I tried to manually drop a file on the current show, 
    I got the double file playing problem.

    I deleted the virtual machine and started with a new setup.
    I documented my steps (attached) for myself, since this reinstall thing is getting to be a habit.

    This, time, rather than install from the .tar, I cloned the install from github.

    I couldn't figure out how to link with a specific fork, even though I installed git, set up an account and ssh key.
    I kept getting an "Access denied" error.

    I finally just did the simple sudo git clone https://github.com/sourcefabric/Airtime.git

    I've just gotten around to adding the media, creating smart blocks and went to enter my stream data when I find the same blank section.

    I tried the "git pull" command above but I get "not a git repository"
    Are you using some shorthand for a longer command?

    How do I access the 2.5.x fork?

    Sorry to be such a newbie pest...
  • were you in the Airtime directory when you did git pull?

    move to the Airtime directory and type "git branch" to see what you're currently on.

    to get to 2.5.x type

    "git checkout 2.5.x"
    Post edited by Naomi at 2013-12-09 16:32:47
  • By editing tags do you mean you were changing the metadata of some files? 

    Which folders were these files in and what program did you use to edit them?
  • I find that the stream breaks sometimes when I edit tags inside airtime. It usually recovers. Sometimes I then get two tracks playing.

    No longer using Airtime or Libretime.
  • Are you editing metadata of files that are currently playing? Or scheduled sometime in the future? If you have any other details that could help us reproduce it please provide them. Thanks

  • I have only noticed it on linked files - which are not playing. Anyway you are not playing that file - you are playing from the airtime cache.
    No longer using Airtime or Libretime.
  • No, I wasn't in the Airtime directory.
    That was the problem.

    I got to the right fork, pulled origin, went to the 2.5.1 upgrade directory and ran the airtime-2.5.1 upgrade script from command line.

    After restarting apache, Airtime shows that I am on v2.5.1
    I have my streams configured and they are up and running.

    Thanks, again.
    You folks are the best!

    I've never had such fast response from developers - not even from my own company.

    Oh, right...Yes, I was using MusicBrainz Picard, which auto-updates tags and has a last.fm "Mood" plug-in.
    Almost all of the files are in a Watch folder in a VMware shared folder on the host pc.

    I was doing a block of a couple hundred tags when the trouble hit.
    I was using smart blocks, based on Genre.
    My guess was that Picard changed the Genre of a file that was playing or was queued up.

    I checked another file via Preview and it played, so I tried dropping that on the current show.
    That's when the doubling started.

    I deleted all shows and smart blocks and unwatched the media folder.
    I re-imported the media, created new smart blocks and started to make some new shows.
    I couldn't ever get "On Air" to do anything but come on for about a second.

    I finally gave up and decided to start over with a whole new VM.
    Unfortunately, I deleted the dead one from disk, I don't have any log files left.
    Post edited by Matthew Pawloski at 2013-12-09 19:09:02