× Warning! This forum is in archival status. New contributions may not work.
Multiple playlists playing simultaneously! WTF?
  • We've got a situation where what appears to be a random playlist is playing along side our scheduled one.  We have not modified our ls_script.lq file, it's straight stock.

    Where would pypo be getting two concurrent play lists from, and why would it be attempting to do this, and how do I fix it?  My radio station is effectively crippled until this is solved.

    Kind of an emergency.
  • 24 Comments sorted by
  • Vote Up0Vote Down hoerichhoerich
    Posts: 627Member, Airtime Moderator
    what does
    sudo airtime-check-system
    say?

    there's a bug with overlapping shows in calendar. is this happening to you too?
    Official Airtime Forum Manager
    --------------------------
    Most of the time an issue is located between keyboard and chair.
  • Are you using linked shows? If yes, how were you adding content to them?
  • Vote Up0Vote Down NaomiNaomi
    Posts: 228Member
    It would be great if you could post some logs, or allow us some kind of access to your radio to see what is going on in more detail.
  • That situation is now resolved - but I have a new one:  We schedule our time wall to wall (have to, because of the lack of an auto-dj function in AirTime) and end up with seven or eight blocks a day.  Nearly every day, two or more of these blocks hit the airwaves and play nothing. When we look at the contents, nearly every file (but not ALL the files) are marked as "temporarily missing or unfindable", despite the fact that the previous block may have contained some of the same files and played them without incident.

    This problem is requiring a constant daily upkeep, and even then sometimes when we fix them, they don't stay fixed.

    I'm completely mystified.

    If you'd like access to our system so that you can observe what's going on (and possibly advice me on how to fix this) please email me at kryptonradio (at) kryptonradio.com.
  • Nuts.  Happened again.

    Here's the situation:  a show is set up and populated using playlists.  The previous show stops and this show begins.
    Except that the show doesn't play.  The contents in the display panel are "pasteled" out.  As in overlaid with translucent white.  The interface does not respond to attempts to edit the current playlist for the show.

    So I cancel the show, build a new show, populate that, and the show starts.  Music!  Hurray!

    Except a few minutes into it, suddenly there are TWO playlists running, and I recognize one of them as the one that hadn't been playing earlier that I canceled!

    So I cancel the NEW show, and the two playlists being played simultaneously go back to one again, the old one, but AirTime thinks NO show is playing, even though music continues to stream. 

    The next scheduled show proceeds normally.

  • I am seeing this sometimes too. I was told (in this forum) that my fallback script was wrong - which it was not.
    @Krypton
    Just to rule something out: Have you scheduled any shows past midnight?
    No longer using Airtime or Libretime.
  • I am having the same issue were tracks are double playing. Sometimes it happens when moving tracks around during the now playing other times completely randomly does it. I usually use smart blocks to fill in large shows then try to go in and tweak them while they are playing based on the audience. If i do something as simple as delete a track suddenly I will get the double play bug.
    hoerich said:

    what does
    sudo airtime-check-system
    say?

    there's a bug with overlapping shows in calendar. is this happening to you too?



    I only use the web based GUI so I have not been able to do that but I am also having issues with overlapping shows. I deleted shows from my calender and have started rebuilding but I keep getting "cannot schedule overlapping shows."
  • Hi @Ryno @Krypton

    Can you send us a dump of your database and let us know on what day and time you were hearing double tracks at the same time. You can email it to denise.rigato at sourcefabric dot org

    Thanks :)


  • I will have to get with my guy for the db dumps. I can make it happen at almost any given time.
  • Has anyone resolved this? I am having the same problem with smart blocks.

    Thought I had things rolling until a new issue arose this morning. I had a show scheduled from 8:10 to 8:30. Everything went fine up until 8:23 when multiple files began playing at one time (2 of which are not even on the schedule) and were not part of the previous or upcoming schedule. I finally just had to delete the show. Now I see the same is happening right now with the next show. This time however, it is playing scheduled files but playing them at one time. I scheduled using dynamic smart blocks and linked shows, however, this is the first set of shows to which the other shows are linked.

    I also see that even though I cancelled the show if I click on air the show is still playing and the calendar will not allow me to schedule a new show in it's place so it's as if it is still there.

    If you need to see any logs please tell me how to get them because I have no idea.

     

    Thanks,

    Post edited by Lisa Forbes at 2013-11-30 12:00:00
  • New development. I realized that I did not delete the current show (the one that was overlapping) as I was looking at the wrong day. BUT this means the stream is not working either! It is going through the playlist but the On Air light is off and I can't start the stream.

    Airtime-check-system shows everything to be ok.

    If you look at the attached play out history you can see were 2 files were being played simultaneously at 8:21 and it looks like there has been no further play out since around 8:30 even though there is a show scheduled right now at 10:24.

    Went in and scheduled a new show, when time came for it to start...NOTHING!

     

    What's going on here?

  • This just happened to me too. This is nuts - how on earth can something not on the schedule get played? Looking at the database tables it looks like stuff that's being removed from the schedule isn't being removed from cc_schedule and show instances aren't being removed from cc_show_instances. I had to do a manual purge through stuff in an effort to preserve the work the programming guys had done on the schedule and remove what was there before.

    Hoping this is fixed in 2.5.2 too!
  • OK, I'm at a loss to explain this now. Does this issue happen to everyone and everyone just says "yep, we put up with that"?

    Look at this database dump from the cc_schedule table, screenshot attached.

    At some points there, 3 items are playing simultaneously. How does the schedule end up in such as state?


  • Here's an idea for a script I wanted to put together to sort this - if someone could advise whether it's likely to be correct that'd be great.

    The script would iterate through every item in cc_schedule (where start > now).

    It looks at the start time and end time of that item. It knows the default transition time so adds that to the start time and takes it away from the end time.

    It then looks for another item in the cc_schedule table that has a start time between those two values.

    If it finds one, it checks the instance_id of both and deletes the *lower* table entry of the two - this assumes the instance_id is simply a progressive number that identifies the scheduling rounds.

    Does that look right?
  • OK, I think I can safely declare your software of no use whatsoever.

    I wrote this script - thanks for the helpful responses, by the way - and it works great. Deletes stuff in the schedule table that should not be there.

    But this morning I'm listening to two items at the same time again - and this time ONE OF THEM IS NOT IN THE SCHEDULE TABLE.

    Post edited by Ken Rayner at 2014-06-27 15:23:22
  • Ken -- did you ever discover the root cause?
  • This is what I noticed. If you change the Title of a show - it wipes the contents. Or seems to. Sometimes you can still see it in NOW PLAYING view.
    My workaround is: If the content goes missing like that, delete the show and all following instances. That seems to stop it occuring. This bug has been logged.

    No longer using Airtime or Libretime.
  • Sweet! What's the URL in the tracker for it?
  • I've just noticed a similar occurrence. I created a repeating show for every day of the week starting at 14:00 and ending at 14:30. At first, I decided to just populate the show by hand but this quickly became tedious. So I used John Chewter's trick of making the content have the same name and linking the shows. This didn't work well because Airtime does not notice if the length of the show changes (in my case the shows vary by as much as five minutes). This is not a problem if the show is shorter than the original linked item, but the show is truncated to the original length if it is longer than the original - not okay.

    I opened the scheduler and, to my surprise, I saw TWO shows. The first was the original, unlinked show and the second was the linked show. Both of these shows were scheduled at exactly the same time. Needless to say, this should never happen. I removed all the linked shows and went back to my original, time-intensive method.

    I'm awaiting 2.5.2 with the hope that this issue will be resolved.
  • Try making an mp3 of the same duration as the show length. Call it 'latest.mp3' Import it.
    Add that to your repeating linked show.

    Now you can over-write that file with this week's show.

    It works.
    No longer using Airtime or Libretime.
  • Thatnks, John - that does indeed work. To make that "custom" mp3 I found a file that was somewhat longer, edited it, and truncated so it was exactly 30 minutes long).
  • Hi,
    I'm having the same issue, I rebooted the server with airtime running, the problem was still present... I deleted and recreated the current scheduled show but something was still playing, the only way to stop it was to delete the present show. 

    Now the next show is running and playing even if airtime says it's not...
    In calendar the show appears as populated, but in the 'now playing' tab it's empty!! 

    airtime-check-system is completely green and says that the installation looks ok...

    Any idea? At least to fix it temporarly...

  • Probably a corrupt repeating show is in the database and/or a Timezone is set up incorrectly.

    In admin, look in the Now Playing list - you will probably see the problem show/tracks. Delete them.
    No longer using Airtime or Libretime.
  • In this moment I've only few programs scheduled.
    I deleted all the scheduled shows in calendar, I'll do the programming again from a clean calendar and let's see what happens...
    In the Now Playing list it was unclear which of the shows was corrupted.