2.4 timezone question.
  • Installed 2.4 on ubuntu 12.04 everything is working great.

    I set timezone EDT as an admin in global preferences,  the time reflects perfect.

    Added test Program Manager, DJ, and Guest accounts.

    When i log in as these users the time is GMT,   don't see where i can set the default for a user.


  • 7 Comments sorted by
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    in your system/preferences
  • I set the preferences in system preferences when logged it as admin, it correctly shows.

    but logging in as any other user shows GMT.  I will restart services to see if that fixes.

  • I just rebooted server, issue still there...  the admin user shows the EDT which is set in global preferences.

    The other 3 users show GMT  PM,DJ,Guest.  Doesnt look like they have place to set preferences as users.

  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    that's pretty normal
    in a webradio, users could be everywhere , they must modify their own preferences
  • @Stephen,

    New users should get assigned the default timezone setting in System -> Preferences upon creation.

    Are there any errors in /var/log/airtime/zendphp.log at the time you set the default timezone setting?

    What is the output of:

    sudo -u postgres psql -c "select * from cc_pref where keystr = 'timezone'" airtime
  • Forgot to mention, users can edit their own preferences by clicking on their username in the top right corner, when logged into Airtime.

  • Denise

     11 |        | timezone | America/Detroit

    No errors is log...   clicking on the username did the trick for the 3 i already had created.

    i must have created those accounts prior to setting the global preference.

    I just confirmed a new added user picked up the global setting.

    so all set (user error) software fine, thanks for quick response.