× Warning! This forum is in archival status. New contributions may not work.
Media Monitor Erratic in 2.3.1
  • Vote Up0Vote Down AlexAlex
    Posts: 18Member
    I recently upgraded from 2.2 to 2.3.1 on Debian squeeze. Ever since we upgraded media monitor just stops running, even though if you ask airtime-check-system it is says its running fine with a process id. When I restart (sudo service airtime-media-monitor restart) media monitor it picks back up again and imports all the pending files. Checking /var/log/airtime/media_monitor/media_monitor.log there isn't anything weird and certainly there are no errors. 

     Has something changed with the media monitor in this version? currently I need to restart media monitor daily.

     Is anyone having similar issues? 

    Thanks
    Alex


  • 5 Comments sorted by
  • Vote Up1Vote Down Cliff WangCliff Wang
    Posts: 339Member, Sourcefabric Team
    Could you please check the rabbitmq section in both /etc/airtime/airtime.conf and /etc/airtime/media-monitor.cfg? I'm guessing the rabbitmq settings do not equal in both files.
    Cloud Radio -> http://airtime.pro
  • Vote Up0Vote Down AlexAlex
    Posts: 18Member
    Hey cliff thanks for the response. 

    They are slightly different, but not really, 127.0.0.1 should equal localhost in this case. 

    another clu
    sudo service airtime-media-monitor restart yields:
    Restarting Airtime Media Monitor: start-stop-daemon: warning: failed to kill 23563: No such process
    Done.


    media monitor.cfg :

    ############################################
    # RabbitMQ settings                        #
    ############################################
    rabbitmq_host = 'localhost'
    rabbitmq_user = 'guest'
    rabbitmq_password = 'guest'
    rabbitmq_vhost = '/'

    airtime.conf
    [rabbitmq]
    host = 127.0.0.1
    port = 5672
    user = guest
    password = guest
    vhost = /



  • I just found that on mine (2.4) it DOES matter. I changed rabbitmq_host from 'localhost' to 127.0.0.1 and the errors went went away.
    rabbitmq_host = 'localhost'
    Post edited by John Chewter at 2013-06-30 05:35:09
    No longer using Airtime or Libretime.
  • This was useful... I think. Changed so that the rabbitmq_host is 127.0.0.1 and we'll see how it goes... Thanks John!
  • I'm running 2.5.1 on Ubuntu 12.04.  I recently migrated the Ubuntu instance to KVM.  Since then, I have had to keep restarting media monitor in order for uploaded files to appear in the library.  I tried the above suggestion of setting rabbitmq_host is 127.0.0.1 and restarted, but the problem still persists.  I've included my media-monitor log file.  Thanks.