× Warning! This forum is in archival status. New contributions may not work.
Liquid soap error takes down broadcast regularly on new install of Airtime.
  • We have a physical transmitter, and on Airtime, our Liquid soap keeps crashing, and the station audio goes off air. 
    The only error I can see is the following...

    Restarting Liquidsoap: ('Error loading config file: %s', error(111, 'Connection refused'))

    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = 3.5.0-30-generic
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 3964124
    TOTAL_SWAP_MBYTES              = 4107260
    AIRTIME_VERSION                = 2.3.1
    OS                             = Ubuntu 12.04.2 LTS x86_64
    CPU                            = Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz
    WEB_SERVER                     = Apache/2.2.22 (Ubuntu)
    PLAYOUT_ENGINE_PROCESS_ID      = 985
    PLAYOUT_ENGINE_RUNNING_SECONDS = 91587
    PLAYOUT_ENGINE_MEM_PERC        = 0.4%
    PLAYOUT_ENGINE_CPU_PERC        = 0.4%
    LIQUIDSOAP_PROCESS_ID          = NOT MONITORED
    LIQUIDSOAP_RUNNING_SECONDS     = 1
    LIQUIDSOAP_MEM_PERC            = 0%
    LIQUIDSOAP_CPU_PERC            = 0%
    MEDIA_MONITOR_PROCESS_ID       = 1323
    MEDIA_MONITOR_RUNNING_SECONDS  = 91584
    MEDIA_MONITOR_MEM_PERC         = 0.0%
    MEDIA_MONITOR_CPU_PERC         = 1.7%
    -- There appears to be a problem with your Airtime installation.

    After restarting, it looks like this

    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = 3.5.0-30-generic
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 3964124
    TOTAL_SWAP_MBYTES              = 4107260
    AIRTIME_VERSION                = 2.3.1
    OS                             = Ubuntu 12.04.2 LTS x86_64
    CPU                            = Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz
    WEB_SERVER                     = Apache/2.2.22 (Ubuntu)
    PLAYOUT_ENGINE_PROCESS_ID      = 985
    PLAYOUT_ENGINE_RUNNING_SECONDS = 91687
    PLAYOUT_ENGINE_MEM_PERC        = 0.3%
    PLAYOUT_ENGINE_CPU_PERC        = 0.4%
    LIQUIDSOAP_PROCESS_ID          = 8736
    LIQUIDSOAP_RUNNING_SECONDS     = 90
    LIQUIDSOAP_MEM_PERC            = 0.7%
    LIQUIDSOAP_CPU_PERC            = 1.2%
    MEDIA_MONITOR_PROCESS_ID       = 1323
    MEDIA_MONITOR_RUNNING_SECONDS  = 91684
    MEDIA_MONITOR_MEM_PERC         = 0.0%
    MEDIA_MONITOR_CPU_PERC         = 1.9%
    -- Your installation of Airtime looks OK!
  • 32 Comments sorted by
  • Having the same issue
    When running the check we get this error

    LIQUIDSOAP_PROCESS_ID          = NOT MONITORED

    Restarting does not work

    The only "fix" is to reinstall over the original

    This is getting REAL annoying
  • Starting liquid-soap does get it going again, sometimes only for an hour, sometimes only a few minutes.

    Further info, and request for help please to the devs.

    Pypo logs are giving me this, is this my fault? 
    I'm not sure what it means or why I've got it. Is it the .m4a files the kids have recorded on the iMac?
    Can I provide any more info that will help?


    013/05/30 10:44:31 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:31 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:31 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:32 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:32 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:32 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:32 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:32 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:32 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:33 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:33 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:33 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:33 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:33 [stdout:3] 
    2013/05/30 10:44:33 [stdout:3] #########################################
    2013/05/30 10:44:33 [stdout:3] #           *** pypo  ***               #
    2013/05/30 10:44:33 [stdout:3] #     pypo notification gateway         #
    2013/05/30 10:44:33 [stdout:3] #########################################
    2013/05/30 10:44:42 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:42 [alsa_out(default):2] Trying to recover..

    Post edited by Barry Clearwater at 2013-05-29 18:56:51
  • Having the same problem.  Airtime 2.3.1 on Ubuntu 12.10.

    Are there any solutions for this?
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    how did you install airtime ?
  • Starting liquid-soap does get it going again, sometimes only for an hour, sometimes only a few minutes.

    Further info, and request for help please to the devs.

    Pypo logs are giving me this, is this my fault? 
    I'm not sure what it means or why I've got it. Is it the .m4a files the kids have recorded on the iMac?
    Can I provide any more info that will help?


    013/05/30 10:44:31 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:31 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:31 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:32 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:32 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:32 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:32 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:32 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:32 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:33 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:33 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:33 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:33 [alsa_out(default):2] Trying to recover..
    2013/05/30 10:44:33 [stdout:3] 
    2013/05/30 10:44:33 [stdout:3] #########################################
    2013/05/30 10:44:33 [stdout:3] #           *** pypo  ***               #
    2013/05/30 10:44:33 [stdout:3] #     pypo notification gateway         #
    2013/05/30 10:44:33 [stdout:3] #########################################
    2013/05/30 10:44:42 [alsa_out(default):2] Underrun!
    2013/05/30 10:44:42 [alsa_out(default):2] Trying to recover..



    HI Barry,

    This may be related to the audio driver of your machine. You could try switching to PulseAudio or AO output to see if it resolves the situation.
    Airtime Pro Hosting: http://airtime.pro
  • Larry — you might be running into an old liquidsoap memleak issue with aac. Try installing 1.1.1 on your platform.
    Post edited by Roger Wilco at 2013-06-03 14:19:16
  • Hi Albert,

    I used airtime-easy-setup 2.3.0-1 via the Ubuntu Sofware Centre.
  • Larry — can you run:

    liquidsoap --version

    from a command line and report back?
  • I'm at 1.0.1. I'll try installing 1.1.1 and get back to you. 

    Thanks guys.
  • Sorry guys, noob question...

    Could you please point me towards upgrade instructions for liquidsoap?

    thanks in advance...
  • Bingo! I'm currently running liquidsoap 1.1.1 with airtime 2.3.1 and it's cleared up 99% of my major headaches. :)
  • Sorry guys, noob question...


    Could you please point me towards upgrade instructions for liquidsoap?

    thanks in advance...


    Please find the appropriate Debian package for your OS here:



    Airtime Pro Hosting: http://airtime.pro
  • Over 20 hours without dropping connection ... Looks like we have a winner! Thanks for your help guys.
  • I'm not sure why this happened as I have the apt repository in my sources.list.d but somehow liquidsoap_1.1.1 was not being offered as an upgrade.
    Also, and I am unsure why this has not happened either, I have been checking in on my thread since I opened it, and the added comments were not showing up! Having just logged back in with a different browser, I have found the comments and manually installed liquidsoap_1.1.1

    I'll wait and see if our dropouts disappear but having ready Larry's post, I am ever hopeful.

    Thanks all
  • On Wed, Jun 12, 2013 at 7:51 PM, Barry Clearwater <<br />airtime-support@lists.sourcefabric.org> wrote:

    > I'm not sure why this happened as I have the apt repository in my
    > sources.list.d but somehow liquidsoap_1.1.1 was not being offered as an
    > upgrade.
    >

    We haven't made Liquidsoap 1.1.1 publicly available yet. It will become
    available with the final Airtime 2.4 release. For now you need to download
    it manually (as you already did).

    M


    --
    Open source radio in the cloud. Get yours now! -
    Airtime Pro Hosting: http://airtime.pro
  • We're having the same issues and will try the liquidsoap update

    Thanks
  • Probably a N00b issue but after adding the line to 
    /etc/apt/sources.list
    We get

    W: Duplicate sources.list entry http://apt.sourcefabric.org/ precise/main amd64 Packages (/var/lib/apt/lists/apt.sourcefabric.org_dists_precise_main_binary-amd64_Packages)
    W: Duplicate sources.list entry http://apt.sourcefabric.org/ precise/main i386 Packages (/var/lib/apt/lists/apt.sourcefabric.org_dists_precise_main_binary-i386_Packages)

  • Try using one or the other. If you know you have a 64bit rig, keep that line. If you're unsure, go with i386.
  • Hmmm....

    Maybe I'm not tracking...
    I edited
    /etc/apt/sources.list

    and added the line

    deb http://apt.sourcefabric.org/ precise main

    as it states here

    http://apt.sourcefabric.org/misc/liquidsoap_1.1.1/

    Then ran

    sudo apt-get update
    sudo apt-get install sourcefabric-keyring

    If I remove the line, the error goes away


  • You can't download files from the misc folder via apt-get. Those are made
    to be manually downloaded and installed. We will make Liquidsoap 1.1.1
    available via apt-get soon.
    On Jun 16, 2013 2:01 PM, "Bob Zurunclε" <<br />airtime-support@lists.sourcefabric.org> wrote:

    > Hmmm....
    >
    > Maybe I'm not tracking...
    > I edited
    >
    > /etc/apt/sources.list
    >
    > and added the line
    >
    > deb http://apt.sourcefabric.org/ precise main
    >
    > as it states here
    >
    > http://apt.sourcefabric.org/misc/liquidsoap_1.1.1/
    >
    > Then ran
    >
    > sudo apt-get update
    > sudo apt-get install sourcefabric-keyring
    >
    > If I remove the line, the error goes away
    >
    >
    >
    Airtime Pro Hosting: http://airtime.pro
  • OK... Why do the instructions state differently?

    http://apt.sourcefabric.org/misc/liquidsoap_1.1.1/

    I ended up

    wget http://apt.sourcefabric.org/misc/liquidsoap_1.1.1 # for my needs

    Then used gdebi to install

    We're now running liquidsoap 1.1.1

    We'll see if it keeps crashing from here

    Thanks
  • It's been over 24 hours and no airtime crashes...
    Yea!

    Liquidsoap was apparently the issue
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    thanks to mark this thread as solved ;-)
  • Noo not too soon,I still get crash on a bad file or webstream,try locate in your logfile and test again mine still crash in 4 hours. I have had 5 days without using the streams or bad file but saw something in liquidsoap documentation but want to confirm with others as I try to understand the airtime ls_script
    Post edited by Voisses Tech at 2013-06-19 17:22:42
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • What's a "bad file" ? Liquidsoap 1.1.1 has been rock solid for me along with Airtime 2.3.1 + Debian 7.
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    send your log file
  • My post here explains this better

    http://forum.sourcefabric.org/discussion/15576/bitratesencoders-and-music-could-this-be-the-reason-liquidsoap-to-crash-and-take-down-airtime.

    No Logs available
    I use this as test machine sorry up to yesterday 06192013,the machine was up ,I cleared it to do some more testing and a clean install. Never saw anything in the log except MAD Answer to MP3 tags error.

    This machine was used last sunday and this sunday for my 6hour show with all the changes,I now implement that on the remote machine after upgrading to liquidsoap 1.1.11 The remote machine has been up 7days now without any error.
    Post edited by Voisses Tech at 2013-06-20 08:13:19
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    then, the problem is solved ?
    if, it's the case, thanks to close this thread with a [SOLVED] in the subject
  • For me, the "bad" was running liquidsoap 1.0.1 with Airtime 2.3.1

    That seems to be the reason why Airtime kept crashing and throwing the error

    LIQUIDSOAP_PROCESS_ID          = NOT MONITORED


  • Bob Zurunclε

    I think we could safely by going to the first postmarked this as solved

    I still feel a little "tick" that where stream rates (kbps) differs from bit-rates on multiple stream (both shoutcast and Icecast streaming at the same time) you might have a little problem,but I cannot give any certainty on this  so i am moving  my thread  at  http://forum.sourcefabric.org/discussion/15576/bitratesencoders-and-music-could-this-be-the-reason-liquidsoap-to-crash-and-take-down-airtime to development and do some more testing. but for others reading this thread with a single stream out,you could mark it as solved .

    Post edited by Voisses Tech at 2013-06-20 16:12:30
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Vote Up0Vote Down hoerichhoerich
    Posts: 627Member, Airtime Moderator
    I also got no probs after upgrading LS to 1.1.11
    Official Airtime Forum Manager
    --------------------------
    Most of the time an issue is located between keyboard and chair.
  • Yup.. LS 1.1.11 took care of the issues regarding going offline and throwing the error

    LIQUIDSOAP_PROCESS_ID          = NOT MONITORED