Booktype is very slow : is it normal ?
  • I have a server with an atom. And it's very slow to create a chapter or a section, to save the datas,... Some minutes sometimes...
    Has someone a idea ?
    It's a postgresql and apache installation.
    htop shows a high activity with redis and with Apache.

    Thanks for all helps...
  • 5 Comments sorted by
  • Hi! 

    It should not be so slow. Was it always so slow or it become slow over time?

    What you should check is your redis settings. You really don't need to save memory dump to disk, or if you do want that you should not save it so often. So in /etc/redis/redis.conf you should either remove all "save" lines (to disable the save) or increase the time and number of keys couple of times. If you are saving data to disk then check your "appendfsync" configuration and set it to "no". What could happen is that redis is full of undeleted messages and is wasting too much RAM or something. Try to remove "/var/lib/redis/dump.rdb" file and restart redis-server. There is a distributed lock saved inside of redis database, so it might be that your request is waiting for the lock to be unreleased. Not that it is happening everyday but that could easily happen if something else is slowing the system.

  • Hi

    It's better now with : remove "/var/lib/redis/dump.rdb" file and restart redis-server. I tried but without restart redis-server then it was not good.
    I'll try the other answers.
    I began a video club with my students (14 years old) a week ago and I use booktype.
    They are very surprised by the collaborative work.
    I'll write here news in a few weeks.

  • Hi! It happens in certain situations but not that often at all. We do have in roadmap one task to clean this up from time to time in Redis but not sure when it will be. Until then when it gets very very slow just delete the dump (or disable the save in redis).

    Looking forward to hear about your experience with your students!
  • Sounds like a great project!
  • Ah.... ignore this. I thought I was answering to private e-mail :)
    Post edited by Aleksandar Erkalović at 2013-01-22 11:29:40