× Warning! This forum is in archival status. New contributions may not work.
Default playlist on airtime
  • Hi,
    I know this has been asked before, and people have had it working in the past, but I am having no luck in getting liquidsoap to play a random playlist from a directory. I am running airtime 2.2 on Ubuntu server 12.04. I am looking to use airtime as a playout system for our local community radio station and its looking promising, except that in the event of there being nothing in the schedule and nothing on any of the other input streams I need a random playlist to go out. We face the prospect of a fine or broadcast licence being taken away if there is dead air.

    I hashed out the 2 'default = ' lines in ls_script.liq and replaced them with default=playlist(mode='random',"/srv/airtime/stor") , but it doesn't work - all there is is silence. In previous versions of airtime (according to the forums) it seems to have been working.

    Has something been changed in the code in 2.2 that causes this mod to stop working?
    Steve

    Post edited by Steve Franklin at 2012-11-11 18:53:23
  • 9 Comments sorted by
  • Have you tried using a third party way of doing this ?

    Just install a streaming client that can read the contents of a folder, then get that to stream to your master source, it's a work around until the feature is fixed ;)
  • I always thought  it was mode='randomize'?
  • mode=randomize doesn't work either. I could use a separate stream, but I know that people have had this working and so is a bit frustrating. :)
  • I've got the same OS and version installed and it works for me. The hack I use is a bit more complex....

    jingles1 = playlist(mode='randomize',reload=1,reload_mode="rounds", "/Music/jingles1/")
    freshout = playlist(mode='randomize',reload=1,reload_mode="rounds", "/Music/2013/")
    shouts = playlist(mode='randomize',reload=1,reload_mode="rounds", "/Music/shouts/")
    music = playlist(mode='randomize',reload=1,reload_mode="rounds", "/Music/All/")
    jingles = playlist(mode='randomize',reload=1,reload_mode="rounds", "/Music/samples/")
    podcasts = playlist(mode='randomize',reload=1,reload_mode="rounds", "/Music/podcasts/")
    News = playlist("/Music/News/")

    default = rotate(weights=[1,10,1,10,1,1,1,15], [jingles, music, shouts, music, podcasts, News, jingles1, freshout])

    def crossfade(s)
      s = fade.in(type="log", duration=0., s)
      s = fade.out(type="log", duration=0., s)
      fader = fun (a,b) -> add(normalize=false,[b,a])
      cross(fader,s)
    end

    ignore(output.dummy(default, fallible=true))

    Post edited by MinistryofSoca at 2012-11-13 14:28:44
  • still the same I'm sorry to say. I'm running version 2.2 Are you running version an earlier version?
    Post edited by Steve Franklin at 2012-11-14 21:25:33
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    no, that's working on 2.2 installations

    but not this crossfade code, erase it
  • Steve....

    Once you apply the settings...make sure to restart your liquidsoap and airtime services after the change otherwise its no go.

    I had to use "randomize" for mine to work on 2.2.1
  • I've been trying to get this working - no go. I edited ls_script.lq and restarted airtime-liquidsoap - silence. if I restart just liquidsoap service, I get error 

    Stopping liquidsoap channels: no script found in /etc/liquidsoap
    Starting liquidsoap channels: no script found in /etc/liquidsoap

    Hmm... Ubuntu 12.04 and latest Airtime - what am I missing?
  • Would you mind posting the lines you added?