× Warning! This forum is in archival status. New contributions may not work.
Airtime Install Error!
  • I running ubuntu server and attempting to install airtime 2.03.  I'm getting an error message that a non UTF-8 default locale found.  I confirmed the required file is present and run the reconfigure command but get the same message when running install again.
  • 28 Comments sorted by
  • Please post the contents of the "file". It should specify the system locale as UTF-8.
    Airtime Pro Hosting: http://airtime.pro
  • I decided to do a clean install.  Now I'm stuck with the following:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Building data structures... Done
    Building data structures... Done
    This package is uninstallable
    Dependency is not satisfiable: libmp3lame0
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    apt-get install libmp3lame0*
  • I get this:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libmp3lame0 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package libmp3lame0 has no installation candidate
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    apt-cache search lame
  • Did that. Rebooted. Same error
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    your distribution is ?
    have you actived the universe/non free/sourcefabric repositories ?
  • running ubuntu 10.04. I'll check on activating the repositories.
  • I upgraded ubuntu to 12.04 then tried the install.  I get the original error: non UTF-8 default locale found.  The attached file was added but I still get the error after I reconfigure locales.
    18B
  • little help please?  I haven't gotten any response in several weeks.

    thanks
  • Hi David,

    Sorry, this was lost in a sea of forum posts :)

    Let's take this from the beginning again. First please post the output of 

    less /etc/default/locale

    Second, please post the exact error message you see when you are trying to install.
    Airtime Pro Hosting: http://airtime.pro
  • 1.here's the contents of the file:  #  File generated by update-locale

    2. The install errors are as follows:

    * Making sure /etc/default/locale is set properly
     * Fail

    A non UTF-8 default locale found in /etc/default/locale. Airtime requires
    a UTF-8 locale to run. To fix this please do the following:

    Ubuntu:
    Put line 'en_US.UTF-8 UTF-8' (or similar) without quotes to '/var/lib/locales/supported.d/local',
    replacing any existing lines.
    A list of supported locales is available in '/usr/share/i18n/SUPPORTED'
    Then run 'sudo dpkg-reconfigure locales'

    Debian:
    Run 'sudo dpkg-reconfigure locales' and use the interface to select 'en_US.UTF-8 UTF-8' (or similar).
    On the second page select this new locale as the default.

    After these changes have been made simply run install again.

    Now exiting install...

    dpkg: error processing airtime (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
  • Ok so #1 is your problem. You need to have a line in there that specifies the locale (this is how debian/ubuntu work). For example, here is my /etc/default/locale

    #  File generated by update-locale
    LANG="en_CA.UTF-8"
    LANGUAGE="en_CA:en"

    What is the contents of the file /var/lib/locales/supported.d/local
    ?



    Airtime Pro Hosting: http://airtime.pro
  • Here's what I see:
    en_US.UTF-8 UTF-8
  • So if you run 

    "sudo dpkg-reconfigure locales", then "en_US.UTF-8 UTF-8" doesn't appear in /etc/default/locale????

    Please try this one more time.
    Airtime Pro Hosting: http://airtime.pro
  • Try this 

    apt-get  install locales language-env

    dpkg-reconfigure locales and select en_US.UTF-8 with space key you need to mark it with "*"

    then

    type /usr/sbin/locale-gen

    then type

    export LANG="en_US.UTF-8"

    optionally reboot

    this worked for me
    Post edited by Topea at 2012-11-02 18:47:11
  • Reply to @Martin+Konecny:
    When I run sudo dpkg-reconfigure locales I get

    Generating locales...
      en_US.UTF-8... up-to-date
    Generation complete.

  • Reply to @Topea:

    I believe the UI where you need to mark with "*" is only in Debian. Ubuntu does it differently unfortunately.
    Airtime Pro Hosting: http://airtime.pro
  • Reply to @David+Pittman:

    Ok, so is /etc/default/locale still empty? Sorry for making you redo all these steps, I just want to cover all the bases.
    Airtime Pro Hosting: http://airtime.pro
  • I ran install again and got this:

     Unfortunately your postgresql database has not been created using a UTF-8 encoding.
     * As of Airtime 2.1, installs will fail unless the encoding has been set to UTF-8. Please verify this is the case
     * and try the install again
    There was an error during install. Exit code 1
    dpkg: error processing airtime (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     airtime

  • Reply to @Martin+Konecny:
    Only line in the file is:
    #  File generated by update-locale
    LANG=en_US.UTF-8

  • Ok so we're making progress.

    Do the following steps:

    sudo apt-get purge postgresql
    reboot the system (**important**)
    sudo apt-get install postgresql

    Your system should now be properly configured and Airtime will install.





    Airtime Pro Hosting: http://airtime.pro
  • I did everything and thought it was working until I saw this:


    * Giving Apache permission to access /srv/airtime/stor/organize
    * Checking database for correct encoding
     * Unfortunately your postgresql database has not been created using a UTF-8 encoding.
     * As of Airtime 2.1, installs will fail unless the encoding has been set to UTF-8. Please verify this is the case
     * and try the install again
    There was an error during install. Exit code 1
    dpkg: error processing airtime (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     airtime
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  • I got the same issue, tried all the things you followed here but nothing helps :(

    Any ideas?
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    be more specific
    send yours logfiles from /var/log/airtime

  • * Making sure /etc/default/locale is set properly
    * Fail

    A non UTF-8 default locale found in /etc/default/locale. Airtime requires
    a UTF-8 locale to run. To fix this please do the following:

    Ubuntu:
    Put line 'en_US.UTF-8 UTF-8' (or similar) without quotes to '/var/lib/locales/supported.d/local',
    replacing any existing lines.
    A list of supported locales is available in '/usr/share/i18n/SUPPORTED'
    Then run 'sudo dpkg-reconfigure locales'

    Debian:
    Run 'sudo dpkg-reconfigure locales' and use the interface to select 'en_US.UTF-8 UTF-8' (or similar).
    On the second page select this new locale as the default.

    After these changes have been made simply run install again.

    Now exiting install...

    dpkg: error processing airtime (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    airtime
    E: Sub-process /usr/bin/dpkg returned an error code (1)
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    did you reconfigure locales as asked ?
    after this, have desintalled postgres and reinstalled it ?
    and after all this did you do an

    apt-get install airtime
    or an apt-get upgrade or apt-get dist-upgrade ?
  • same thing happened again :(


    Liquidsoap symlink points to the right place!
    * Making sure /etc/default/locale is set properly
    * Fail

    A non UTF-8 default locale found in /etc/default/locale. Airtime requires
    a UTF-8 locale to run. To fix this please do the following:

    Ubuntu:
    Put line 'en_US.UTF-8 UTF-8' (or similar) without quotes to '/var/lib/locales/supported.d/local',
    replacing any existing lines.
    A list of supported locales is available in '/usr/share/i18n/SUPPORTED'
    Then run 'sudo dpkg-reconfigure locales'

    Debian:
    Run 'sudo dpkg-reconfigure locales' and use the interface to select 'en_US.UTF-8 UTF-8' (or similar).
    On the second page select this new locale as the default.

    After these changes have been made simply run install again.

    Now exiting install...

    dpkg: error processing airtime (--configure):
    subprocess installed post-installation script returned error exit status 1
    Setting up libapt-inst1.4 (0.8.16~exp12ubuntu10.5) ...
    Setting up libparted0debian1 (2.3-8ubuntu5.1) ...
    Setting up libqtcore4:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-xml:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-dbus:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-script:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-network:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-sql:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-xmlpatterns:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-test:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libxcb-shape0 (1.8.1-1ubuntu0.1) ...
    Setting up mktemp (8.13-3ubuntu3.1) ...
    Setting up rpcbind (0.2.0-7ubuntu1.2) ...
    Installing new version of config file /etc/init/portmap-wait.conf ...
    Setting up libglu1-mesa:i386 (8.0.4-0ubuntu0.2) ...
    Setting up apt-utils (0.8.16~exp12ubuntu10.5) ...
    Setting up lsb-release (4.0-0ubuntu20.2) ...
    Setting up udev (175-0ubuntu9.2) ...
    udev stop/waiting
    udev start/running, process 11063
    Removing 'diversion of /sbin/udevadm to /sbin/udevadm.upgrade by fake-udev'
    update-initramfs: deferring update (trigger activated)
    Setting up libisc83 (1:9.8.1.dfsg.P1-4ubuntu0.4) ...
    Setting up libdns81 (1:9.8.1.dfsg.P1-4ubuntu0.4) ...
    Setting up libisccc80 (1:9.8.1.dfsg.P1-4ubuntu0.4) ...
    Setting up libisccfg82 (1:9.8.1.dfsg.P1-4ubuntu0.4) ...
    Setting up libbind9-80 (1:9.8.1.dfsg.P1-4ubuntu0.4) ...
    Setting up liblwres80 (1:9.8.1.dfsg.P1-4ubuntu0.4) ...
    Setting up bind9utils (1:9.8.1.dfsg.P1-4ubuntu0.4) ...
    Setting up bind9 (1:9.8.1.dfsg.P1-4ubuntu0.4) ...
    * Starting domain name service... bind9 [ OK ]
    Setting up bind9-host (1:9.8.1.dfsg.P1-4ubuntu0.4) ...
    Setting up dbus (1.4.18-1ubuntu1.3) ...
    Setting up apache2-doc (2.2.22-1ubuntu1.2) ...
    * Reloading web server config apache2 [ OK ]
    Setting up dbus-x11 (1.4.18-1ubuntu1.3) ...
    Setting up x11-utils (7.6+4ubuntu0.1) ...
    Setting up gvfs-daemons (1.12.1-0ubuntu1.1) ...
    Setting up gvfs:i386 (1.12.1-0ubuntu1.1) ...
    Setting up libgssglue1 (0.3-4ubuntu0.1) ...
    Setting up quota (4.00-3ubuntu1) ...
    Setting up libqt4-declarative:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqtgui4:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-designer:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-qt3support:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-scripttools:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-opengl:i386 (4:4.8.1-0ubuntu4.3) ...
    Setting up libqt4-svg:i386 (4:4.8.1-0ubuntu4.3) ...
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    Processing triggers for initramfs-tools ...
    Errors were encountered while processing:
    airtime
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@server:~#


    I don't know what else to do.... any ideas? 
    Thanks for your help already :)