[SOLVED] Newscoop on shared host - missing kqw9j.php [SOLVED]
  • Hi

    I have tried installing Newscoop onto two different shared webhosts:
    Servage.net and

    In both of these instances the Newscoop installer finishes successfully and I get redirected to the admin interface which works fine.
    However the problem is that when I try to watch the "live site", it crashes fatally and prints php errors onto the screen mentioning Zend.

    Mainly it seems this is the culprit (full error paste below):
     include_once(doctrine/orm/query/kqw9j.php) [function.include-once]: failed to open stream: No such file or directory

    I know that the Greengeeks.com shared offering has "Zend", but it isn't working.
    I have finecombed the Wiki and elsewhere, to look for any clues regarding this. A suggestion would be to have the Installer *check* for Zend requirements and test it. Now the installer says everything is okay, when it really isn't!

    Here is the error I get when I log into the Admin pane (but the dropdown menus and settings are functional):

    D del error:2:Newscoop:4.0.2:Loader.php:146
    String de error:include_once(doctrine/orm/query/kqw9j.php) [function.include-once]: failed to open stream: No such file or directory
    Hora:Sun, 19 Aug 2012 15:48:14 -0500

    This is the error I get when trying to load up the index page in Newscoop
    Error ID:2:Newscoop:4.0.2:Loader.php:146
    Error String:include_once(doctrine/orm/query/kqw9j.php) [function.include-once]: failed to open stream: No such file or directory
    Time:Sun, 19 Aug 2012 15:52:19 -0500
    {closure}() called at [/home/aftensto/public_html/newscoop/library/Zend/Loader.php:146]
    Zend_Loader::loadFile() called at [/home/aftensto/public_html/newscoop/library/Zend/Loader.php:146]
    Zend_Loader::loadFile() called at [/home/aftensto/public_html/newscoop/library/Zend/Loader.php:94]
    Zend_Loader::loadClass() called at [:]
    call_user_func() called at [/home/aftensto/public_html/newscoop/library/Zend/Loader/Autoloader.php:472]
    Zend_Loader_Autoloader::_autoload() called at [:]
    call_user_func() called at [/home/aftensto/public_html/newscoop/library/Zend/Loader/Autoloader.php:124]
    Zend_Loader_Autoloader::autoload() called at [:]
    spl_autoload_call() called at [:]
    defined() called at [/home/aftensto/public_html/newscoop/library/Doctrine/ORM/Query/Lexer.php:161]
    Doctrine\ORM\Query\Lexer::getType() called at [/home/aftensto/public_html/newscoop/library/Doctrine/Common/Lexer.php:214]
    Doctrine\Common\Lexer::scan() called at [/home/aftensto/public_html/newscoop/library/Doctrine/Common/Lexer.php:70]
    Doctrine\Common\Lexer::setInput() called at [/home/aftensto/public_html/newscoop/library/Doctrine/ORM/Query/Lexer.php:117]
    Doctrine\ORM\Query\Lexer::__construct() called at [/home/aftensto/public_html/newscoop/library/Doctrine/ORM/Query/Parser.php:145]
    Doctrine\ORM\Query\Parser::__construct() called at [/home/aftensto/public_html/newscoop/library/Doctrine/ORM/Query.php:212]
    Doctrine\ORM\Query::_parse() called at [/home/aftensto/public_html/newscoop/library/Doctrine/ORM/Query.php:234]
    Doctrine\ORM\Query::_doExecute() called at [/home/aftensto/public_html/newscoop/library/Doctrine/ORM/AbstractQuery.php:607]
    Doctrine\ORM\AbstractQuery::execute() called at [/home/aftensto/public_html/newscoop/library/Doctrine/ORM/AbstractQuery.php:413]
    Doctrine\ORM\AbstractQuery::getResult() called at [/home/aftensto/public_html/newscoop/library/Newscoop/Service/Implementation/TemplateSearchServiceDoctrine.php:140]
    Newscoop\Service\Implementation\TemplateSearchServiceDoctrine::getFrontPage() called at [/home/aftensto/public_html/newscoop/template_engine/classes/CampSystem.php:340]
    CampSystem::GetIssueTemplate() called at [/home/aftensto/public_html/newscoop/template_engine/classes/CampSystem.php:296]
    CampSystem::GetTemplate() called at [/home/aftensto/public_html/newscoop/template_engine/classes/CampURI.php:672]
    CampURI::getTemplate() called at [/home/aftensto/public_html/newscoop/template_engine/classes/CampURIShortNames.php:335]
    CampURIShortNames::_getTemplate() called at [/home/aftensto/public_html/newscoop/template_engine/classes/CampURIShortNames.php:389]
    CampURIShortNames::setURL() called at [/home/aftensto/public_html/newscoop/template_engine/classes/CampURIShortNames.php:60]
    CampURIShortNames::__construct() called at [/home/aftensto/public_html/newscoop/template_engine/classes/CampSite.php:263]
    CampSite::GetURIInstance() called at [/home/aftensto/public_html/newscoop/application/controllers/helpers/Smarty.php:35]
    Action_Helper_Smarty::preDispatch() called at [/home/aftensto/public_html/newscoop/library/Zend/Controller/Action/HelperBroker.php:265]
    Zend_Controller_Action_HelperBroker::notifyPreDispatch() called at [/home/aftensto/public_html/newscoop/library/Zend/Controller/Action.php:500]
    Zend_Controller_Action::dispatch() called at [/home/aftensto/public_html/newscoop/library/Zend/Controller/Dispatcher/Standard.php:295]
    Zend_Controller_Dispatcher_Standard::dispatch() called at [/home/aftensto/public_html/newscoop/library/Zend/Controller/Front.php:954]
    Zend_Controller_Front::dispatch() called at [/home/aftensto/public_html/newscoop/library/Zend/Application/Bootstrap/Bootstrap.php:97]
    Zend_Application_Bootstrap_Bootstrap::run() called at [/home/aftensto/public_html/newscoop/library/Zend/Application.php:366]
    Zend_Application::run() called at [/home/aftensto/public_html/newscoop/public/index.php:5]
    require_once() called at [/home/aftensto/public_html/newscoop/index.php:12]

    Post edited by Jobe Lawn at 2012-08-20 03:33:32
  • 7 Comments sorted by
  • Could it be related to Zendguard?

    see the last posts
  • Vote Up0Vote Down Sava TatićSava Tatić
    Posts: 113Member, Administrator, Sourcefabric Team
    Zendguard is bad for Newscoop. Check this forum for more details.
    On Aug 19, 2012 5:22 PM, "Jobe Lawn" <<br />newscoop-support@lists.sourcefabric.org> wrote:

    > Could it be related to Zendguard?
    > see the last posts
    > https://github.com/ccapndave/flextrine/issues/18
  • My hosting doesn't have Zendguard, I found out after asking support.
    Newscoop v3.5.5 works fine actually... But I am still trying to figure out how I can make 4.x.x run!

    I tried putting this in .htaccess 
    php_value zend_optimizer.optimization_level = 0 
    (which is supposed to disable Zendguard - but it only results in 500 Errors, so PHP doesn't understand it because it doesn't have Zendguard)

    I have seen many posts on this, but I have never seen it resolved, but surely it could be possible to do it!

    Okay I think I have made some progress in trying to solve this:
    The PHP error gives this quite clear error message: 
    include_once(doctrine/orm/query/kqw9j.php) [function.include-once]: failed to open stream: No such file or directory

    It really is very clear what the problem is - the file newscoop/Library/orm/query/kqw9j.php is missing! 
    I have searched through the entire Newscoop folder to look for this file and it doesn't exist.
    I have downloaded the latest DOCTRINE ORM package, and the file does not exist their either!
    What's the story here. What is this kqw9j.php file???

    Also I have noticed something weird which is inconsistent with Unix logic, the files in /Library are all in MixEd CaSe Letters. Yet that PHP error message is all lowercase. Maybe it's as simple as that!
    Yet, the elusive kqw9j.php is still missing from the face of the earth.

    Is this resolved in the dev-version of Newscoop? Maybe I should get it from GIT?
    Post edited by Jobe Lawn at 2012-08-20 03:28:06
  • Yes!!! I managed to solve it.

    The problem was what I indicated, the names which had MixED cAsE in their physical folders, but the code was looking for all lowercase.

    I simply did this to fix the problem:
    cd newscoop-4.0.2
    cd library
    mkdir -p doctrine/orm/query
    cd doctrine/orm/query
    touch kqw9j.php

    And all errors were gone!!!

    Post edited by Jobe Lawn at 2012-08-20 12:56:20
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    Thank you!
  • Hello,
    I have the same problem
    Please tell me How did you do that?
    I have a cPanel
    Thank you!
  • I did it! I just made a directory with the same path but using lowcase. I was easy.