× Warning! This forum is in archival status. New contributions may not work.
New Install
  • I have downloaded and extracted the files out to a folder on my server /var/www/newscoop. I have set the permissions on the folders as specified. When I browse to the url I am using for the install, I get a 500 error for http://www.mydomain.com/install

    Any ideas? I have all the dependencies already on the server since I am hosting almost 30 sites on it already. Not sure what else may need to be done. It picks up the favicon but thats about it.
  • 20 Comments sorted by
  • Anyone want to take a guess?

    The website encountered an error while retrieving http://www.mydomain.com/install/. It may be down for maintenance or configured incorrectly.

    Here are some suggestions:

    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.
  • Permissions or Ownership, ensure httpd is in the correct group/users which is part of /var/www/newscoop It is one of these two issues. 

    I am not sure why they wrote the documentation the way they did, you can install the script inside any virtual directory, /var/www/newscoop is only an example. If you have have virtual host directives you can install it anywhere you like. 

    /home/www/mydomain.com

    /var/domains/mydomain.com the directive does not need to be newscoop ( confused why this is made out to be such an issue ) 

    In short, it does not need it's own specific virtual host container as the documentation makes it sound, any virtualhost container works just fine. 
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team

    I get a 500 error for http://www.mydomain.com/install



    it means that there is a php error. Check apache error log file for this.
  • Reply to @Rick+Wilson:

    Thanks for pointing this out Rick, we will check it out.

    All Best,
  • Thank you Holman and the rest of the team for all your hard work, all of you are appreciated. 
  • I have decided to come back and try newscoop again but to no avail, I get a 404 error on the install page. I have copied the files directly into my folder on my webserver but just cannot get it to install. I think I will redownload the files and reupload and see what happens from there.
  • Update...I am now trying to install it on Godaddy deluxe hosting account and getting the same 500 error for www.mydomain.com/install

    Any ideas is appreciated.
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    I recommend using vps/vds instead of shared hosting
  • The first time I tried installing it was on a dedicated server...second attempt was on Godaddy Shared hosting server.

     

    Any other suggestions? Getting a 500 error right now. No other CMSes do I have trouble with. I have over 30 sites now on my dedicated servers...ranging from streaming media, to social networking, to WP, Concrete5, Kaltura, Joomla...etc. You name it...its on here.

  • Vote Up0Vote Down Sava TatićSava Tatić
    Posts: 113Member, Administrator, Sourcefabric Team
    What was the issue on your dedicated server? What distro/OS were you
    running there?

    All the best,

    Sava

    On Tue, Sep 11, 2012 at 11:24 PM, Jeremy Monroe <<br />newscoop-support@lists.sourcefabric.org> wrote:

    > The first time I tried installing it was on a dedicated server...second
    > attempt was on Godaddy Shared hosting server.
    >
    >
    >
    > Any other suggestions? Getting a 500 error right now. No other CMSes do I
    > have trouble with. I have over 30 sites now on my dedicated
    > servers...ranging from streaming media, to social networking, to WP,
    > Concrete5, Kaltura, Joomla...etc. You name it...its on here.
    >
    >
  • 500 Error on mydomain.com/install    My dedicated server is running Ubuntu 10.10 server. I have Apach2 and Php 5.3 on it and MySQL. If you need specfic versions I can get that. I have xcache installed and all the other dependencies that the manual states needing to have.
    Post edited by Jeremy Monroe at 2012-09-11 17:39:56
  • Does anyone else have any ideas? It's not the permissions...nor dependencies. In fact, I have another Symfony site running on my server already.
  • hi,

    try to add in your .htaccess file this:

    SetEnv APPLICATION_ENV "development"

    that might show you some error message

  • I have tried as you suggested. I get the same error...500 error. Nothing else. If you go to http://www.flipware.info/app_dev.php you will see that I have a symfony app setup on the same server and it works fine.
    Post edited by Jeremy Monroe at 2012-09-12 09:27:33
  • That's on the browser I guess, what about server (apache) logs?
  • @Holman+Romero
    [Wed Sep 12 07:54:31 2012] [error] [client xx.xx.xx.xx] PHP Fatal error:  require_once(): Failed opening required 'smarty/libs/Smarty.class.php' (include_path='/var/www/newscoop4/classes:/var/www/newscoop4/classes/Extension:/var/www/newscoop4/template_engine/classes:/var/www/newscoop4/template_engine/metaclasses:/var/www/newscoop4/application/../library:/var/www/newscoop4/library:/var/www/newscoop4/include:.:/usr/share/php:/usr/share/pear') in /var/www/newscoop4/install/classes/CampTemplate.php on line 13
    [Wed Sep 12 07:54:31 2012] [error] [client xx.xx.xx.xx] PHP Fatal error:  require_once(): Failed opening required 'smarty/libs/Smarty.class.php' (include_path='/var/www/newscoop4/classes:/var/www/newscoop4/classes/Extension:/var/www/newscoop4/template_engine/classes:/var/www/newscoop4/template_engine/metaclasses:/var/www/newscoop4/application/../library:/var/www/newscoop4/library:/var/www/newscoop4/include:.:/usr/share/php:/usr/share/pear') in /var/www/newscoop4/install/classes/CampTemplate.php on line 13

    Post edited by Jeremy Monroe at 2012-09-12 12:38:30
  • I am currently installing it on my recursive server I use as a back up in case my primary goes down...so far its installing...just put in the credentials....lets see what happens.

    I got all of this information....

    Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/universe wwwconfig-common all 0.2.2 [18.0 kB]
    Get:2 http://apt.sourcefabric.org/ maverick/main newscoop all 4.0.2-1 [68.5 MB]
    Fetched 68.6 MB in 1min 27s (783 kB/s)
    Preconfiguring packages ...
    Selecting previously unselected package wwwconfig-common.
    (Reading database ... 296100 files and directories currently installed.)
    Unpacking wwwconfig-common (from .../wwwconfig-common_0.2.2_all.deb) ...
    Selecting previously unselected package newscoop.
    Unpacking newscoop (from .../newscoop_4.0.2-1_all.deb) ...
    Setting up wwwconfig-common (0.2.2) ...
    Setting up newscoop (4.0.2-1) ...

    Please open a browser at http://www.mydomain.com/ to complete Newscoop installation.


    And I get an error. The website encountered an error while retrieving http://www.mydomain.com/install. It may be down or configured incorrectly.

    Http Error 500......same thing as before.
    Post edited by Jeremy Monroe at 2012-09-12 13:04:27
  • I am looking around and it installed all the main files to var/lib/newscoop and there is some vhost and conf files in etc/newscoop/4.0.

    Contains apache.conf which Alias /newscoop /var/lib/newscoop
    Contains apache.vhost.tpl, newscoop.cron.tpl and newscoop.ini

    Since I am running apache 2....all of my sites are under /var/www/....
    Post edited by Jeremy Monroe at 2012-09-12 13:16:15
  • I now have the web based installation page. I checked my Apache server and noticed it created another virtual host...so I left the one it created and deleted the vhost entry I manually made. Says all system requirements are met...so here we go.....

    Let's see if I can finally get this finished.
    Post edited by Jeremy Monroe at 2012-09-12 13:30:17
  • Success! image