× Warning! This forum is in archival status. New contributions may not work.
Airtime 2.1.2 Broken After Upgrade from 2.1.1 - Cannot Connect To Streaming Server
  • Hello All!

    We just upgraded to 2.1.2 and now we cannot connect to the streaming server under  system>>streams

    The password and user were as before

    Any suggestions?
    Post edited by Bob Zurunclε at 2012-06-27 17:53:11
  • 11 Comments sorted by
  • Hi,

    Are you using the tarball or deb package? This must be an install issue as the changes between 2.1.1 and 2.1.2 are *very* minor.

    If this is the debian package, can you check if your icecast configuration settings (/etc/icecast2/icecast.xml) are as you expect them?
    Airtime Pro Hosting: http://airtime.pro
  • tarball...

    The icecast.xml looks as it should be

    I did the same thing going from 2.1.1 to 2.1.2 as I did migrating to 2.1.1

    sudo tar -xvzf airtime-2.1.2.tar.gz -C ~/
    sudo ~/airtime-2.1.2/install_full/ubuntu/airtime-full-install -r
    # Dumps data to avoid error on restore
    sudo -u postgres dropdb airtime
    # Restores database
    sudo -u postgres psql -f airtime-backup.2.1.1.full postgres

    I could try the deb package and see if it works

    Do you have the link to the deb package?





    Post edited by Bob Zurunclε at 2012-06-27 18:52:24
  • No don't do that. What is the error under the stream page?

    Is the icecast server remote, or on a local machine?
    Airtime Pro Hosting: http://airtime.pro
  • Cannot connect to streaming server (see attached)

    Local machine

    603 x 78 - 3K
  • What's real odd is I added a scheduled show and all is streaming properly to the web despite the problems
  • Were you able to duplicate this?
    Post edited by Bob Zurunclε at 2012-06-28 09:12:26
  • Hello?
  • Hi Bob,

    Can you confirm user/pass on icecast.xml and /etc/airtime/liquidsoap.log is same(eg. s1_user and s1_pass, assuming the screen shot is for stream1)?

    Thank you.
  • I believe you mean /etc/airtime/liquidsoap.cfg

    They are the same


  • One more tidbit.
    I tried using stream 2 with the exact information and turned off stream 1
    Stream 2 works!
    1102 x 787 - 63K
    Post edited by Bob Zurunclε at 2012-06-30 10:59:02
  • Reply to @Bob+Zurunclε:

    And when you switch back to stream 1 again it is still red?

    If you do 

    sudo -u postgres pd_dump -f airtime.sql airtime

    and send me a link to the file, I can tell you what's wrong.
    Airtime Pro Hosting: http://airtime.pro