× Warning! This forum is in archival status. New contributions may not work.
Off Air Script Solution?
  • Periodically Airtime will go "Off Air" while show content is programmed and running

    What would be the most elegant way to automatically restart icecast?

    Pseudo code:

    Do while

    Airtime = "on air" & Program Schedule = "active"

           If Airtime = "off air"
                 restart icecast
                 eMail Alert Someone
           End If

    Next

    Thanks!
  • 9 Comments sorted by
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    normally monnit do this ;)
  • Vote Up0Vote Down StephenStephen
    Posts: 43Member

    Bob, I would want to try and debug and find out why it is off air.... is liquidsoap not transmitting, or is icecast crashing?

    We have been running 1.9.4 on ubuntu 10.04 LTS since december in production, and never had a crash yet :) 

    the log files should show some errors to help resolve the issue.

    Would be interested in seeing what is causing this.

    Stephen

  • @Bob,

    I agree with Stephen, if true, this is a serious issue that should be addressed properly.

    Are you sure icecast is the culprit? I would be really interested in hearing more about this problem.
    Airtime Pro Hosting: http://airtime.pro
  • We are running the latest DEV version because we were having HUGE issues with our NAS borking the database when it didn't mount in the proper sequence

    That seems to all be fixed but the off air thing popped up

    I'll pull and review the logs

    Thanks
    Post edited by Bob Zurunclε at 2012-05-14 19:32:09
  • Vote Up0Vote Down Paul BaranowskiPaul Baranowski
    Posts: 389Member, Administrator, Sourcefabric Team
    On Sun, May 13, 2012 at 1:31 PM, Bob Zurunclε <<br />airtime-dev@lists.sourcefabric.org> wrote:

    > Periodically Airtime will go "Off Air" while show content is programmed
    > and running
    >

    Did you check if there was something playing when the ON AIR light was
    off? It could just be a problem with the light, not the playout.
  • There was no playout
  • I poked around the logs a bit

    Here's something that might be a clue

    From icecast/icecast.log

    [2012-05-17  14:52:51] INFO admin/admin_handle_request Received admin command metadata on mount "/airtime_128"
    [2012-05-17  14:52:51] INFO util/util_conv_string converting metadata from UTF-8 to ISO8859-1
    [2012-05-17  14:52:51] INFO admin/command_metadata Metadata on mountpoint /airtime_128 changed to "Airtime - offline"

    From apache error.log

    [Thu May 17 10:53:18 2012] [error] [client 127.0.0.1] PHP Notice:  Undefined offset: 2 in /usr/share/airtime/application/models/Schedule.php on line 368, referer: http://localhost/Schedule
    [Thu May 17 10:53:18 2012] [error] [client 127.0.0.1] PHP Notice:  Undefined offset: 1 in /usr/share/airtime/application/models/Schedule.php on line 370, referer: http://localhost/Schedule


    From the icecast2 logs

    2012-05-17 15:41:08,331 ERROR - [Thread #0] [airtimemetadata.py : get_md_from_file()] : LINE 132 - failed getting metadata from /home/user/mp3_2012/mp3 From 4200/folder/folder2/18-ABC-  Oh, What a Time  [name name 2].mp3
    2012-05-17 15:41:08,333 ERROR - [Thread #0] [airtimemetadata.py : get_md_from_file()] : LINE 133 - Exception can't sync to an MPEG frame

    Thanks!


  • I think the section in apache error log is the source of this problem. I looked through the code and found what could be causing this error. 

    Will be fixed today, thanks!
    Airtime Pro Hosting: http://airtime.pro
  • Hi,

    I think I know the cause of this problem. Quick question, have you been playing around with fade-in and fade-out? This will help me narrow down the problem.
    Airtime Pro Hosting: http://airtime.pro