× Warning! This forum is in archival status. New contributions may not work.
AEGIR problems result: AIRTIME_VERSION = Could not contact server
  • Airtime is working fine until I install Drupal's Aegir Provision.   

    The "On Air" button will not light,everything else appears to work ok but I can hear no sound from the mount. Upon trying an "airtime-check-system"  I notice that AIRTIME_VERSION  cannot contact the server.

     airtime-check-system
    CPU                            = Intel(R) Xeon(R) CPU           L5420  @ 2.50GHz
    Total RAM                      = 509084 kB
    Free RAM                       = 81688 kB
    OS                             = 6.0.3 Intel 80386
    AIRTIME_CONFIG_FILES           = OK
    POSTGRESQL_DATABASE            = OK
    PYTHON_KOMBU_VERSION           = 1.2.0
    PYTHON_POSTER_VERSION          = 0.8.1
    PYTHON_MUTAGEN_VERSION         = 1.20
    PYTHON_PYINOTIFY_VERSION       = 0.9.2
    RABBITMQ_SERVER                = OK
    AIRTIME_VERSION_URL            = http://localhost:80/api/version/api_key/%%api_key%%
    APACHE_CONFIGURED              = NO
    AIRTIME_VERSION                = Could not contact server
    PLAYOUT_ENGINE_PROCESS_ID      = 21201
    PLAYOUT_ENGINE_RUNNING_SECONDS = 2422
    LIQUIDSOAP_PROCESS_ID          = 21205
    LIQUIDSOAP_RUNNING_SECONDS     = 2422
    MEDIA_MONITOR_PROCESS_ID       = 11386
    MEDIA_MONITOR_RUNNING_SECONDS  = 6698
    SHOW_RECORDER_PROCESS_ID       = 11362
    SHOW_RECORDER_RUNNING_SECONDS  = 6698
    ICECAST_PROCESS_ID             = 10996

      -- System setup looks OK!

    What could be causing this?

  • 4 Comments sorted by
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    check apache virtual hosts configuration files /etc/apache2/sites-enabled
  • Hi,

    I've got airtime-vhost in there;

    <VirtualHost *:80>
          ServerName myservername
          #ServerAlias www.example.com

          ServerAdmin myemail

          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php

          SetEnv APPLICATION_ENV "production"

          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
          </Directory>
    </VirtualHost>

    Can you see anything wrong? 

     
    Post edited by Megthing at 2012-01-05 10:44:16
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    airtime-check-system repoerts about
    AIRTIME_VERSION_URL            = http://localhost:80/

    but apache conf file nothing knows about localhost site

    Add in apache conf file:
       ServerAlias localhost
  •  Woooohoooo!  You are a genius! Thank you so very much!!        

    That was exactly the problem and now I've got a working system.