× Warning! This forum is in archival status. New contributions may not work.
403 Forbidden
  • Hi

    I've seen the question asked a few times on here but can't really pick up an answer.

    I've installed Newscoop on a server running vDeck. It's a normal kind of server, you pay for your hosting, get access to a control panel and file manager...you know, the usual thing.

    So, I run the install of Newscoop, it goes through to the last screen with the icon to click on to access the Admin login screen and all I get is:

    403 Forbidden

    Forbidden

    You don't have permission to access /newscoop/newscoop/index.php on this server.


    Now, I'm really not a brilliant computer person but I can install things like Wordpress, Joomla, Drupal etc. I cannot for the life of me install Newscoop and I really, really want too.

    Can anybody explain what might be going wrong here and how I could work around it?

    With thanks
    Carl.
  • 7 Comments sorted by
  • I know this has something to do with the .htaccess file as my web host renamed it.

    I then get hit with the warning page about not having a publication. I still cannot access any admin login page however.

    Having tried a fresh install, I just get hit with this: http://www.dorsetmusicguide.com/newscoop/newscoop/admin/inde x.php

    If anybody can shine any light on this, I'd be most grateful.

    Carl.

    The .htaccess file contents are as below:

    # There might be no access to apache config, set options here
    DirectoryIndex index.php index.html
    Options -Indexes FollowSymLinks -MultiViews

    AddType video/ogg .ogm
    AddType video/ogg .ogv
    AddType audio/ogg .ogg
    AddType video/mp4 .mp4
    AddType video/webm .webm

    # Options might not allowed here, use Rewrite rules instead
    <IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{REQUEST_URI} /+get_img$
    RewriteRule . get_img.php [L]

    RewriteCond %{REQUEST_URI} /+attachment/+
    RewriteRule . attachment.php [L]

    RewriteCond %{REQUEST_URI} !\.php$
    RewriteCond %{REQUEST_URI} !\.html$
    RewriteCond %{REQUEST_URI} !\.css$
    RewriteCond %{REQUEST_URI} !\.js$
    RewriteCond %{REQUEST_URI} !\.ico$
    RewriteCond %{REQUEST_URI} !/+admin
    RewriteCond %{REQUEST_URI} !/+install
    RewriteCond %{REQUEST_URI} !(/+plugins/[^/]*)?/+js
    RewriteCond %{REQUEST_URI} !(/+plugins/[^/]*)?/+css
    RewriteCond %{REQUEST_URI} !(/+plugins/[^/]*)?/+images
    RewriteCond %{REQUEST_URI} !/+templates
    RewriteCond %{REQUEST_URI} !/+videos
    RewriteRule . index.php [L]

    RewriteCond %{REQUEST_URI} .tpl$
    RewriteRule . index.php [L]

    RewriteCond %{REQUEST_URI} /+admin$|/+admin/+.*|/+admin-files
    RewriteRule . admin.php [L]
    </IfModule>

    # Uncomment it for gui backup/restore process
    # NOTE: It can be incompatible on some shared hosting
    #php_value output_buffering Off
  • Vote Up0Vote Down Sava TatićSava Tatić
    Posts: 113Member, Administrator, Sourcefabric Team
    Hi Carl,

    I just followed the link below and I got to the standard Newscoop admin
    inteface login. Do you see something else?

    Perhaps you should refresh your browser's cache?

    All the best,

    Sava
  • Sava

    Thanks for your response. In between me posting that last post and you trying the link, I found the final piece of the jigsaw.

    I had to go into my .htaccess editor in my host control panel (vDeck 4) and set a Default Page instruction to point at the index.php file in the main directory which has now sorted it.

    So, all working.

    Thanks for taking the time respond.

    Carl.
  • Vote Up0Vote Down Sava TatićSava Tatić
    Posts: 113Member, Administrator, Sourcefabric Team
    You are welcome. Please let us know how it goes with the rest of your
    implementation.

    All the best,

    Sava
  • Hi Carl,

    Your note about checking the control panel for access to your .htaccess file is a good thing to add to our documentation, which, if you haven't seen it, is at http://manuals.sourcefabric.org.

    doug
    Douglas Arellanes
    Director of Innovation
    Sourcefabric, o.p.s.

    Find a way or make one.
  • Hi Douglas

    Thanks for your message. Yes I have seen it. It was only sheer fluke that I thought to check that part of the Control Panel (vDeck 4) and of course, the method may well vary on other platform such as cPanel.

    Carl.
  • Hi Carl,

    i have the same Problem, but i have no vDeck at my managed hosting. Could you post how the entry look like in the .htacces

    Thank you

    Andreas