× Warning! This forum is in archival status. New contributions may not work.
No Sound from 1.8.2RC2
  • So far I've checked:

    /etc/airtime/liquidsoap.cfg and set the soundcard to true
    php time.zone
    Removed Pulseaudio

    Doing service rabbitmq-server start results in the follow

    Starting rabbitmq-server: FAILED - check /var/log/rabbitmq/startup_log, _err rabbitmq-server.

    cat /var/log/rabbitmq/startup_log

    Starting all nodes...
    Starting node rabbit@studio-one...

    and that's all the error log reveals. I must admit I'm a bit stuck!

    Oh I forgot to add that the ole red "On-Air" light is lit while the scheduled show is going out.

    - Chris
  • 14 Comments sorted by
  • Hi!

    Are you running on Debian or Ubuntu?
    Airtime Pro Hosting: http://airtime.pro
  • Ubuntu 10.04 on a Dell Optiplex 980 (2.6.32-32-generic-pae i686 GNU/Linux)
  • Sorry if I'm double posting (do the emails go on to the forum?)

    The machine is Ubuntu 10.04 on a Dell Optiplex 980 (2.6.32-32-generic-pae
    i686 GNU/Linux)

    - CW



    On 3 June 2011 15:44, Martin Konecny <airtime-support@lists.sourcefabric.org
    > wrote:

    > Hi!
    >
    > Are you running on Debian or Ubuntu?
    >



    --
    Chris Weaver
    Production Manager
    Resonance104.4FM
    resonancefm.com
    +44 (0)207 407 1210

  • Ha Ha it appears they do. I've also just found this http://forum.sourcefabric.org/index.php/mv/msg/3487/10096/
    which suggests editing /etc/rabbitmq/rabbitmq.conf containing only these 2 lines:

    NODENAME=rabbit@localhost
    NODE_IP_ADDRESS=127.0.0.1

    after this I will try editing /etc/hosts

  • Sadly silence so I'll do:

    sudo service rabbitmq-server start

    Starting rabbitmq-server: /etc/init.d/rabbitmq-server: 134: cannot create /var/log/rabbitmq/startup_log: Permission denied
    FAILED - check /var/log/rabbitmq/startup_log, _err
    rabbitmq-server.

    then cat /var/log/rabbitmq/startup_log

    Starting all nodes...
    Starting node rabbit@localhost...

    +---+ +---+
    | | | |
    | | | |
    | | | |
    | +---+ +-------+
    | |
    | RabbitMQ +---+ |
    | | | |
    | v1.7.2 +---+ |
    | |
    +-------------------+
    AMQP 8-0
    Copyright (C) 2007-2010 LShift Ltd., Cohesive Financial Technologies LLC., and Rabbit Technologies Ltd.
    Licensed under the MPL. See http://www.rabbitmq.com/

    node : rabbit@localhost
    app descriptor: /usr/lib/rabbitmq/lib/rabbitmq_server-1.7.2/sbin/../ebin/rab bit.app
    home dir : /var/lib/rabbitmq
    cookie hash : KgaK24wd9az0CKZrVvBliA==
    log : /var/log/rabbitmq/rabbit@localhost.log
    sasl log : /var/log/rabbitmq/rabbit@localhost-sasl.log
    database dir : /var/lib/rabbitmq/mnesia/rabbit@localhost

    starting internal event notification system ...done
    starting logging server ...done
    starting database ...done
    -- kernel ready
    starting alarm handler ...done
    starting queue supervisor ...done
    starting node monitor ...done
    starting cluster router ...done
    -- core initialized
    starting empty DB check ...done
    starting codec correctness check ...done
    starting exchange recovery ...done
    starting queue recovery ...done
    starting persister ...done
    starting guid generator ...done
    -- message delivery logic ready
    starting error log relay ...done
    starting networking ...done
    -- network listeners available

    broker running
    OK
    done.

    Correct me if I'm wrong but I don't see any errors there.
  • Please post:
    service rabbitmq-server status
    


    Then you will see if rabbitmq is running or not, if it isn't running write:
    service rabbitmq-server start
    


    Then, if you have no errors, try to shedule something and look what happens...
  • Doing service rabbitmq-server status results in:

    erlexec: HOME must be set

    Only root or rabbitmq should run rabbitmq-multi

    and service rabbitmq-server start results in:

    sudo service rabbitmq-server start
    [sudo] password for studio-one:
    Starting rabbitmq-server: FAILED - check /var/log/rabbitmq/startup_log, _err
    rabbitmq-server.
    studio-one@studio-one:~$ cat /var/log/rabbitmq/startup_log
    Starting all nodes...
    Starting node rabbit@localhost...




    On 3 June 2011 17:19, Andrea Giardini
    <airtime-support@lists.sourcefabric.org> wrote:
    >
    > Please post:
    >
    > service rabbitmq-server status
    >
    >
    > Then you will see if rabbitmq is running or not, if it isn't running write:
    >
    > service rabbitmq-server start
    >
    >
    > Then, if you have no errors, try to shedule something and look what happens...
    >


    --
    Chris Weaver
    Production Manager
    Resonance104.4FM
    resonancefm.com
    +44 (0)207 407 1210
  • Hi Chris,

    I'm not sure what the problem is, we've had a few of our users report problems with getting rabbitmq running. Would you consider upgrading rabbitmq to the latest deb package?

    You will find a link to the deb package here:
    http://www.rabbitmq.com/server.html

    Or to the APT repository here:
    http://www.rabbitmq.com/debian.html#apt
    Airtime Pro Hosting: http://airtime.pro
  • Alternatively if you get it working with the Ubuntu 10.04 version, please let us know.
    Airtime Pro Hosting: http://airtime.pro
  • I've installed the latest rabbitmq and have scheduled a programme for 5
    minutes time. Fingers crossed!



    On 3 June 2011 17:34, Martin Konecny <airtime-support@lists.sourcefabric.org
    > wrote:

    > Alternatively if you get it working with the Ubuntu 10.04 version,
    > please let us know.
    >



    --
    Chris Weaver
    Production Manager
    Resonance104.4FM
    resonancefm.com
    +44 (0)207 407 1210

  • Still nothing and running the following doesn't flag up anything too serious (I'm assuming icecast is not used to play audio locally)

    sudo airtime-check-system

    sudo airtime-check-system
    [sudo] password for studio-one:
    Sorry, try again.
    [sudo] password for studio-one:
    CPU = Intel(R) Core(TM) i7 CPU 860 @ 2.80GHz
    Total RAM = 4049904 kB
    Free RAM = 3153556 kB
    OS = Ubuntu 10.04.2 LTS Intel 80386
    AIRTIME_CONFIG_FILES = OK
    POSTGRESQL_DATABASE = OK
    PYTHON_KOMBU_VERSION = 1.1.3
    PYTHON_POSTER_VERSION = 0.8.1
    RABBITMQ_SERVER = OK
    AIRTIME_VERSION_URL = http://localhost:80/api/version/api_key/%%api_key%%
    APACHE_CONFIGURED = YES
    AIRTIME_VERSION = 1.8.2
    PLAYOUT_ENGINE_PROCESS_ID = 1754
    PLAYOUT_ENGINE_RUNNING_SECONDS = 367
    LIQUIDSOAP_PROCESS_ID = 1016
    LIQUIDSOAP_RUNNING_SECONDS = 373
    ICECAST_PROCESS_ID = FAILED

    -- There appears to be problems with your setup. Please visit
    -- http://wiki.sourcefabric.org/x/HABQ for troubleshooting info.
  • Same problem with 1.8.1: no sound.
    Players connected to icecast receive the stream, which is deaf.
    Same rabbitmq-server status result:
    service rabbitmq-server status
    erlexec: HOME must be set
    
    Only root or rabbitmq should run rabbitmq-multi


    "On AIR" LED is not lit when a scheduled show pretends to be playing at least the song titles and timing counts correctly.

    I'm not experienced with Linux/Ubuntu at all yet. Appreciate the detailed hint on what commands to use : )

    Tryed compiling liquidsoap locally and placing the binary to the folder mentioned in the other post - didn't change anything. Still radio silence.
  • Sergei S. wrote on Tue, 07 June 2011 15:26
    Same problem with 1.8.1: no sound.
    Players connected to icecast receive the stream, which is deaf.
    Same rabbitmq-server status result:
    service rabbitmq-server status
    erlexec: HOME must be set
    
    Only root or rabbitmq should run rabbitmq-multi


    "On AIR" LED is not lit when a scheduled show pretends to be playing at least the song titles and timing counts correctly.

    I'm not experienced with Linux/Ubuntu at all yet. Appreciate the detailed hint on what commands to use : )

    Tryed compiling liquidsoap locally and placing the binary to the folder mentioned in the other post - didn't change anything. Still radio silence.


    Sergei,

    If rabbitmq isn't working for you, I'd recommend you download the latest package from here

    http://www.rabbitmq.com/server.html

    You can then install it from the command line using

    dpkg -i rabbitmq-server_2.4.1-1_all.deb

    Airtime Pro Hosting: http://airtime.pro
  • Vote Up0Vote Down VerheekVerheek
    Posts: 158Member
    I got rabbitmq working on a clean Ubuntu 10.04 with the latest updates and no /etc file needed. I also didn't have blank password problems.

    I'm convinced a lot of problems come from a messy OS.

    Jeremy