Translation update not working
  • Vote Up1Vote Down JamalJamal
    Posts: 11Member
    I tried to update the translate file (admin console - configure blog - localization), but it seems the file is not update after saving.

    The sentences on blog + language file remains the same. And i noticed this for all languages.

    I need to edit the translation file, because i get a strange code above the embed blog. This code is only showing after posting a new message. So i think its the sentence "a moment ago". Please check the pictures, and please support me asap with updating the translation file, and removing the strange code. 

    1300 x 561 - 184K
    1942 x 566 - 194K
  • 5 Comments sorted by
  • Hello Jamal,

    I've try to replicate the issue locally with latest tags from 
    Ally-Py: 2.0.5-stable 
    Live-Blog:  2.0.30-stable

    and worked fine with the po you had provided.

    that code is the there when there `post-date` message is not formated well.

    also I took a look at the po and saw that the `post-date` wasn't formated and also timezone was wrong provided, so I change it and attached, maybe this will fix the issue.

    So, the keys with `-` are internal used not to be literally translated, aka
    `post-date` is format used for post date time and with `moment` context formated with momentjs. more here for moment js:
    also the same for `timezone` with `moment` context more here

    If not please provide me with more details, about the themes are you using which tags for Live-Blog and Ally-Py.

  • remove "…" symbol; remove langpacks from workspace folder; eestart app and re-upload langpack
    Innovations developer, Sourcefabric
  • When i try to re-upload the po file, it stucks on: Creating internationalization cache

    Internal server error occurred, this is a major issue so please contact your administrator

    Traceback (most recent call last):
    File "/opt/ally-py/liveblog/distribution/components/ally-1.0.dev0-py3.2.egg/ally/design/processor/", line 254, in do
    try: call(self, **self.arg.__dict__)
    File "/opt/ally-py/liveblog/distribution/components/ally-1.0.dev0-py3.2.egg/ally/design/processor/", line 268, in wrapper
    call(*chain(args, self.processings), **keyargs)
    File "/opt/ally-py/liveblog/distribution/components/ally_core_http-1.0.dev0-py3.2.egg/ally/core/http/impl/processor/", line 89, in process
    Chain(redirect).process(request=request, response=response, **keyargs).doAll()
    File "/opt/ally-py/liveblog/distribution/components/ally-1.0.dev0-py3.2.egg/ally/design/processor/", line 280, in doAll
    if not break
    File "/opt/ally-py/liveblog/distribution/components/ally-1.0.dev0-py3.2.egg/ally/design/processor/", line 254, in do
    try: call(self, **self.arg.__dict__)
    File "/opt/ally-py/liveblog/distribution/components/ally-1.0.dev0-py3.2.egg/ally/design/processor/", line 169, in wrapper
    File "/opt/ally-py/liveblog/distribution/components/ally_core-1.0.dev0-py3.2.egg/ally/core/impl/processor/", line 100, in process
    value = request.invoker.invoke(*arguments)
    File "/opt/ally-py/liveblog/distribution/components/ally_core-1.0.dev0-py3.2.egg/ally/core/impl/", line 77, in invoke
    return getattr(self.implementation,*args)
    File "/opt/ally-py/liveblog/distribution/components/ally-1.0.dev0-py3.2.egg/ally/container/impl/", line 245, in __call__
    return Execution(self, deque(self.proxy._proxy_handlers), args, keyargs).invoke()
    File "/opt/ally-py/liveblog/distribution/components/ally-1.0.dev0-py3.2.egg/ally/container/impl/", line 193, in invoke
    return handler.handle(self)
    File "/opt/ally-py/liveblog/distribution/components/ally-1.0.dev0-py3.2.egg/ally/container/impl/", line 241, in handle
    value = execution.invoke()
    File "/opt/ally-py/liveblog/distribution/components/ally-1.0.dev0-py3.2.egg/ally/container/impl/", line 193, in invoke
    return handler.handle(self)
    File "/opt/ally-py/liveblog/distribution/components/ally-1.0.dev0-py3.2.egg/ally/container/impl/", line 330, in handle
    return method(*execution.args, **execution.keyargs)
    File "/opt/ally-py/liveblog/distribution/plugins/internationalization-1.0.dev0-py3.2.egg/internationalization/impl/", line 105, in getPluginPOFile
    self.cdmLocale.publishFromFile(path, self.poFileManager.getPluginPOFile(plugin, locale))
    File "/opt/ally-py/liveblog/distribution/plugins/internationalization-1.0.dev0-py3.2.egg/internationalization/core/impl/", line 197, in getPluginPOFile
    self._filePath(locale, plugin=plugin), self._filePath(locale))
    File "/opt/ally-py/liveblog/distribution/plugins/internationalization-1.0.dev0-py3.2.egg/internationalization/core/impl/", line 422, in _build
    with open(path) as fObj: catalog = read_po(fObj, locale)
    File "/opt/ally-py/liveblog/distribution/libraries/Babel-1.0dev-py3.2/babel/messages/", line 217, in read_po
    for lineno, line in enumerate(fileobj.readlines()):
    File "/opt/python32/lib/python3.2/encodings/", line 26, in decode
    return codecs.ascii_decode(input, self.errors)[0]
    UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 715: ordinal not in range(128)
  • i removed the "..." symbols in po file.

    i removed langpacks (po / mo files) in workspace folders:


    then i restarted app and re-uploaded file: 

    it seems like the translation file remains unchanged. And the strange post-date format is still there.

    What am i doing wrong?
  • There is probably still somewhere a (momentjs?) cache i have to clean. Does someone knows the location?