RuntimeException: The process timed-out.

  • and have filled "Main settings" with the site name and password,
    when I click next, I have those error message:

    Whoops, looks like something went wrong.

    1/1RuntimeException: The process timed-out.
    in /home/msite/public_html/vendor/symfony/symfony/src/Symfony/Component/Process/Process.php line 995
    at Process->checkTimeout() in /home/msite/public_html/vendor/symfony/symfony/src/Symfony/Component/Process/Process.php line 316
    at Process->wait() in /home/msite/public_html/vendor/symfony/symfony/src/Symfony/Component/Process/Process.php line 197
    at Process->run() in /home/msite/public_html/library/Newscoop/Installer/Services/FinishService.php line 54
    at FinishService->generateProxies() in /home/msite/public_html/install/index.php line 345
    at {closure}(object(Request))
    at call_user_func_array(object(Closure), array(object(Request))) in /home/msite/public_html/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php line 117
    at HttpKernel->handleRaw(object(Request), '1') in /home/msite/public_html/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php line 61
    at HttpKernel->handle(object(Request), '1', true) in /home/msite/public_html/vendor/silex/silex/src/Silex/Application.php line 538
    at Application->handle(object(Request)) in /home/msite/public_html/vendor/silex/silex/src/Silex/Application.php line 515
    at Application->run() in /home/msite/public_html/install/index.php line 354
  • 6 Comments sorted by
  • Hi kweb,

    Try to change the timeout for the command that generates the proxies (because it crashes on this command).

    Open file /home/msite/public_html/library/Newscoop/Installer/Services/FinishService.php  and in line 53 where you have:

    $generateProxies = new Process("$php $doctrine orm:generate-proxies", null, null, null, 300);

    change last parameter from 300 seconds to some higher. 300 seconds is by default 5 minutes, try to increase it or set "null" for no timeout. For some reason your host needs more time to generate the proxies.

  • Okay, Thank you rafal,

    I error

    Installation is very slow and does not work

    Internal Server Error

    The server encountered an internal error or
    misconfiguration and was unable to complete
    your request.

    Please contact the server administrator,
    webmaster@.... and inform them of the time the error occurred,
    and anything you might have done that may have
    caused the error.

    More information about this error may be available
    in the server error log.

    Additionally, a 404 Not Found
    error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2.2.29 (Unix) mod_ssl/2.2.29 OpenSSL/1.0.1e-fips mod_bwlimited/1.4

    Post edited by kweb at 2014-12-28 19:07:51
  • impossible to install Newscoop
    how to solve the problem?
  • I am having the same problem.  Is there any more information on this?

  • not always the problem of finding a solution, I now have this error when I install wishes when all is good in the easyphp cpanel
      and the server php.ini

    System compatibility


    • PHP version must be at least 5.3.3 (5.4.36 installed)
    • PHP version must not be 5.3.16 as Symfony won't work properly with it
    • Vendor libraries must be installed
    • cache/ directory must be writable
    • log/ directory must be writable
    • conf/ directory must be writable
    • library/Proxy/ directory must be writable
    • themes/ directory must be writable
    • plugins/ directory must be writable
    • public/ directory must be writable
    • images/ directory must be writable
    • date.timezone setting must be set
    • Configured default timezone "Europe/Paris" must be supported by your installation of PHP
    • json_encode() must be available
    • session_start() must be available
    • ctype_alpha() must be available
    • token_get_all() must be available
    • simplexml_import_dom() must be available
    • detect_unicode must be disabled in php.ini
    • PCRE extension must be available


    • sendmail should be installed
    • You should use at least PHP 5.3.4 due to PHP bug #52083 in earlier versions
    • When using annotations you should have at least PHP 5.3.8 due to PHP bug #55156
    • You should not use PHP 5.4.0 due to the PHP bug #61453
    • You should use PHP 5.3.18+ or PHP 5.4.8+ to always get nice error messages for fatal errors in the development environment due to PHP bug #61767/#60909
    • PCRE extension should be at least version 8.0 (8.36 installed)
    • PHP-XML module should be installed
    • mb_strlen() should be available
    • iconv() should be available
    • utf8_decode() should be available
    • posix_isatty() should be available
    • intl extension should be available
    • intl extension should be correctly configured
    • intl ICU version should be at least 4+
    • a PHP accelerator should be installed
    • short_open_tag should be disabled in php.ini
    • magic_quotes_gpc should be disabled in php.ini
    • register_globals should be disabled in php.ini
    • session.auto_start should be disabled in php.ini
    • PDO should be installed
    • PDO should have some drivers installed (currently available: sqlite, mysql)
    All is well! Next Refresh

    Newscoop, the open content management system for professional journalists. 
    © 2015 Sourcefabric z.ú. Newscoop is distributed under GNU GPL v.3

  • Can anybody give a solution to this problem am having the same issue.THANKS