404 Not Found: The server can not find the requested page:
  • Fresh install... keep getting

    404 Not Found


    The server can not find the requested page:



    listen.bigstation.fm/login (port 443)
    Have install and reinstalled. Have followed protocols for "Secure login with SSL or TLS." Have also checked my "etc/host" setting and done a physical check on server for all files to insure correct pathways. Any assistance would greatly appreciated. Thank you.

    install@listen:~$ sudo airtime-check-system
    AIRTIME_STATUS_URL             = http://listen.bigstation.fm:80/api/status/format/json/api_key/%%api_key%%
    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = 3.13.0-34-generic
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 8165072
    TOTAL_SWAP_MBYTES              = 7807932
    AIRTIME_VERSION                = 2.5.1
    OS                             = Ubuntu 12.04.5 LTS x86_64
    CPU                            = Intel(R) Xeon(R) CPU           L5520  @ 2.27GHz
    WEB_SERVER                     = Apache/2.2.22 (Ubuntu)
    PLAYOUT_ENGINE_PROCESS_ID      = 1590
    PLAYOUT_ENGINE_RUNNING_SECONDS = 2025
    PLAYOUT_ENGINE_MEM_PERC        = 0.1%
    PLAYOUT_ENGINE_CPU_PERC        = 0.0%
    LIQUIDSOAP_PROCESS_ID          = FAILED
    LIQUIDSOAP_RUNNING_SECONDS     = 0
    LIQUIDSOAP_MEM_PERC            = 0%
    LIQUIDSOAP_CPU_PERC            = 0%
    tail: cannot open `/var/log/airtime/pypo-liquidsoap/ls_script.log' for reading: No such file or directory
    -- Displaying log file /var/log/airtime/pypo-liquidsoap/ls_script.log
    --
    --
    MEDIA_MONITOR_PROCESS_ID       = 1585
    MEDIA_MONITOR_RUNNING_SECONDS  = 2025
    MEDIA_MONITOR_MEM_PERC         = 0.1%
    MEDIA_MONITOR_CPU_PERC         = 0.0%
    -- There appears to be a problem with your Airtime installation.
    -- Please visit http://wiki.sourcefabric.org/x/HABQ

  • 4 Comments sorted by
  • Which method did you use to install?

    I always recommend this http://sourcefabric.booktype.pro/airtime-25-for-broadcasters/automated-installation/

    but not to worry.

    Your issues seems to be domain related so try and do this
    sudo dpkg-reconfigure airtime

    then you need to make the installation run and
    do not chose to setup the domain manually let airtime chose to install,then search this forum for my dummy tutorial
    on Virtual hosting on ways to configure your domain if you have like say a webserver
    already on this machine.

    If not work then do a total reinstall by following the link above.

    Step 1

     the relevant sections are

    •     Set up repositories for Ubuntu/Debian


    •     Install the Sourcefabric signing key


    Step 2

    Remove your attempted installation by this command

    sudo apt-get remove airtime && sudo apt-get purge airtime && sudo apt-get autoremove


    Notes

    1. you do not have  to setup the database or icecast server,during the installation process it will ask you the relevant information.so if you are going to use different passwords (recommended )etc.on the  servers have these ready to answer the questions in the installation process
    2. In the prompt that say "Debian and Ubuntu servers are set up with a default Apache configuration, which might block station staff from accessing Airtime. If you wish, this default configuration can be removed automatically for you." chose no change unless you know what you are doing and if you have a copy,so you can have an idea on how to configure the virtual host


    Step 3

    Install Airtime

    Wish you luck

    VOISSES







    Post edited by Voisses Tech at 2014-11-24 19:36:23
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • I have done the "Automated Installation" verbatim the instructions a few times. Still getting the same issue. I have attached my current "status" and my "etc/host/" and "airtime-vhost.conf" files. I'm convinced as you said its domain related but I'm not sure where.

    AIRTIME_STATUS_URL             = http://listen.bigstation.fm:80/api/status/format/json/api_key/%%api_key%%
    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = 3.13.0-32-generic
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 8165072
    TOTAL_SWAP_MBYTES              = 7806908
    AIRTIME_VERSION                = 2.5.1
    OS                             = Ubuntu 12.04.5 LTS x86_64
    CPU                            = Intel(R) Xeon(R) CPU           L5520  @ 2.27GHz
    WEB_SERVER                     = Apache/2.2.22 (Ubuntu)
    PLAYOUT_ENGINE_PROCESS_ID      = 1535
    PLAYOUT_ENGINE_RUNNING_SECONDS = 1077
    PLAYOUT_ENGINE_MEM_PERC        = 0.2%
    PLAYOUT_ENGINE_CPU_PERC        = 0.0%
    LIQUIDSOAP_PROCESS_ID          = 1958
    LIQUIDSOAP_RUNNING_SECONDS     = 1053
    LIQUIDSOAP_MEM_PERC            = 0.3%
    LIQUIDSOAP_CPU_PERC            = 0.4%
    MEDIA_MONITOR_PROCESS_ID       = 1519
    MEDIA_MONITOR_RUNNING_SECONDS  = 1077
    MEDIA_MONITOR_MEM_PERC         = 0.1%
    MEDIA_MONITOR_CPU_PERC         = 0.0%
    -- Your installation of Airtime looks OK!

    ETC/HOST
    127.0.0.1       localhost
    198.101.12.199  listen.bigstation.fm

    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

    AIRTIME-VHOSTS.CONF
    <VirtualHost *:443>
          SSLEngine on
          SSLProtocol All -SSLv2 -SSLv3
          SSLCompression off
          SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
          SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
          Header always set Strict-Transport-Security "max-age=31536000"

          ServerName listen.bigstation.fm
          #ServerAlias www.example.com

          ServerAdmin keith.walters@smartcast.pro

          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php

          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride all
                  Allow from all
          </Directory>
    </VirtualHost>

    <VirtualHost *:80>
          ServerName listen.bigstation.fm

          ServerAdmin keith.walters@smartcast.pro

          DocumentRoot /usr/share/airtime/public
          Redirect permanent /login https://listen.bigstation.fm/login

          SetEnv APPLICATION_ENV "production"

          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
          </Directory>
    </VirtualHost>

    Post edited by Keith Walters at 2014-11-27 04:13:12
  • Everything seems Okay
    So what could be wor ng

    Take a look at this post https://forum.sourcefabric.org/discussion/comment/30197#Comment_30197
    Try access on the same subnet and let me know

    1. Are you having problem accessing your page as https://whateverIP&nbsp; as in your case https://listen.bigstation.fm&nbsp;
    2. Type hostname and then hostname -f  at the prompt and ensure both are the same ( you might need to type echo listen.bigstation.fm > /etc/hostname and then sudo /etc/init.d/hostname restart )
    3. The hostname seem ok but do you have a firewall on your system or anywhere.You need to enable port 80 and port 443 both (incoming and outgoing).

    Let me know it seems a resolution problem and not airtime problem.

    Try Access the stream page  to ensure all is okay http://yourIP:8000  

    or for a troubleshoot directly from that machine

    you could also install a command line browser and see if the site is up

    sudo apt-get install w3m w3m-img

    then browse to the Airtime by typing

    w3m https://localhost

    or to check if your host is properly redirects

    w3m http://localhost

    of course finally you could check name resolution

    https:// listen.bigstation.fm


    to remove that command line browser (you do not like additional applications on your system-which is good for security)

    sudo apt-get remove w3m && sudo apt-get remove w3m-img && sudo apt-get purge w3m && sudo apt-get autoremove 


    Happy Holidays

    To All in the USA

    VOISSES



    Post edited by Voisses Tech at 2014-11-27 13:07:24
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Done... thanks