Superdesk install
  • 62 Comments sorted by
  • Vote Up0Vote Down Tom HTom H
    Posts: 27Member
    Thanks Yauhen, all looks great so far but now can't login! what's default username and password? Have tried all the ones I can see mentioned in these forums unless I'm missing something??
  • I am really glad to hear that! :-)

    So when you was starting the demo, it was written how to handle logging in:

    Or how do you think, should we move that to the readme from the script?
    Post edited by Yauhen Kirylau at 2015-04-28 14:19:49
    Innovations developer, Sourcefabric
  • Vote Up0Vote Down Tom HTom H
    Posts: 27Member
    Success!! Yes I remembered seeing that but if you put in readme it would be much better as I forgot where I saw it initially!

    Also, I ran it earlier as "./" under Superdesk repository and it said 'no such file or directory' so I didn't run it again thinking it was error but after your reply I realised it was in scripts folder so I ran './scripts/' and it created user fine.

    So I'm all logged in a it looks great! Excited to start using it, thanks so much for your help Yauhen and I will stop pestering you now and get on with trying it out! :)

    Many thanks

  • Thank you for your feedback, Tom!
    I have slightly updated the readme file based on it.
    Post edited by Yauhen Kirylau at 2015-04-29 02:46:46
    Innovations developer, Sourcefabric
  • Hi,
    I try to install superdesk on ubuntu 14 and i get this message :

    Successfully installed docker-compose docopt PyYAML requests texttable websocket-client docker-py dockerpty six backports.ssl-match-hostname
    Cleaning up...
    ./scripts/ line 10: docker: command not found
    Depended executable not found. Check the message above

    Can u help me please ???

  • > docker: command not found
    Depended executable not found. Check the message above

    You did not installed docker.
    Innovations developer, Sourcefabric
  • Should have posted to this discussion instead of starting another one...

    I'm running on Mac OS X with boot2docker
    ran the ./scripts/ cmd and see this grunt error.  I have grunt installed...

    redis_1    | [1] 10 Jul 15:02:29.359 * The server is now ready to accept connections on port 6379

    backend_1  | waiting for mongo...

    frontend_1 | grunt-cli: The grunt command line interface. (v0.1.13)

    frontend_1 | 

    frontend_1 | Fatal error: Unable to find local grunt.

    frontend_1 | 

    frontend_1 | If you're seeing this message, either a Gruntfile wasn't found or grunt

    frontend_1 | hasn't been installed locally to your project. For more information about

    frontend_1 | installing and configuring grunt, please see the Getting Started guide:

    frontend_1 | 

    frontend_1 |

    superdesk_frontend_1 exited with code 99

    Any ideas?


  • please ignore my previous post about grunt... I commented out the cd docker line in the  sorry
  • ok I finally got the server to start and see the login screen but I see a ton of the below repetitive messages:

    kibana_1   | {"@timestamp":"2015-07-10T16:40:30.044Z","level":"warn","message":"Unable to revive connection: http://elastic:9200/","node_env":"production"}

    kibana_1   | {"@timestamp":"2015-07-10T16:40:30.045Z","level":"warn","message":"No living connections","node_env":"production"}

    kibana_1   | {"@timestamp":"2015-07-10T16:40:30.045Z","level":"info","message":"Unable to connect to elasticsearch at http://elastic:9200. Retrying in 2.5 seconds.","node_env":"production"}

    backend_1  | waiting for mongo...

    backend_1  | waiting for elastic...

    Not sure why it's not able to connect to elastic search or mongo.  the http://elastic:9200 url doesn't look like a real url...  is it supposed to be running locally on my box?  Can somebody help?  I'm using Mac OS X with boot2docker.


  • Can you please paste log messages starting with "elastic_1" ? It seems what elasticsearch container did not started for some reason.
    Innovations developer, Sourcefabric
  • I don't see elastic_1 at all.   I only see the backend try to start but waiting for elastic and mongo forever... 

    backend_1  | waiting for elastic...

    backend_1  | waiting for mongo...

    I also noticed some scripts calling readlink -e, which doesn't exist in Mac OS X.  So i modified those lines with the actual physical path such as

    #WORK_DIR=$(readlink  $(dirname "$0"))


    in scripts/ 

    Why won't elastic and mongo start?

  • I was finally able bring up the server and log in...

    had to change in docker-compose.yml

    do the same for other relative volume mounts in that file such as ../data/mongodb and ../data/redis etc...

    also had to modify the readline -e lines scattered around the project to actual paths to get ride of the "readline -e not valid argument" errors for mac os x.

    this project really needs better installation instructions for Mac OS X