× Warning! This forum is in archival status. New contributions may not work.
Airtime Schedule and Liquidsoap Errors
  • When shutting down the box as it closes down it reports

    liquidsoap channels no script found /etc/liquidsoap/
    and
    Airtime Schedule Engine chown cannot access /etc/airtime/liquidsoap.cfg no such file or directory

    then as i reboot the box i get
    Liquidsoap channels no script found /etc/liquidsoap/

    Can't say i noticed this before hand but since trying a few different ways to get the software to work as i needed icecast suddenly decided to stop access to the status page using the full ip ?(main ip not router ip). On rebooting all the software i noticed the error messages.

    The liquidsoap.cfg is in the /etc/airtime/ folder and matches the settings in Airtime.
  • 13 Comments sorted by
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    perhaps an installation problem...
    try to uninstall airtime and reinstall it

    like that :

    apt-get --purge remove airtime
    apt-get install airtime

    but this manipulation erase your postgresql database airtime (backup it before)
  • Post the output of 'sudo airtime-check-system' as well as post some log files from 

    /var/log/airtime/pypo
    /var/log/airtime/pypo-liquidsoap
    Airtime Pro Hosting: http://airtime.pro
  • No file exists for these commands
    /var/log/airtime/pypo
    /var/log/airtime/pypo-liquidsoap
    (i ran sudo nano /var/log/airtime/pypo and same again for the liquidsoap)

    but that maybe because i reinstalled again, last uninstall/remove didn't remove icecast and liquidsoap so i manually removed them again before reinstalling.
    646 x 546 - 31K
  • Even after a fresh install the issue has come back,

    Again no file exists for these commands?
     /var/log/airtime/pypo/
    /var/log/airtime/pypo-liquidsoap


    "liquidsoap channels no script found /etc/liquidsoap/
    and
    Airtime Schedule Engine chown cannot access /etc/airtime/liquidsoap.cfg no such file or directory,
    then as i reboot the box i get

    Liquidsoap channels no script found /etc/liquidsoap/
    "

    Everything seems to work but somehow icecast stopped working sometime today then after rebooting the machine those error messages popped back up.

    Airtime seems to function fine and icecast output is working but took a few minutes before it would connect to the server.

    I'm going to monitor it for the next few hours will report back any issues.
    Post edited by mikeibc at 2012-11-12 14:16:35
  • Airtime is still running fine i think icecast and liquidsoap are having issues as the output stream seems to crash after an hour or so.

    Output Streams Settings now reports:
    Can not connect to the streaming server
    could not connect to host: connection timeout

    Icecast has to be restarted to get the stream backup.
    Any help is always apreciated.
  • Only changes to the icecast xml are..
    that i uncomented the shoutcast stream (/stream) mountpoint
    and changed the host from localhost to my main ip
  • Liquidsoap.cfg outputs the same settings that are in the streams area inside airtime.

    One thing i did notice is that the output_sound_device has no setting, i didn't have any of the cards listed on hardware output so i left the box unticked.

    Log is located /var/log/airtime/pypo-liquidsoap/<script>.log so i'm not sure how to access that ?
    Post edited by mikeibc at 2012-11-12 15:53:34
  • Without Rebooting i got the output stream to re-connect by changing main ip to the router ip address ?
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    no
  • Router ip works but can't get external access to the stream, so i reinstall ubuntu and airtime again
     i'm figuring this issue with ips is related to hostname i spent a great deal of time on this already so some help here would be appreciated
  • I'm getting this message after adding deb and updating ?


    642 x 520 - 34K
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    Hi

    first you are not on lucid, change your sources.list to quantal
    and perhaps the interconnection is not good for the moment
    try again later
  • I've managed to sort it the end, i got myself in a tangle with servername and hostnames once i figured out that i was easily abled to track down the issue.