Memory Leak?
  • Prior to 2.2, my server only used about 50% of the CPU at a stead pace. Since a fresh install of 2.2 and Ubuntu, it's slamming the server with 100% perpetual CPU utilization and becomes less and less responsive until it has to be rebooted (about 2 - 3 days later). The stream eventually dies because it doesn't have enough resources.

    Is this a known bug?
  • 9 Comments sorted by
  • Initially, Airtime 2.2 will take higher CPU after an install (over 2.1) while it computes ReplayGain values for tracks in your media library (for audio normalization purposes).

    However, these computations are given a very low CPU priority and shouldn't affect the system's performance. 

    Please run the "top" command, and post report what processes are using the most CPU %.

    Airtime Pro Hosting:
  • I just reset the server, but currently:

    pypo - 33%
    user - 10%
    root 10%
    icecast2 - 1%

    Everything else is 0%
  • Please post the names under the command column.
    Airtime Pro Hosting:
  • pypo - airtie-liquids
    root - xorg
    user ksysgaurd
    icecast2 - icecast2

    www-data appears 3 times at around 7%

    www-data - apache2

    So far the problem hasn't appeared since my last reboot, however, people were reporting that the stream stopped and they were getting a timeout while trying to connect. There are 2 more problems that cropped up:

    My DJ's (one a program coordinator) uploaded tracks, but they didn't appear until after I restarted the server.

    When trying to preview one track (and only one track so far) we all get this error:

    Not Found

    The requested URL /audiopreview/audio-preview/audioFileID/811.mp3/audioFileArtist/Two Beans/George Ledoux/audioFileTitle/Mechwarrior 2 Remix/type/audioclip was not found on this server.

    I can download the song just fine, and there are no other errors. I tried changing the name and metatags to remove all special characters and it still doesn't work.

    It was due to a / in several of the metatags. Sanitation maybe? 

    Post edited by Stephen King at 2012-11-05 23:57:26
  • Vote Up0Vote Down Cliff WangCliff Wang
    Posts: 339Member, Sourcefabric Team
    Yes, it's because /, we've already fixed that in 2.2.1 and currently the workaround is to remove that "/" temporally. 
    Cloud Radio ->
  • I should also note that I added several hundred hours of smart playlists to the calender. All the playlists populated properly, but that may have been where the problem originated.
  • hi! we also had the same issue at our radio station (the machine becomes less and less responsive until in few days it has to be rebooted). the machine is new, dedicated only to airtime and all software were installed recently. we are monitoring this and will post our observations here if it repeats.
  • Alright, I've confirmed that he slow down happens when adding a number of smart playlists. I added about 70 (one week's worth) and the cpu is now maxed at 100%, even after all the playlists have been added. TOP:

    User Command CPU%
    www-data apache2 34
    www-data apache2 30
    www-data apache2 27
    www-data apache2 25
    www-data apache2 20
    www-data apache2 17
    root xorg 6
    pypo airtime-liquid 4

    I hope that helps.
  • We also experience the problem that after a few days the aiertime-liquids process goes up to 100%, the stream stops and the web interface is almost not responsive. 
    Only thing to do is to killing the process by force and starting it again.

    Anyone that has any suggestions on what logfiles to look in?