Liquidsoap daemon is not starting. Upgrade from airtime 5.2.1 to
  • Running on Debian Wheezy
    $ uname -a
    Linux data 2.6.32-042stab102.9 #1 SMP Fri Dec 19 20:34:40 MSK 2014 x86_64 GNU/Linux

    I installed the previous version (5.2.1) using automatic install, but I couldn't find the version on apt repositories so i downloaded the source from and executed the install script.
    everything went smooth. web installer detected the previous database ("database already installed") and Im able to log in using my old admin passwords. I can also see my old schedules on calendar.



    but the stream is down, I think the problem is airtime liquidsoap daemon not starting (or running). don't know there the problem is. please help me to fix this.

    i tried run the daemon using debug mode.
    #sudo -u www-data /usr/bin/airtime-liquidsoap -d
    Airtime Liquidsoap
    Airtime Liquidsoap
    usage: liquidsoap [-h] [-d]
    liquidsoap: error: unrecognized arguments: /usr/local/lib/python2.7/dist-packages/airtime_playout-1.0-py2.7.egg/liquidsoap/ls_script.liq --verbose -f

    ok i ran the install script again, this time liquidsoap daemon is running perfect. now the problem is media-monitor is down. now this makes me want to pull out my hair
    Post edited by nawank at 2015-09-16 02:24:22
  • 2 Comments sorted by
  • I figure out how to make it work!
    For first you need to purge old configs(do NOT FORGOT to save a copy of database, apache Vhost if is custom, and /etc/airtime/ dir)
    What i do :
    1. ~/airtime- aptitude purge airtime
    2. ~/airtime- ./install
    3. Enable back (if is not enabled) apache Vhost.
    4. Open URL where the radio will be and setup it up with default settings, but if change the user and database name enter it.
    5 . Start services :
    ~/airtime- /etc/init.d/airtime-liquidsoap restart
    ~/airtime- /etc/init.d/airtime-media-monitor restart
    ~/airtime- /etc/init.d/airtime-playout restart
    6. Verify if all start, and is done!
  • *bump*
    I'm seeing the exact same errors as Alexandru. I had a running version of 2.5.1 and ran the 2.5.2 installer manually over it. Setup worked fine, did not complain with any errors and I could open the configuration page on the web just fine. Except: the liquidsoap process fails with the same error messages as above.

    So, 2nd try. apt-get purge airtime to remove 2.5.1 - runs through, seems to delete all necessary things. Running the 2.5.2 installer again, runs through, no errors. Starting the services -> liquidsoap fails.

    3rd try: run the uninstaller script, manually removed the remaining confing files, cleared the database. No trace of anything Airtime left. Ran the installer. No errors. Open up the config, liquidsoap service fails.

    And I can't seem to find any reason why, except two lines in the pypo.log:
    2016-11-04 17:27:49,666 DEBUG - [ : liquidsoap_get_info() : line 169] - Checking to see if Liquidsoap is running
    2016-11-04 17:27:49,666 ERROR - [ : liquidsoap_get_info() : line 178] - [Errno 111] Connection refused
    2016-11-04 17:27:49,667 WARNING - [ : liquidsoap_startup_test() : line 205] - Liquidsoap doesn't appear to be running!, Sleeping and trying again

    Does anyone have another solution than to run the installer again?

    Edit: while speaking to a friend he came up with the rather simple idea: "just reinstall liquidsoap and see what happens" - me: "errr, ok..."
    Turns out his idea wasn't so silly after all. apt-get remove liquidsoap - apt-get install liquidsoap
    aaaaaaand it works. I dont' understand why, but it works. Case closed.

    Edit 2: unfortunately that did not last very long and liquidsoap ended itself for reasons beyond my understanding. And Airtime refuses to connect to the icecast server on localhost, stating authentication errors, even though I triple checked the passwords and config. 
    At this point I might as well give up and return to the less troublesome previous version.
    Post edited by Zaunpfahl42 at 2016-11-04 14:30:43