× Warning! This forum is in archival status. New contributions may not work.
Airtime refuses to install on Ubuntu 12.04.4 (+ zpanel) [Solved]
  • I'm seeing loads of these being posted with no fixes/replies except use a supported OS but Ubuntu 12.04 should be Kosha.
    I'm hoping there's something obvious here that I'm missing.


    *** Verifying your system environment, running airtime-check-system ***
    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = UNKNOWN
    MACHINE_ARCHITECTURE           = UNKNOWN
    TOTAL_MEMORY_MBYTES            = UNKNOWN
    TOTAL_SWAP_MBYTES              = UNKNOWN
    AIRTIME_VERSION                = UNKNOWN
    OS                             = Ubuntu 12.04.4 LTS x86_64
    CPU                            = Intel(R) Xeon(R) CPU E5-2403 0 @ 1.80GHz
    WEB_SERVER                     = Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.9 with Suhosin-Patch
    PLAYOUT_ENGINE_PROCESS_ID      = FAILED
    PLAYOUT_ENGINE_RUNNING_SECONDS = 0
    PLAYOUT_ENGINE_MEM_PERC        = 0%
    PLAYOUT_ENGINE_CPU_PERC        = 0%
    -- Displaying log file /var/log/airtime/pypo/pypo.log
    -- 2014-01-28 22:19:24,329 INFO - [api_client.py : is_server_compatible() : line 220] - Unable to get Airtime version number.
    -- 
    -- 2014-01-28 22:19:29,334 DEBUG - [api_client.py : __call__() : line 134] - http://localhost:80/api/version/api_key/GKF6FZBJSRZA5YB6S9HX
    -- 2014-01-28 22:19:29,336 INFO - [api_client.py : is_server_compatible() : line 220] - Unable to get Airtime version number.
    -- 
    -- 
    -- 
    LIQUIDSOAP_PROCESS_ID          = FAILED
    LIQUIDSOAP_RUNNING_SECONDS     = 0
    LIQUIDSOAP_MEM_PERC            = 0%
    LIQUIDSOAP_CPU_PERC            = 0%
    -- Displaying log file /var/log/airtime/pypo-liquidsoap/ls_script.log
    -- 
    -- 
    MEDIA_MONITOR_PROCESS_ID       = FAILED
    MEDIA_MONITOR_RUNNING_SECONDS  = 0
    MEDIA_MONITOR_MEM_PERC         = 0%
    MEDIA_MONITOR_CPU_PERC         = 0%
    -- Displaying log file /var/log/airtime/media-monitor/media-monitor.log
    -- 2014-01-28 22:19:20,678 INFO - [Thread-1] [watchersyncer.py : __init__()] : LINE 19 - Created timeout thread...
    -- 2014-01-28 22:19:20,679 INFO - [Thread-1] [airtime.py : init_rabbit_mq()] : LINE 36 - Initializing RabbitMQ message consumer...
    -- 2014-01-28 22:19:20,689 INFO - [Thread-1] [airtime.py : init_rabbit_mq()] : LINE 48 - Initialized RabbitMQ consumer.
    -- 2014-01-28 22:19:20,689 DEBUG - [Thread-1] [api_client.py : __call__()] : LINE 134 - http://localhost:80/api/media-monitor-setup/format/json/api_key/GKF6FZBJSRZA5YB6S9HX
    -- 2014-01-28 22:19:20,695 INFO - [Thread-1] [syncdb.py : reload_directories()] : LINE 49 - HTTP Error 404: Not Found
    -- 
    -- 
    -- There appears to be a problem with your Airtime installation.

    What's up with this.

    Just reinstalled my whole VPS with Ubuntu (was centos) just so I could run this. Help!

    Post edited by Jester Roberts at 2014-02-12 01:58:42
  • 12 Comments sorted by
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    perhaps your vps is not a complete system, or your host configuration is not good. try to look at /var/log/airtime
  • I have one log file inside with...

    tail: cannot open `/var/log/airtime/pypo-liquidsoap/ls_script.log' for reading: No such file or directory


    There is also an empty pyro-liquidsoap folder

  • Ok I see what is happening and why this is a recurrent problem.(well I thing I have mimic this problem)

    @Jester Roberts
    Could you confirm for me,that when you were installing Airtime and it ask you,if you want airtime to be your dedicated host what solution you chose?
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • @Voisses Tech

    If you mean when it asks to configure the Apache server then I chose yes (main because I wash't sure)
    Then I tried 3 different FQDNs 
    1. airtime.mydomain.com
    2. mydomain.com
    3. localhost

    Only localhost works at all.
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    Hi @Jester,

    your /etc/hosts is well configured ?
  • At this point it is a fresh install of ubunto 12.04 with zpanel installed. So my hosts file contains just a few entries that panel made.

    fe00::0         ip6-localnet
    ff00::0         ip6-mcastprefix
    ff02::1         ip6-allnodes
    ff02::2         ip6-allrouters


    127.0.0.1 localhost.localdomain localhost zpanel.mydomain.com mydomain autoreply.zpanel.mydomain.com


    # Auto-generated hostname. Please do not remove this comment.


    m.y.i.p --save

    ::1             localhost ip6-localhost ip6-loopback


  • This is ip6 information and to me may make little difference.

    The biggest problem is that its not that Airtime is VHOST is not properly set up.

    So install Airtime on localhost,then modify the virtual host.

    My suggestion is that small organization running many different service/applications/servers should chose to use port change because of its flexibility.
    Large organisation I consider (,is in terms of application-not size) are with many websites

    Then configure your host as you chose.

    Try this  after you get Airtime to host locally http://forum.sourcefabric.org/discussion/16329/after-changing-ports-to-8080-airtime-fails

    And for reference

    http://forum.sourcefabric.org/discussion/comment/27908
    Post edited by Voisses Tech at 2014-01-29 22:17:24
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Actually I would prefer to run on a separate port of main domain but I'm just trying all options as I cannot get it to start at all.

    Try this  after you get Airtime to host locally

    By this do you mean having the FQDN set to localhost in setup?
    Because when I do that it fails to start with the errors listed in my first post.

    Is there anything special I need to do to get it to run locally or a guide?

    Thanks.
    Post edited by Jester Roberts at 2014-01-29 23:57:07
  • as @Albert Fr. suggest your /etc/hosts may be the problem.
    put another way. If you have your system locally  and wish to have that name resolve,you need to have proper name resolution.

    It makes little since if you have mysite.net but your Airtime machine cannot resolve it.

    So start with putting the IP numbers and test.

    The 3 ways to have a good name resolution is
    1. modify the /etc/host                               (apply mainly to localhost or dedicated host,virtal machine)
    2. set up DNS server -Dnsmaq is a simple one (ditto)
    3. Resolve by hosting provider  (VPS)
    I will post from my notes later when I get home

    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • ok so i purged airtime, then made an entry for airtime.mydomain.com in the hosts thats pointing to my VPS 's IP.
     Then ran 'apt-get install airtime' again and entered airtime.mydomain.com as FQDN during setup.... 

    Fails with same output as first post.

    I had airtime.mydomain.com setup as a subdomain in zPanel, but wasn't sure if this was right so i removed the subdomain from zPanel and tried again..... 

    Fails with same output as first post.

    So for completeness, I've tried the following as FQDN in the airtime setup.

    1. airtime.mydomain.com (with entry in /etc/hosts to point to VPS IP)
    2. mydomain.com (actually does resolve to VPS IP)
    3. actual IP address of VPS
    4. localhost

    In each case the install fails with the output listed in the first post.

    So can't even get it running on localhost to start with.

    One thing I notice is when I restart Apache I get...

    [warn] NameVirtualHost *:80 has no VirtualHosts


    Post edited by Jester Roberts at 2014-01-30 22:08:44
  • Your site  virtual host is not enable.


    Please see the last part of that post I explained why you get this warning and how to fix it

    You need to enable the virtual host


    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Ok finally got this sorted. I am using Zpanel which is overriding the vhost settings.

    For anyone experiencing similar problems here's the workaround that worked for me.

    Zpanel has a custom vhosts file here /etc/zpanel/configs/apache/httpd-vhost.conf but this file get's recreated every time there are changes to domains within Zpanel.

    We can use Zpanel->module admin->apache config->vhost overrides to add the airtime virtual host like so. Note the closing </virtualhost> tag at the beginning.

    </virtualhost>
    <virtualhost *:8040>
          ServerName localhost
          #ServerAlias www.example.com

          ServerAdmin me@mydomain.com

          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php

          SetEnv APPLICATION_ENV "production"

          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
          </Directory>

    I also needed to enter 8040 in the 'port override' field.

    Only caveat is that I had to add the override to the root domain or else NameVirtualHost *:8040  was not added to the beginning of the file. This in turn assign port 8040 to the Zpanel control panel, overriding airtime which I had manually change. This of course means it will have to be done each time there are changes to domains in zpanel but at least it's working!