× Warning! This forum is in archival status. New contributions may not work.
@airtime-liquidsoap issue
  • Vote Up0Vote Down MarinaMarina
    Posts: 296Member
    Hello!
    From time to time (once a month) I have some problems with Airtime workflow on my VPS (Ubuntu 12.04 LTS (PyGrub) 64 bit airtime 2.3.1)

    Sometimes the stream disappears. And @airtime-liquidsoap on the status page (systemstatus) in table service is being in the error status.
    The log file/var/log/airtime/pypo/pypo.log contains the following entries for this time:

    2013-04-05 10:39:48,493 DEBUG - [pypocli.py: liquidsoap_running_test (): line 129] - Checking to see if Liquidsoap is running
    2013-04-05 10:39:48,494 ERROR - [pypocli.py: liquidsoap_running_test (): line 139] - [Errno 111] Connection refused
    2013-04-05 10:39:48,494 WARNING - [pypocli.py: <module> (): line 172] - Liquidsoap not started yet. Sleeping one second and trying again


    Log /var/log/airtime/pypo-liquidsoap/ls_script.log does not contain any error records.
    In general, does not contain any entries for this time.

    The file /etc/airtime/liquidsoap.cfg simply disappears and when I try to create the file liquidsoap.cfg in that folder it's immediately deleted automatically.

    The server rebooting does not help. I twice reinstalled Airtime, too tired. I would like to sort out the problem.

    Please help me! Thank you!

    http://forum.sourcefabric.org/discussion/15336/pomogite-s-liquidsoap
  • 3 Comments sorted by
  • Vote Up0Vote Down Daniel JamesDaniel James
    Posts: 844Member, Sourcefabric Team
    Hi Marina,

    The probable reason that /etc/airtime/liquidsoap.cfg is deleted is because that file is auto generated by the System -> Streams page of the Airtime web interface. Please post the output of the command:

    ls -l /etc/airtime/

    The issue you are experiencing with Liquidsoap may be due to a bug in input.harbor which we are expecting to see a fix for in Liquidsoap 1.1.1, due to be released shortly.

    Cheers!

    Daniel


  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    I already had this problem via a beta version to a final
    the only solution was to purge the installation and reinstall...
  • Vote Up0Vote Down MarinaMarina
    Posts: 296Member
    Thank you guys!