× Warning! This forum is in archival status. New contributions may not work.
good web gui for Ubantu Apache/mysql
  • I was using webmin but that breaks Airtime, any thoughts?
  • 3 Comments sorted by
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    desintall webmin
  • @Albert FR: That is a good temporary solution :D :D


    What exactly breaks - do you have any logs or error messages? We haven't tested Airtime with webmin, it might be good to sort out these compatibility issues for Airtime 2.2. 
    Airtime Pro Hosting: http://airtime.pro
  • webmin breaks airtime , it removes key dependency apparently Airtime needs. Same thing I found with openpanel.  The errors were identical, why I am not entirly sure. here is the status file:


    AIRTIME_STATUS_URL             = http://localhost:80/api/status/format/json/api_key/%%api_key%%

    AIRTIME_SERVER_RESPONDING      = OK

    KERNEL_VERSION                 = UNKNOWN

    MACHINE_ARCHITECTURE           = UNKNOWN

    TOTAL_MEMORY_MBYTES            = UNKNOWN

    TOTAL_SWAP_MBYTES              = UNKNOWN

    AIRTIME_VERSION                = UNKNOWN

    OS                             = Ubuntu 10.04.4 LTS x86_64

    CPU                            = AMD Opteron(tm) Processor 4170 HE

    WEB_SERVER                     = A

    PLAYOUT_ENGINE_PROCESS_ID      = FAILED

    PLAYOUT_ENGINE_RUNNING_SECONDS = 0

    PLAYOUT_ENGINE_MEM_PERC        = 0%

    PLAYOUT_ENGINE_CPU_PERC        = 0%

    LIQUIDSOAP_PROCESS_ID          = FAILED

    LIQUIDSOAP_RUNNING_SECONDS     = 0

    LIQUIDSOAP_MEM_PERC            = 0%

    LIQUIDSOAP_CPU_PERC            = 0%

    MEDIA_MONITOR_PROCESS_ID       = FAILED

    MEDIA_MONITOR_RUNNING_SECONDS  = 0

    MEDIA_MONITOR_MEM_PERC         = 0%

    MEDIA_MONITOR_CPU_PERC         = 0%

    RABBITMQ_PROCESS_ID            = FAILED

    RABBITMQ_RUNNING_SECONDS       = 0

    RABBITMQ_MEM_PERC              = 0%

    RABBITMQ_CPU_PERC              = 0%



    -- There appears to be a problem with your Airtime installation.


    They both do a nice job managing things from a GUI but they make it impossible for Airtime to work. So I was a bit disappointing however, there is always another way......

    I did find a solution, unfortunately its  do everything via command line but I really needed to sort out the URL being hijacked by airtime despite my putting it on a subdomain during config and setting the proper DNS.

    I manually installed apache/mysql/php5 and was pissed that airtime stole the main domain no matter what. I changed the port, it broke it. Airtime wants port 80, and that is that. So... setting up any other config turned out to be futile because the only one Apache is responding to is airtime-vhost. So I needed the main domainname.com to show my website and I also wanted access to my phpadmin (also hijacked by airtime)

    Solution that worked for me was adding to the airtime-vhost file, restarted apache and bam ! it all worked.

    every step of the way running a sudo airtime-check-system to be sure. It was a pain to do but let me tell you, if i would have known this 4 images ago, I would have saved myself a week in frustration. Thank god for my host Rackspace cloud, saved my ass. I had saved my images after I got to a good point, burned them when it got fatel, just spun up a backup to do over. very handy.

    And the Angels sang::::::


    AIRTIME_STATUS_URL             = http://airtime.mydomaincom:80/api/status/format/json/api_key/%%api_key%%
    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = 2.6.32-31-server
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 504288
    TOTAL_SWAP_MBYTES              = UNKNOWN
    AIRTIME_VERSION                = 2.1.3
    OS                             = Ubuntu 10.04.4 LTS x86_64
    CPU                            = AMD Opteron(tm) Processor 4170 HE
    WEB_SERVER                     = Apache/2.2.14 (Ubuntu)
    PLAYOUT_ENGINE_PROCESS_ID      = 709
    PLAYOUT_ENGINE_RUNNING_SECONDS = 64960
    PLAYOUT_ENGINE_MEM_PERC        = 1.6%
    PLAYOUT_ENGINE_CPU_PERC        = 0.0%
    LIQUIDSOAP_PROCESS_ID          = 717
    LIQUIDSOAP_RUNNING_SECONDS     = 64960
    LIQUIDSOAP_MEM_PERC            = 3.1%
    LIQUIDSOAP_CPU_PERC            = 6.9%
    MEDIA_MONITOR_PROCESS_ID       = 690
    MEDIA_MONITOR_RUNNING_SECONDS  = 64960
    MEDIA_MONITOR_MEM_PERC         = 1.8%
    MEDIA_MONITOR_CPU_PERC         = 0.0%
    RABBITMQ_PROCESS_ID            = 856
    RABBITMQ_RUNNING_SECONDS       = 64955
    RABBITMQ_MEM_PERC              = 1.9%
    RABBITMQ_CPU_PERC              = 0.0%



    And here is the only file that makes it all work and is worth the edit (for me anyway)   /etc/apache2/sites-enabled/airtime-vhost (mydomain.com gets replaced with your domain name)


    *******************************************************************
    *******************************************************************

    <VirtualHost *:80>
          ServerName airtime.mydomain.com
          #ServerAlias www.example.com

          ServerAdmin rosariopanzarella@myemail.com

          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php

          SetEnv APPLICATION_ENV "production"

          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
          </Directory>
    </VirtualHost>
    #Main Website now
    <VirtualHost *:80>
          ServerName mydomain.com
          #ServerAlias www.example.com

          ServerAdmin rosariopanzarella@myemail.com

          DocumentRoot /var/www
          DirectoryIndex index.php

          SetEnv APPLICATION_ENV "production"

          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
    # RedirectMatch ^/$ /apache2-default/
         </Directory>
    </VirtualHost>

    # phpMyAdmin default Apache configuration

    Alias /phpmyadmin /usr/share/phpmyadmin

    <Directory /usr/share/phpmyadmin>
            Options FollowSymLinks
            DirectoryIndex index.php

            <IfModule mod_php5.c>
                    AddType application/x-httpd-php .php

                    php_flag magic_quotes_gpc Off
                    php_flag track_vars On
                    php_flag register_globals Off
                    php_value include_path .
            </IfModule>

    </Directory>

    *******************************************************************

    *******************************************************************

    Now, I have control, and my VPS is less bogged down with cpanel nonsense. I would have liked Airtime to work with OpenPanel because it makes management a cinch, but hey, perhaps you can work on that.