× Warning! This forum is in archival status. New contributions may not work.
Unable to login (first login)
  • Hello,
    i'm new here, so I say Hello ! to everybody
    I'm a bit familiar with Liquidsoap (after using it during 4 years)

    Airtime seems amazing, unfortunately after an automated install (2.0.2) on my Debian Squeeze
    i'm not able to logging in by using default  "admin" "admin" credentials
    i get only a new captcha after each try :(

    I've try to "dpkg-reconfigure airtime" and changing the password but it don"t ask for changing the password
    I also try to look into the database with phppgadmin with no success.

    there is a workaround ? a tips ?
    i'm like a children in front of a closed candy store :)

    Thank you very much.
    Salutations
  • 7 Comments sorted by
  • Hi Fred,

    There was a prompt to set the default password during the debian package setup. If you can't remember it, then here is a tip to reset it to default:

    sudo -u postgres psql airtime
    airtime=# UPDATE cc_subjs SET pass = md5('admin') where login = 'admin';
    Airtime Pro Hosting: http://airtime.pro
  • Hello,
    thank for your help.

    I run the command 
    airtime=# UPDATE cc_subjs SET pass = md5('admin') where login = 'admin';
    UPDATE 1
    But I still unable to connect.


    I have a look into my postgresql logs :



    2012-03-28 11:34:37 CEST FATAL: 
    authentification par mot de passe ?chou?e pour l'utilisateur  << airtime >>



    translated in english it mean "password identification failed for
    user" (airtime)

    shall i open specific port in iptable ?

    for information :

    netstat -taupen | grep 5432

    tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN

    107        12669130    18868/postgres

    and pg_hba.conf :

    # TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD

    # "local" is for Unix domain socket connections only

    local   all         all                               ident

    # IPv4 local connections:

    host    all         all         127.0.0.1/32          md5

    Post edited by Fred Percevault at 2012-03-28 08:08:50
  • This is the first time I've seen this problem, and everything in your config looks good.

    Is the postgresql db server on the same machine as the apache server?
    Airtime Pro Hosting: http://airtime.pro
  • yes postgre on the same machine
    (encoding LATIN1 can't switch to UTF-8 because of my local) if it's important (?)

    May the problem coming from vhost or apache issue ?
    i have one website/domain running on this machine
    domain.net
    now i have added a vhost 
    airtime.domain.net

    my vhost.log when i try to connect :

    airtime.domain.net:80 193.XXX.XXX.9 - -
    [29/Mar/2012:13:56:47 +0200] "POST /login HTTP/1.1" 302 435 "http://airtime.domain.net/login"
    "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.19 (KHTML, like Gecko)
    Chrome/18.0.1025.140 Safari/535.19"



    airtime.domain.net:80 193.XXX.XXX.9 - - [29/Mar/2012:13:56:47
    +0200] "GET /login HTTP/1.1" 200 1680 "http://airtime.domain.net/login"
    "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.19 (KHTML, like Gecko)
    Chrome/18.0.1025.140 Safari/535.19"

    and i get :

    localhost.localdomain:80 127.0.0.1 - - [29/Mar/2012:16:08:57 +0200] "GET /api/schedule/api_key/XKKBVZKUQZT8GHLVHMCG HTTP/1.0" 404 426 "-" "Python-urllib/1.17"
    localhost.localdomain:80 127.0.0.1 - - [29/Mar/2012:16:09:18 +0200] "GET /api/recorded-shows/format/json/api_key/XKKBVZKUQZT8GHLVHMCG HTTP/1.0" 404 444 "-" "Python-urllib/1.17"

    + some :

    localhost.localdomain:80 ::1 - - [29/Mar/2012:15:51:26 +0200] "OPTIONS * HTTP/1.0" 200 136 "-" "Apache (internal dummy connection)"
    Post edited by Fred Percevault at 2012-03-29 10:30:52
  • Airtime database should use the UTF-8 encoding. Why can't you change this, I'm almost certain that each database can have its own encoding, and so having Airtime db as UTF-8 should not affect any other databases you are running on the server.

    Just to verify, please enter

    psql airtime -c 'SHOW SERVER_ENCODING'

    to see your database encoding type.

    If it is ASCII or LATIN1 you should upgrade it to UTF-8. I found a link here to do that:

    I'm also going to patch the installation script of Airtime 2.1 to force UTF-8 so that we don't have this problem in the future.
    Post edited by Martin Konecny at 2012-03-29 17:04:08
    Airtime Pro Hosting: http://airtime.pro
  • Thank you very much i wil check that tomorrow.
    maybe i will reinstall postgresql

    When i try to create a database "airtime2" for instance
    CREATE DATABASE airtime2 ENCODING 'UNICODE'; 
    postgresql reply :
    ERREUR:  l'encodage UTF8 ne correspond pas � la locale fr_FR
    DÉTAIL : Le param�tre LC_CTYPE choisi n�cessite l'encodage LATIN1.

    which mean
    UTF8 does not match your local fr_FR
    LC_CTYPE parameter chosen need LATIN1 encoding

    My Debian support UTF8 (i have checked by running dpkg-reconfigure locale)

    [*] fr_FR@euro ISO-8859-15                                                               
    [*] fr_FR ISO-8859-1 
    [*] fr_FR.UTF-8@euro UTF-8
    [*] fr_FR.UTF-8 UTF-8 

    I will be back if needed..thank you very much again
    your help is really appreciated.
  • Hello guys!

    I have done a fresh install, on a virtual machine (vagrant, virtual box), Ubuntu 14.04.1 LTS x86_64, using airtime-easy-setup (http://apt.sourcefabric.org/misc/airtime-easy-setup.deb)
    as described on: http://sourcefabric.booktype.pro/airtime-25-for-broadcasters/easy-setup/

    The installation seems to work fine.
    I can access and login to the Icecast admin web page (http://airtime:8000),
    and can access the Airtime login form: https://airtime/login
    But the authentication of the admin user fail.

    I have also executed the sudo dpkg-reconfigure airtime to ensure that the passwords was ok.

    Am I missing something?

    Thanks for your help.



    Here is the result of the installation:
    *** Verifying your system environment, running airtime-check-system ***
    AIRTIME_STATUS_URL             = http://vagrant-ubuntu-trusty-64:80/api/status/format/json/api_key/%%api_key%%
    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = 3.13.0-37-generic
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 1017844
    TOTAL_SWAP_MBYTES              = 0
    AIRTIME_VERSION                = 2.5.1
    OS                             = Ubuntu 14.04.1 LTS x86_64
    CPU                            = Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
    WEB_SERVER                     = Apache/2.4.7 (Ubuntu)
    PLAYOUT_ENGINE_PROCESS_ID      = 21147
    PLAYOUT_ENGINE_RUNNING_SECONDS = 12
    PLAYOUT_ENGINE_MEM_PERC        = 3.0%
    PLAYOUT_ENGINE_CPU_PERC        = 0.0%
    LIQUIDSOAP_PROCESS_ID          = -1
    LIQUIDSOAP_RUNNING_SECONDS     = 0
    LIQUIDSOAP_MEM_PERC            = 0.0%
    LIQUIDSOAP_CPU_PERC            = 0.0%
    MEDIA_MONITOR_PROCESS_ID       = 21006
    MEDIA_MONITOR_RUNNING_SECONDS  = 14
    MEDIA_MONITOR_MEM_PERC         = 1.6%
    MEDIA_MONITOR_CPU_PERC         = 0.0%
    -- Your installation of Airtime looks OK!