× Warning! This forum is in archival status. New contributions may not work.
Don`t understand the politics of using The Journal template
  • Hello, people! I found a post of  Sava Tatić on the forum where it is written:

    "Just FYI, we are no longer using Woo themes due to license (and, shall we say, philosophical) incompatibilities with the said company. So whatever you do, please don't base your publication on The Journal." link

    Then, I can`t understand why this temlate is included in 3.5.3 version on the download page at sourceforge? Why not to remove it from installation pack and replace with ZEN template?

    Post edited by Serge Kojan at 2012-03-07 19:46:03
  • 8 Comments sorted by
  • Vote Up0Vote Down Daniel JamesDaniel James
    Posts: 844Member, Sourcefabric Team
    The original Woo theme that we used as the basis of The Journal was licensed to Sourcefabric under the GNU GPL, so it's OK for us to redistribute. See:

    http://www.woothemes.com/2009/06/woothemes-gpled/

    > Why not to remove it from
    > installation pack and replace with ZEN template?

    If there were more releases due in the Newscoop 3.x series, we might have done that. However the Newscoop 4.0 release is due very shortly, and this will have a brand new theme with loads of cool features.

    In the meantime, you can install ZEN* on a Newscoop 3.5.3 server if you wish.
  • Hi, Daniel. I tried to install ZEN theme like it is written in the manual. It installs but without images and with broken css.
  • Vote Up0Vote Down Daniel JamesDaniel James
    Posts: 844Member, Sourcefabric Team
    Hi Serge,

    I would suggest using the demo site http://newscoop-demo.sourcefabric.org/admin/templates/ for comparison, as that is running ZEN* on Newscoop 3.5.3. You will need to log in as a guest, the password is shown on the login page at http://newscoop-demo.sourcefabric.org/admin/

    Cheers!

    Daniel
  • Vote Up0Vote Down Daniel JamesDaniel James
    Posts: 844Member, Sourcefabric Team
    p.s. if you do not have a Newscoop 3.5.3 site in production yet, I would recommend installing 4.0.0-RC2 because you get ZEN* included.
  • I tried already three hostings and can`t install 4.0 RC2, maybe something will change with the final release of 4.0.(I hope) I don`t understand why the 4-th version can`t be installed on php 5.2. In Ukraine only several hosters have php 5.3
  • it's because of the library we're using for persistence (doctrine 2 orm) which is using namespaces. and now with php 5.4 out 5.2 is a bit outdated
  • Vote Up0Vote Down Daniel JamesDaniel James
    Posts: 844Member, Sourcefabric Team
    Hi Serge, if hosting is proving difficult locally, let us know and we can work something out for you. See http://www.sourcefabric.com/en/newscooppro/ for details. We have a Russian-speaking support team too.

    Cheers!

    Daniel
  • Vote Up0Vote Down Sava TatićSava Tatić
    Posts: 113Member, Administrator, Sourcefabric Team
    Just to clarify Petr's post, the minimum version of PHP we require for Newscoop 4.0 is PHP 5.3 (we are using some new features that were introduced with that version). So please look for hosting that fulfills this criterion. Or talk to us, if your nonprofit sites fit with our mission, we could consider giving you a special rate.