× Warning! This forum is in archival status. New contributions may not work.
[campcaster-support] help!!! please and thank you
  • > Hello,
  • 3 Comments sorted by
  • Hi Pablo Lozano,

    Sorry for the delay but glade to have developers around. It's clear
    these packages are not build for Musix, so we've got to hack some stuff.
    It's simple setting files.

    Do you think you are able to build Campcaster from it's source code?
    It's good to know you are gonna build a 1.4 pre release, nobody has yet,
    based on Gstreamer 0.10. Please follow the wiki setup step by step.

    http://code.campware.org/projects/campcaster/wiki/DevelopmentEnvironment

    we will be available in IRC, please checkin for questions. Or drop a
    mail in the Developers Mailing list, that's were we are.

    http://code.campware.org/projects/campcaster/wiki/DeveloperMeetings


    Thanks,

    Frans van Berckel

    On Wed, 2008-03-19 at 00:16 +0000, Pablo Lozano wrote:
    > > Hello, í`m tryn to install campcaster in a debian based distro (Musix) and i recieve this output after doing apt-get install campcaster-libs campcaster-station campcaster-studio , can anyone helpme please? BTW, i am using LAMPP becasue i do web developing, there is a way to install campcaster in my htdocs folder using LAMPP? Thank you very much!
    > >
    > > Regards, from Argentina, here is the output:
    > >
    > > Making post-install steps for Campcaster Station.
    > >
    > > Using the following installation parameters:
    > >
    > > installation directory: /opt/campcaster
    > > database server: localhost
    > > database: Campcaster
    > > database user: campcaster
    > > database user password: campcaster
    > > apache daemon group: www-data
    > > apache document root: /var/www
    > > postgresql data directory: /etc/postgresql/8.1/main
    > > postgresql init script: /etc/init.d/postgresql-8.1
    > >
    > > Checking for required tools...
    > > Executable sed found...
    > > Executable psql found...
    > > Executable php found...
    > > Executable odbcinst found...
    > > Modifying postgresql access permissions...
    > > Stopping PostgreSQL 8.1 database server: main.
    > > Starting PostgreSQL 8.1 database server: main.
    > > Creating database for Campcaster scheduler.
    > >
    > > Using the following parameters:
    > >
    > > database server: localhost
    > > database: Campcaster
    > > database user: campcaster
    > > database user password: campcaster
    > >
    > > Checking for required tools...
    > > Executable su found...
    > > Executable psql found...
    > > Creating database and database user...
    > > Sin directorio, entrando con HOME=/
    > > ERROR: el rol «campcaster» ya existe
    > > Sin directorio, entrando con HOME=/
    > > ERROR: la base de datos «Campcaster» ya existe
    > > Done.
    > > Creating ODBC data source for Campcaster scheduler.
    > >
    > > Using the following installation parameters:
    > >
    > > database server: localhost
    > > database: Campcaster
    > >
    > > Checking for required tools...
    > > Executable sed found...
    > > Executable grep found...
    > > Executable odbcinst found...
    > > Removing old ODBC PostgreSQL driver...
    > > PostgreSQL_Campcaster has been deleted (if it existed at all) because its usage count became zero
    > > Registering ODBC PostgreSQL driver...
    > > odbcinst: Driver installed. Usage count increased to 1.
    > > Target directory is /etc
    > > Registering Campcaster ODBC data source...
    > > Done.
    > > Setting up directory permissions...
    > > Configuring apache ...
    > > /etc/apache/conf.d Y
    > > done
    > > Restarting apache...
    > > apache Y
    > > Configuration syntax error detected, not starting/reloading...
    > > apache2: Syntax error on line 190 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/httpd.conf: No such file or directory
    > > failed!
    > > done
    > > Creating symlinks...
    > > Initializing database...
    > > *************************
    > > * StorageServer Install *
    > > *************************
    > >
    > > Warning: require_once(../conf.php): failed to open stream: No such file or directory in /opt/campcaster/var/Campcaster/storageServer/var/install/install.php on line 29
    > >
    > > Fatal error: require_once(): Failed opening required '../conf.php' (include_path='.:/usr/share/php:/usr/share/pear') in /opt/campcaster/var/Campcaster/storageServer/var/install/install.php on line 29
    > > dpkg: error al procesar campcaster-station (--configure):
    > > el subproceso post-installation script devolvió el código de salida de error 1
    > > dpkg: problemas de dependencias impiden la configuración de campcaster-studio:
    > > campcaster-studio depende de campcaster-station (= 1.2.0-1debian1); sin embargo:
    > > El paquete `campcaster-station' no está configurado todavía.
    > > dpkg: error al procesar campcaster-studio (--configure):
    > > problemas de dependencias - se deja sin configurar
    > > Se encontraron errores al procesar:
    > > campcaster-station
    > > campcaster-studio
    > > E: Sub-process /usr/bin/dpkg returned an error code (1)
    > > Un paquete no se pudo instalar. Intentado recuperarse:
    > > Configurando campcaster-station (1.2.0-1debian1) ...
    > > Making post-install steps for Campcaster Station.
    > >
    > > Using the following installation parameters:
    > >
    > > installation directory: /opt/campcaster
    > > database server: localhost
    > > database: Campcaster
    > > database user: campcaster
    > > database user password: campcaster
    > > apache daemon group: www-data
    > > apache document root: /var/www
    > > postgresql data directory: /etc/postgresql/8.1/main
    > > postgresql init script: /etc/init.d/postgresql-8.1
    > >
    > > Checking for required tools...
    > > Executable sed found...
    > > Executable psql found...
    > > Executable php found...
    > > Executable odbcinst found...
    > > Modifying postgresql access permissions...
    > > Stopping PostgreSQL 8.1 database server: main.
    > > Starting PostgreSQL 8.1 database server: main.
    > > Creating database for Campcaster scheduler.
    > >
    > > Using the following parameters:
    > >
    > > database server: localhost
    > > database: Campcaster
    > > database user: campcaster
    > > database user password: campcaster
    > >
    > > Checking for required tools...
    > > Executable su found...
    > > Executable psql found...
    > > Creating database and database user...
    > > Sin directorio, entrando con HOME=/
    > > ERROR: el rol «campcaster» ya existe
    > > Sin directorio, entrando con HOME=/
    > > ERROR: la base de datos «Campcaster» ya existe
    > > Done.
    > > Creating ODBC data source for Campcaster scheduler.
    > >
    > > Using the following installation parameters:
    > >
    > > database server: localhost
    > > database: Campcaster
    > >
    > > Checking for required tools...
    > > Executable sed found...
    > > Executable grep found...
    > > Executable odbcinst found...
    > > Removing old ODBC PostgreSQL driver...
    > > PostgreSQL_Campcaster has been deleted (if it existed at all) because its usage count became zero
    > > Registering ODBC PostgreSQL driver...
    > > odbcinst: Driver installed. Usage count increased to 1.
    > > Target directory is /etc
    > > Registering Campcaster ODBC data source...
    > > Done.
    > > Setting up directory permissions...
    > > Configuring apache ...
    > > /etc/apache/conf.d Y
    > > done
    > > Restarting apache...
    > > apache Y
    > > Configuration syntax error detected, not starting/reloading...
    > > apache2: Syntax error on line 190 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/httpd.conf: No such file or directory
    > > failed!
    > > done
    > > Creating symlinks...
    > > Initializing database...
    > > *************************
    > > * StorageServer Install *
    > > *************************
    > >
    > > Warning: require_once(../conf.php): failed to open stream: No such file or directory in /opt/campcaster/var/Campcaster/storageServer/var/install/install.php on line 29
    > >
    > > Fatal error: require_once(): Failed opening required '../conf.php' (include_path='.:/usr/share/php:/usr/share/pear') in /opt/campcaster/var/Campcaster/storageServer/var/install/install.php on line 29
    > > dpkg: error al procesar campcaster-station (--configure):
    > > el subproceso post-installation script devolvió el código de salida de error 1
    > > dpkg: problemas de dependencias impiden la configuración de campcaster-studio:
    > > campcaster-studio depende de campcaster-station (= 1.2.0-1debian1); sin embargo:
    > > El paquete `campcaster-station' no está configurado todavía.
    > > dpkg: error al procesar campcaster-studio (--configure):
    > > problemas de dependencias - se deja sin configurar
    > > Se encontraron errores al procesar:
    > > campcaster-station
    > > campcaster-studio
    > > _________________________________________________________________
    > > Express yourself instantly with MSN Messenger! Download today it's FREE!
    > > http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/
    >
    > _________________________________________________________________
    > Express yourself instantly with MSN Messenger! Download today it's FREE!
    > http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/
    >
  • I have posted somewhere but I would like to configure my computer with campcaster and I just saw what happens when I start campcaster-studio

    qbitz@Qbitz:~$ campcaster-studio
    Campcaster-Studio 1.4.0
    Copyright (c) 2004 Media Development Loan Fund under the GNU GPL
    using configuration file: /home/qbitz/.campcaster/campcaster-studio.xml

    (campcaster-studio:7523): libglade-WARNING **: Error loading image: El archivo de imagen «/usr/share/campcaster/www/glade/.» no contiene datos

    (campcaster-studio:7523): libglade-WARNING **: could not convert string to type `GdkPixbuf' for property `icon'

    (campcaster-studio:7523): libglade-WARNING **: Error loading image: El archivo de imagen «/usr/share/campcaster/www/glade/.» no contiene datos

    (campcaster-studio:7523): libglade-WARNING **: could not convert string to type `GdkPixbuf' for property `icon'
    ERROR: Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2. xml
    ERROR: Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2. xml
    Error in XmlRpcClient::writeRequest: write error (error 111).

    and I get Campcaster-studio "The scheduler server is not available."

    When I upload audio files this is what I get

    TagLib: MPEG::Header::parse() -- Invalid sample rate.
    TagLib: MPEG::Header::parse() -- Invalid sample rate.
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
    <HTML><HEAD><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
    <TITLE>ERROR: The requested URL could not be retrieved</TITLE>
    <STYLE type="text/css">< !--BODY{background-color:#ffffff;font-family:verdana,sans-se rif}PRE{font-family:sans-serif}-- ></STYLE>
    </HEAD><BODY>
    <H1>ERROR</H1>
    <H2>The requested URL could not be retrieved</H2>
    <HR noshade size="1px">
    <P>
    While trying to process the request:
    <PRE>
    PUT /campcaster/storageServer/var/xmlrpc/put.php?token=6c0bf44b6 c81f076 HTTP/1.1
    Host: localhost
    Accept: */*
    Proxy-Connection: Keep-Alive
    Content-Length: 1737473
    Expect: 100-continue

    </PRE>
    <P>
    The following error was encountered:
    <UL>
    <LI>
    <STRONG>
    Invalid Request
    </STRONG>
    </UL>

    <P>
    Some aspect of the HTTP Request is invalid. Possible problems:
    <UL>
    <LI>Missing or unknown request method
    <LI>Missing URL
    <LI>Missing HTTP Identifier (HTTP/1.0)
    <LI>Request is too large
    <LI>Content-Length missing for POST or PUT requests
    <LI>Illegal character in hostname; underscores are not allowed
    </UL>
    <P>Your cache administrator is <A HREF="mailto:webmaster">webmaster</A>.

    <BR clear="all">
    <HR noshade size="1px">
    <ADDRESS>
    Generated Mon, 14 Jun 2010 18:11:44 GMT by aj-yekbal (squid/2.7.STABLE3)
    </ADDRESS>
    </BODY></HTML>
    XML-RPC method 'locstor.storeAudioClipClose' returned error message:
    805 - xr_storeAudioClipClose: BasicStor::bsClosePut: md5sum does not match (token=6c0bf44b6c81f076) [78a0d08a913de0df0cda990c499545a3/d41d8cd98f00b204e9800998ec f8427e]

    And, when I try to start the Scheduler in the options button, then just goes the windows blank of the program, I have managed to install it by adding repos in ubuntu 9.10

    I need to get this working because I'm a representative of the community radio organization in Guatemala and I would like to get this working and in some way to share programs with other community radio stations.
  • Hi,

    You should probably check a few things:

    1) Are all the packages correctly installed? There should be campcaster-station, campcaster-studio, campcaster-data, etc.

    2) Do you have all the dependencies, especially Postgres, installed and running correctly? If you installed from the 64Studio repository, this should be OK.

    3) Try restarting the scheduler with this:

    cd /etc/init.d
    sudo ./campcaster-scheduler stop
    sudo ./campcaster-scheduler start

    At least then you should have the scheduler running.

    Hope this helps. I'm also going to tell our Latin America representative, Claudia Cruz in Guatemala City, to get in touch with you.


    Douglas Arellanes
    Sourcefabric
    Douglas Arellanes
    Director of Innovation
    Sourcefabric, o.p.s.

    Find a way or make one.