× Warning! This forum is in archival status. New contributions may not work.
[campsite-dev] Host Not found problem
  • I got "Host Not found" message on my system. Thiss message means, that
    apache cannot communicate with parser.
    I logged as root to the system and tried telnet to proper port. The
    connection was refused, as Parser registered conenction from my ip and not
    from localhost.
    Therefore I tried to change host allowed for the parser 10.0.0.4, which is
    ip of the webserver.
    However parser needs to have localhost there. So I entered both, localhost
    and 10.0.0.4 separated by space, which was accepted.
    But the situation is the same.
    Than I tried change parser IP in admin interface part. It however expects
    only localhost and does not allow me to enter any other IP that localhost.

    I find this behaveour at least strange.

    Secon, how can I get latest version of campsite from cvs? Any short how-to?

    Ondra

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • 6 Comments sorted by
  • I solved this problem by following:
    Set Parsers allowed ips: 10.0.0.4 127.0.0.1
    Set Admin interface ip: 127.0.0.1
    And everything works.
    Ondra

    -----Original Message-----
    From: Ondra Koutek [mailto:kouteko@tol.cz]
    Sent: Tuesday, November 16, 2004 3:17 PM
    To: campsite-dev@campware.org
    Subject: [campsite-dev] Host Not found problem

    I got "Host Not found" message on my system. Thiss message means, that
    apache cannot communicate with parser.
    I logged as root to the system and tried telnet to proper port. The
    connection was refused, as Parser registered conenction from my ip and not
    from localhost.
    Therefore I tried to change host allowed for the parser 10.0.0.4, which is
    ip of the webserver.
    However parser needs to have localhost there. So I entered both, localhost
    and 10.0.0.4 separated by space, which was accepted.
    But the situation is the same.
    Than I tried change parser IP in admin interface part. It however expects
    only localhost and does not allow me to enter any other IP that localhost.

    I find this behaveour at least strange.

    Secon, how can I get latest version of campsite from cvs? Any short how-to?

    Ondra

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • That means your system was configured badly: any decent system has localhost
    defined in resolv.conf. The script returned "Host not found" because localhost
    was not defined, very simple.

    Mugur

    --- Ondra Koutek wrote:

    > I solved this problem by following:
    > Set Parsers allowed ips: 10.0.0.4 127.0.0.1
    > Set Admin interface ip: 127.0.0.1
    > And everything works.
    > Ondra
    >
    > -----Original Message-----
    > From: Ondra Koutek [mailto:kouteko@tol.cz]
    > Sent: Tuesday, November 16, 2004 3:17 PM
    > To: campsite-dev@campware.org
    > Subject: [campsite-dev] Host Not found problem
    >
    > I got "Host Not found" message on my system. Thiss message means, that
    > apache cannot communicate with parser.
    > I logged as root to the system and tried telnet to proper port. The
    > connection was refused, as Parser registered conenction from my ip and not
    > from localhost.
    > Therefore I tried to change host allowed for the parser 10.0.0.4, which is
    > ip of the webserver.
    > However parser needs to have localhost there. So I entered both, localhost
    > and 10.0.0.4 separated by space, which was accepted.
    > But the situation is the same.
    > Than I tried change parser IP in admin interface part. It however expects
    > only localhost and does not allow me to enter any other IP that localhost.
    >
    > I find this behaveour at least strange.
    >
    > Secon, how can I get latest version of campsite from cvs? Any short how-to?
    >
    > Ondra
    >
    >
    >




    __________________________________
    Do you Yahoo!?
    Meet the all-new My Yahoo! - Try it today!
    http://my.yahoo.com

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • I have /etc/hosts file defining localhost and host localhost returns proper
    value.
    Is it possible that Campsite uses some old method resolving IP that was
    changed in FreeBSD 5.3?
    Ondra

    -----Original Message-----
    From: Mugur Rus [mailto:mugur1973@yahoo.com]
    Sent: Tuesday, November 16, 2004 4:26 PM
    To: campsite-dev@campware.org
    Subject: RE: [campsite-dev] Host Not found problem

    That means your system was configured badly: any decent system has localhost
    defined in resolv.conf. The script returned "Host not found" because
    localhost was not defined, very simple.

    Mugur

    --- Ondra Koutek wrote:

    > I solved this problem by following:
    > Set Parsers allowed ips: 10.0.0.4 127.0.0.1 Set Admin interface ip:
    > 127.0.0.1 And everything works.
    > Ondra
    >
    > -----Original Message-----
    > From: Ondra Koutek [mailto:kouteko@tol.cz]
    > Sent: Tuesday, November 16, 2004 3:17 PM
    > To: campsite-dev@campware.org
    > Subject: [campsite-dev] Host Not found problem
    >
    > I got "Host Not found" message on my system. Thiss message means, that
    > apache cannot communicate with parser.
    > I logged as root to the system and tried telnet to proper port. The
    > connection was refused, as Parser registered conenction from my ip and
    > not from localhost.
    > Therefore I tried to change host allowed for the parser 10.0.0.4,
    > which is ip of the webserver.
    > However parser needs to have localhost there. So I entered both,
    > localhost and 10.0.0.4 separated by space, which was accepted.
    > But the situation is the same.
    > Than I tried change parser IP in admin interface part. It however
    > expects only localhost and does not allow me to enter any other IP that
    localhost.
    >
    > I find this behaveour at least strange.
    >
    > Secon, how can I get latest version of campsite from cvs? Any short
    how-to?
    >
    > Ondra
    >
    >
    >




    __________________________________
    Do you Yahoo!?
    Meet the all-new My Yahoo! - Try it today!
    http://my.yahoo.com

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • Campsite uses the standard method of resolving host names so if "host
    localhost" returns an address campsite scripts should work too. I don't know
    what happened.

    Mugur

    --- Ondra Koutek wrote:

    > I have /etc/hosts file defining localhost and host localhost returns proper
    > value.
    > Is it possible that Campsite uses some old method resolving IP that was
    > changed in FreeBSD 5.3?
    > Ondra
    >
    > -----Original Message-----
    > From: Mugur Rus [mailto:mugur1973@yahoo.com]
    > Sent: Tuesday, November 16, 2004 4:26 PM
    > To: campsite-dev@campware.org
    > Subject: RE: [campsite-dev] Host Not found problem
    >
    > That means your system was configured badly: any decent system has localhost
    > defined in resolv.conf. The script returned "Host not found" because
    > localhost was not defined, very simple.
    >
    > Mugur
    >
    > --- Ondra Koutek wrote:
    >
    > > I solved this problem by following:
    > > Set Parsers allowed ips: 10.0.0.4 127.0.0.1 Set Admin interface ip:
    > > 127.0.0.1 And everything works.
    > > Ondra
    > >
    > > -----Original Message-----
    > > From: Ondra Koutek [mailto:kouteko@tol.cz]
    > > Sent: Tuesday, November 16, 2004 3:17 PM
    > > To: campsite-dev@campware.org
    > > Subject: [campsite-dev] Host Not found problem
    > >
    > > I got "Host Not found" message on my system. Thiss message means, that
    > > apache cannot communicate with parser.
    > > I logged as root to the system and tried telnet to proper port. The
    > > connection was refused, as Parser registered conenction from my ip and
    > > not from localhost.
    > > Therefore I tried to change host allowed for the parser 10.0.0.4,
    > > which is ip of the webserver.
    > > However parser needs to have localhost there. So I entered both,
    > > localhost and 10.0.0.4 separated by space, which was accepted.
    > > But the situation is the same.
    > > Than I tried change parser IP in admin interface part. It however
    > > expects only localhost and does not allow me to enter any other IP that
    > localhost.
    > >
    > > I find this behaveour at least strange.
    > >
    > > Secon, how can I get latest version of campsite from cvs? Any short
    > how-to?
    > >
    > > Ondra
    > >
    > >
    > >
    >
    >
    >
    >
    > __________________________________
    > Do you Yahoo!?
    > Meet the all-new My Yahoo! - Try it today!
    > http://my.yahoo.com
    >
    >
    >
    >




    __________________________________
    Do you Yahoo!?
    Meet the all-new My Yahoo! - Try it today!
    http://my.yahoo.com

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • After last update host localhost stopped working. I use IPS instead and I am
    fine.
    Thank you, sorry to bother.
    Ondra

    -----Original Message-----
    From: Mugur Rus [mailto:mugur1973@yahoo.com]
    Sent: Tuesday, November 16, 2004 4:36 PM
    To: campsite-dev@campware.org
    Subject: RE: [campsite-dev] Host Not found problem

    Campsite uses the standard method of resolving host names so if "host
    localhost" returns an address campsite scripts should work too. I don't know
    what happened.

    Mugur

    --- Ondra Koutek wrote:

    > I have /etc/hosts file defining localhost and host localhost returns
    > proper value.
    > Is it possible that Campsite uses some old method resolving IP that
    > was changed in FreeBSD 5.3?
    > Ondra
    >
    > -----Original Message-----
    > From: Mugur Rus [mailto:mugur1973@yahoo.com]
    > Sent: Tuesday, November 16, 2004 4:26 PM
    > To: campsite-dev@campware.org
    > Subject: RE: [campsite-dev] Host Not found problem
    >
    > That means your system was configured badly: any decent system has
    > localhost defined in resolv.conf. The script returned "Host not found"
    > because localhost was not defined, very simple.
    >
    > Mugur
    >
    > --- Ondra Koutek wrote:
    >
    > > I solved this problem by following:
    > > Set Parsers allowed ips: 10.0.0.4 127.0.0.1 Set Admin interface ip:
    > > 127.0.0.1 And everything works.
    > > Ondra
    > >
    > > -----Original Message-----
    > > From: Ondra Koutek [mailto:kouteko@tol.cz]
    > > Sent: Tuesday, November 16, 2004 3:17 PM
    > > To: campsite-dev@campware.org
    > > Subject: [campsite-dev] Host Not found problem
    > >
    > > I got "Host Not found" message on my system. Thiss message means,
    > > that apache cannot communicate with parser.
    > > I logged as root to the system and tried telnet to proper port. The
    > > connection was refused, as Parser registered conenction from my ip
    > > and not from localhost.
    > > Therefore I tried to change host allowed for the parser 10.0.0.4,
    > > which is ip of the webserver.
    > > However parser needs to have localhost there. So I entered both,
    > > localhost and 10.0.0.4 separated by space, which was accepted.
    > > But the situation is the same.
    > > Than I tried change parser IP in admin interface part. It however
    > > expects only localhost and does not allow me to enter any other IP
    > > that
    > localhost.
    > >
    > > I find this behaveour at least strange.
    > >
    > > Secon, how can I get latest version of campsite from cvs? Any short
    > how-to?
    > >
    > > Ondra
    > >
    > >
    > >
    >
    >
    >
    >
    > __________________________________
    > Do you Yahoo!?
    > Meet the all-new My Yahoo! - Try it today!
    > http://my.yahoo.com
    >
    >
    >
    >




    __________________________________
    Do you Yahoo!?
    Meet the all-new My Yahoo! - Try it today!
    http://my.yahoo.com

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • Just for info, in FreeBSD 5.2.1 host resolved corectly localhost.
    Since 5.3 system expects you are running DNS service to keep named
    consistency and /etc/hosts are ignored.
    Now host localhost returns proper IP, but campsite does not resolve it
    either.
    I will try to debug it on sam not live campsite instance to report more
    later, as it is not vital (I can use IPS instead of word localhost)
    Ondra

    -----Original Message-----
    From: Ondra Koutek [mailto:kouteko@tol.cz]
    Sent: Tuesday, November 16, 2004 5:00 PM
    To: campsite-dev@campware.org
    Subject: RE: [campsite-dev] Host Not found problem

    After last update host localhost stopped working. I use IPS instead and I am
    fine.
    Thank you, sorry to bother.
    Ondra

    -----Original Message-----
    From: Mugur Rus [mailto:mugur1973@yahoo.com]
    Sent: Tuesday, November 16, 2004 4:36 PM
    To: campsite-dev@campware.org
    Subject: RE: [campsite-dev] Host Not found problem

    Campsite uses the standard method of resolving host names so if "host
    localhost" returns an address campsite scripts should work too. I don't know
    what happened.

    Mugur

    --- Ondra Koutek wrote:

    > I have /etc/hosts file defining localhost and host localhost returns
    > proper value.
    > Is it possible that Campsite uses some old method resolving IP that
    > was changed in FreeBSD 5.3?
    > Ondra
    >
    > -----Original Message-----
    > From: Mugur Rus [mailto:mugur1973@yahoo.com]
    > Sent: Tuesday, November 16, 2004 4:26 PM
    > To: campsite-dev@campware.org
    > Subject: RE: [campsite-dev] Host Not found problem
    >
    > That means your system was configured badly: any decent system has
    > localhost defined in resolv.conf. The script returned "Host not found"
    > because localhost was not defined, very simple.
    >
    > Mugur
    >
    > --- Ondra Koutek wrote:
    >
    > > I solved this problem by following:
    > > Set Parsers allowed ips: 10.0.0.4 127.0.0.1 Set Admin interface ip:
    > > 127.0.0.1 And everything works.
    > > Ondra
    > >
    > > -----Original Message-----
    > > From: Ondra Koutek [mailto:kouteko@tol.cz]
    > > Sent: Tuesday, November 16, 2004 3:17 PM
    > > To: campsite-dev@campware.org
    > > Subject: [campsite-dev] Host Not found problem
    > >
    > > I got "Host Not found" message on my system. Thiss message means,
    > > that apache cannot communicate with parser.
    > > I logged as root to the system and tried telnet to proper port. The
    > > connection was refused, as Parser registered conenction from my ip
    > > and not from localhost.
    > > Therefore I tried to change host allowed for the parser 10.0.0.4,
    > > which is ip of the webserver.
    > > However parser needs to have localhost there. So I entered both,
    > > localhost and 10.0.0.4 separated by space, which was accepted.
    > > But the situation is the same.
    > > Than I tried change parser IP in admin interface part. It however
    > > expects only localhost and does not allow me to enter any other IP
    > > that
    > localhost.
    > >
    > > I find this behaveour at least strange.
    > >
    > > Secon, how can I get latest version of campsite from cvs? Any short
    > how-to?
    > >
    > > Ondra
    > >
    > >
    > >
    >
    >
    >
    >
    > __________________________________
    > Do you Yahoo!?
    > Meet the all-new My Yahoo! - Try it today!
    > http://my.yahoo.com
    >
    >
    >
    >




    __________________________________
    Do you Yahoo!?
    Meet the all-new My Yahoo! - Try it today!
    http://my.yahoo.com

    ------------------------------------------
    Posted to Phorum via PhorumMail