× Warning! This forum is in archival status. New contributions may not work.
[campsite-dev] Next release
  • Hi again,
    I would like to ask about next release. When it shall be released? Will install
    script be changed or the change is planed for 3.0?
    Above to changes Mugur sent me to compile campsite parser on gcc 3.4, I had to
    make several changes myself and I am wandering if they will be in next release.


    1) change Makefile in tpl-cgi to link and compile mutex.o
    2) change campsite_serverctl script (for some reason it stopped working,
    probably due to change in ps, I have corrected version I can send later today)

    ------- not much neaded, but would be nice
    3) add /usr/local/etc/apache and /usr/local/etc/apache2 to apache conf files
    location for check4_functions
    4) change *.conf to httpd.conf for apache uid and gid, or just add question for
    these values in case they are not found in config file
    --------

    5) This is most important issue: eventhandler
    It complains about mutex and if I use the same change in Makefile of
    smtp_wrapper, it compiles.
    However if it checks if the relay is enabled, it crashes with core dump.
    I cannot use eventhandler at all.

    This leads to question:
    What do I miss if I do not install it at all?
    When do tou plan to change smtp_wrapper, does it worth to fix (I am the only
    complaining user right now)?

    Ondra

    ----------------------------------------------------------------
    This message was sent using IMP, the Internet Messaging Program.

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • 4 Comments sorted by
  • Hi Ondra,

    I'll commit all your changes to CVS for the next campsite version but I won't
    be available until November 8th, that's when I suppose I'll have a computer and
    Internet access.

    Mugur

    --- kouteko@tol.cz wrote:

    > Hi again,
    > I would like to ask about next release. When it shall be released? Will
    > install
    > script be changed or the change is planed for 3.0?
    > Above to changes Mugur sent me to compile campsite parser on gcc 3.4, I had
    > to
    > make several changes myself and I am wandering if they will be in next
    > release.
    >
    >
    > 1) change Makefile in tpl-cgi to link and compile mutex.o
    > 2) change campsite_serverctl script (for some reason it stopped working,
    > probably due to change in ps, I have corrected version I can send later
    > today)
    >
    > ------- not much neaded, but would be nice
    > 3) add /usr/local/etc/apache and /usr/local/etc/apache2 to apache conf files
    > location for check4_functions
    > 4) change *.conf to httpd.conf for apache uid and gid, or just add question
    > for
    > these values in case they are not found in config file
    > --------
    >
    > 5) This is most important issue: eventhandler
    > It complains about mutex and if I use the same change in Makefile of
    > smtp_wrapper, it compiles.
    > However if it checks if the relay is enabled, it crashes with core dump.
    > I cannot use eventhandler at all.
    >
    > This leads to question:
    > What do I miss if I do not install it at all?
    > When do tou plan to change smtp_wrapper, does it worth to fix (I am the only
    > complaining user right now)?
    >
    > Ondra
    >
    > ----------------------------------------------------------------
    > This message was sent using IMP, the Internet Messaging Program.
    >




    __________________________________
    Do you Yahoo!?
    Check out the new Yahoo! Front Page.
    www.yahoo.com

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • That is great.
    Ondra

    -----Original Message-----
    From: Mugur Rus [mailto:mugur1973@yahoo.com]
    Sent: Monday, November 01, 2004 7:21 PM
    To: campsite-dev@campware.org
    Subject: Re: [campsite-dev] Next release

    Hi Ondra,

    I'll commit all your changes to CVS for the next campsite version but I
    won't be available until November 8th, that's when I suppose I'll have a
    computer and Internet access.

    Mugur

    --- kouteko@tol.cz wrote:

    > Hi again,
    > I would like to ask about next release. When it shall be released?
    > Will install script be changed or the change is planed for 3.0?
    > Above to changes Mugur sent me to compile campsite parser on gcc 3.4,
    > I had to make several changes myself and I am wandering if they will
    > be in next release.
    >
    >
    > 1) change Makefile in tpl-cgi to link and compile mutex.o
    > 2) change campsite_serverctl script (for some reason it stopped
    > working, probably due to change in ps, I have corrected version I can
    > send later
    > today)
    >
    > ------- not much neaded, but would be nice
    > 3) add /usr/local/etc/apache and /usr/local/etc/apache2 to apache conf
    > files location for check4_functions
    > 4) change *.conf to httpd.conf for apache uid and gid, or just add
    > question for these values in case they are not found in config file
    > --------
    >
    > 5) This is most important issue: eventhandler It complains about mutex
    > and if I use the same change in Makefile of smtp_wrapper, it compiles.
    > However if it checks if the relay is enabled, it crashes with core dump.
    > I cannot use eventhandler at all.
    >
    > This leads to question:
    > What do I miss if I do not install it at all?
    > When do tou plan to change smtp_wrapper, does it worth to fix (I am
    > the only complaining user right now)?
    >
    > Ondra
    >
    > ----------------------------------------------------------------
    > This message was sent using IMP, the Internet Messaging Program.
    >




    __________________________________
    Do you Yahoo!?
    Check out the new Yahoo! Front Page.
    www.yahoo.com

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • > I would like to ask about next release. When it shall be released? Will
    > install script be changed or the change is planed for 3.0?
    Fixes for FreeBSD will be released in 2.1.6.

    > 1) change Makefile in tpl-cgi to link and compile mutex.o
    Fixed in CVS - check 2.1 branch

    > 2) change campsite_serverctl script (for some reason it stopped working,
    > probably due to change in ps, I have corrected version I can send later
    > today)
    Fixed in CVS - check 2.1 branch

    > 3) add /usr/local/etc/apache and /usr/local/etc/apache2 to apache conf files
    > location for check4_functions
    Fixed in CVS - check 2.1 branch

    > 4) change *.conf to httpd.conf for apache uid and gid, or just add question
    > for these values in case they are not found in config file
    Fixed in CVS - check 2.1 branch

    > 5) This is most important issue: eventhandler
    > It complains about mutex and if I use the same change in Makefile of
    > smtp_wrapper, it compiles.
    Fixed in CVS - check 2.1 branch

    > However if it checks if the relay is enabled, it crashes with core dump.
    > I cannot use eventhandler at all.
    Can't do anything since I can't replicate the problem; I need access to your
    system.

    > What do I miss if I do not install it at all?
    Event handlers

    > When do tou plan to change smtp_wrapper, does it worth to fix (I am the only
    > complaining user right now)?
    As I said before I'll be able to fix it when I have access to your system (I
    can't replicate it).

    Mugur




    __________________________________
    Do you Yahoo!?
    Meet the all-new My Yahoo! - Try it today!
    http://my.yahoo.com

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • I will try to get some older hardware for campsite testing on FreeBSD 5.3
    for you.
    Ondra


    -----Original Message-----
    From: Mugur Rus [mailto:mugur1973@yahoo.com]
    Sent: Tuesday, November 16, 2004 1:20 PM
    To: campsite-dev@campware.org
    Subject: Re: [campsite-dev] Next release

    > I would like to ask about next release. When it shall be released?
    > Will install script be changed or the change is planed for 3.0?
    Fixes for FreeBSD will be released in 2.1.6.

    > 1) change Makefile in tpl-cgi to link and compile mutex.o
    Fixed in CVS - check 2.1 branch

    > 2) change campsite_serverctl script (for some reason it stopped
    > working, probably due to change in ps, I have corrected version I can
    > send later
    > today)
    Fixed in CVS - check 2.1 branch

    > 3) add /usr/local/etc/apache and /usr/local/etc/apache2 to apache conf
    > files location for check4_functions
    Fixed in CVS - check 2.1 branch

    > 4) change *.conf to httpd.conf for apache uid and gid, or just add
    > question for these values in case they are not found in config file
    Fixed in CVS - check 2.1 branch

    > 5) This is most important issue: eventhandler It complains about mutex
    > and if I use the same change in Makefile of smtp_wrapper, it compiles.
    Fixed in CVS - check 2.1 branch

    > However if it checks if the relay is enabled, it crashes with core dump.
    > I cannot use eventhandler at all.
    Can't do anything since I can't replicate the problem; I need access to your
    system.

    > What do I miss if I do not install it at all?
    Event handlers

    > When do tou plan to change smtp_wrapper, does it worth to fix (I am the
    only
    > complaining user right now)?
    As I said before I'll be able to fix it when I have access to your system (I
    can't replicate it).

    Mugur




    __________________________________
    Do you Yahoo!?
    Meet the all-new My Yahoo! - Try it today!
    http://my.yahoo.com

    ------------------------------------------
    Posted to Phorum via PhorumMail