× Warning! This forum is in archival status. New contributions may not work.
Images present
  • How to check is there uploaded image in article body?
    I added to article, body field: sectionimage, which should contain image to be shown on section.
    Now, how to check is there any image uploaded, (if not i would like to print some "noimageuploaded" image).

    I found "If Image" statement but still I can't understand how it works.

    Please.
  • 6 Comments sorted by
  • At 14:38 27.11.2004, you wrote:
    >This message was sent from: Campsite Support.
    >
    >----------------------------------------------------------------
    >
    >How to check is there uploaded image in article body?
    >I added to article, body field: sectionimage, which should contain image
    >to be shown on section.
    >Now, how to check is there any image uploaded, (if not i would like to
    >print some "noimageuploaded" image).
    >
    >I found "If Image" statement but still I can't understand how it works.

    you have to check for the image number. the number you set when uploading
    the image.
    with the following i am checking if image number 50 was uploaded for the
    editorial. if yes, i generate the HTML to display it.






    bynumber desc>


    height="191" border="0" vspace="0" hspace="0">






    Micz Flor - micz@mi.cz

    content and media development http://mi.cz
    -----------------------------------------------------------------
    http://www.campware.org -- http://crash.mi.cz -- http://suemi.de
    "I told our marketing guys to speak now or forever be silent."
    (Aleksandar Brajanoski)
    -----------------------------------------------------------------

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • thanks for help.
    but i still got some doubts...

    if i don't know exact number? i.e. someone else is going to upload an image.

    is image number autoincrement of all uploaded images in section or else?
  • Whatever, i made "Solomon solution":

    background image of cell where image should be placed is "no image present".
    so, if image is not present, just backgorund is visible.
  • You have to know the image number; create a standard numbering of the images.
    For example:
    1 for front page images
    2 for section images
    ...
    10 and above for article images

    Hope this helps,
    Mugur

    --- campsite-support@eserver2.mdlf.org wrote:

    > This message was sent from: Campsite Support.
    >
    > ----------------------------------------------------------------
    >
    > thanks for help.
    > but i still got some doubts...
    >
    > if i don't know exact number? i.e. someone else is going to upload an
    > image.
    >
    > is image number autoincrement of all uploaded images in section or else?
    >
    > ----------------------------------------------------------------
    > Sent using Phorum software version 3.4.3a
    >




    __________________________________
    Do you Yahoo!?
    Take Yahoo! Mail with you! Get it on your mobile phone.
    http://mobile.yahoo.com/maildemo

    ------------------------------------------
    Posted to Phorum via PhorumMail
  • Now it's clear.
    There should be upload policy.

    One more hint I request:
    Q>
    if i refer to the image as

    then i have no result
    but if i refer to the image as

    then i get result, image is shown, page is executed but with message from debugger:
    "Error 110: Line 4,Column 23; not a valid operator; "
  • > if i refer to the image as
    >
    > then i have no result
    Please check if the language, publication, issue, section and the article were
    correctly set before typing "if image". You can test this by writing:

    Language:


    Publication:


    Issue:


    Section:


    Article:



    If anyone of them is empty there is no way "if image" will work. If you still
    didn't figure out what's wrong please send me the whole template and included
    ones. Also, paste the URL of the page in which you used "if image" from your
    browser.

    > but if i refer to the image as
    >
    > then i get result, image is shown, page is executed but with message from
    > debugger:
    > "Error 110: Line 4,Column 23; not a valid operator; "
    There is no such syntax: "if article image" so don't try to use it Smile

    Hope this helps,
    Mugur




    __________________________________
    Do you Yahoo!?
    Yahoo! Mail - Easier than ever with enhanced search. Learn more.
    http://info.mail.yahoo.com/mail_250

    ------------------------------------------
    Posted to Phorum via PhorumMail