× Warning! This forum is in archival status. New contributions may not work.
  • When I run honcho I see this:

    01:46:59 system      | web.1 started (pid=29640)
    01:46:59 system      | newsapi.1 started (pid=29639)
    01:46:59 system      | newsroom.1 started (pid=29642)
    01:46:59 system      | beat.1 started (pid=29641)
    01:46:59 system      | websocket.1 started (pid=29643)
    01:46:59 websocket.1 | Traceback (most recent call last):
    01:46:59 websocket.1 |   File "/usr/lib/python3.5/runpy.py", line 174, in _run_module_as_main
    01:46:59 websocket.1 |     mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
    01:46:59 websocket.1 |   File "/usr/lib/python3.5/runpy.py", line 109, in _get_module_details
    01:46:59 websocket.1 |     __import__(pkg_name)
    01:46:59 websocket.1 |   File "/opt/newshubproject/newsroom/newsroom/__init__.py", line 8, in <module>
    01:46:59 websocket.1 |     import superdesk
    01:46:59 websocket.1 | ImportError: No module named 'superdesk'
    01:46:59 system      | websocket.1 stopped (rc=1)
    01:46:59 system      | sending SIGTERM to newsroom.1 (pid 29642)
    01:46:59 system      | sending SIGTERM to newsapi.1 (pid 29639)
    01:46:59 system      | sending SIGTERM to web.1 (pid 29640)
    01:46:59 system      | sending SIGTERM to beat.1 (pid 29641)
    01:46:59 system      | web.1 stopped (rc=-15)
    01:46:59 system      | beat.1 stopped (rc=-15)
    01:46:59 system      | newsapi.1 stopped (rc=-15)
    01:46:59 system      | newsroom.1 stopped (rc=-15)

    How to install the missing superdesk "thing"?

    Trond
  • 1 Comment sorted by
  • Hi Trond.
    Make sure that you've installed all python requirements listed in `newsroom/requirements.txt`.
    You can install it with pip (`pip install -r requirements.txt`).