Airtime install on Ubuntu 18.04 - Help?
  • Hey guys,

    Been using Airtime for about 6 years but my current server build (deb 7) has just died - problems with the machine (not airtime).

    I've grabbed a new VPS but as Deb 7 is so old it's no longer supported as an installable OS with my host.
    I installed Deb 9 (the oldest version they offer) but the airtime install got nowhere.

    So I wiped the new machine and installed UB 18.04.

    I've done the following to try and install airtime-2.5.2.1 but I'm still getting a ton of errors.

    - sudo nano /etc/apt/sources.list
    (and added) deb https://apt.sourcefabric.org/ bionic main

    - sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 0888FE5B174C1854
    - sudo apt-get install sourcefabric-keyring
    - sudo add-apt-repository ppa:ondrej/php (for the old version 5 of PHP which is no longer supported)
    - sudo apt-get install -y php5.6

    But when I try to run ./install I get the following errors :

    Package mp3gain is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    Package php5-curl is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    Package php5 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    Package php5-pgsql is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    Package libapache2-mod-php5 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    Package php-apc is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    Package php5-gd is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    W: --force-yes is deprecated, use one of the options starting with --allow instead.
    E: Package 'libapache2-mod-php5' has no installation candidate
    E: Package 'php5' has no installation candidate
    E: Package 'php5-gd' has no installation candidate
    E: Package 'php5-pgsql' has no installation candidate
    E: Package 'php5-curl' has no installation candidate
    E: Package 'mp3gain' has no installation candidate
    E: Package 'php-apc' has no installation candidate

    Can somebody please advise how to manually install the missing files? Where are they located?

    Or is there an updated install script that can be downloaded from anywhere?

    Many thanks!
    Post edited by DaveSpicer at 2020-06-18 06:02:47