Installing Planning Component
  • Hi all,

    I have tried to install the planning component on my newly freshly installed superdesk installation. I have followed this Readme instruction for installing:


    I believe I have completed all steps, but when logging in I cannot see any sights of planning. I have also restarted the superdesk service just in case.

    Looking forward to hearing from someone.

    Trond

  • 9 Comments sorted by
  • Content of package.json under client:
    cat package.json 
    {
        "name": "superdesk",
        "license": "GPL-3.0",
        "dependencies": {
            "superdesk-core": "^1.31.0",
            "superdesk-planning": "superdesk/superdesk-planning#0c8a402"
        }
    }

    (using latest revision in master)

    output of npm install:
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.1.2 (node_modules/watchpack/node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/watchpack-chokidar2/node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/webpack-dev-server/node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN end-to-end-testing-helpers@1.0.5 requires a peer of protractor@5.4.2 but none was installed.
    npm WARN superdesk@ No description
    npm WARN superdesk@ No repository field.

    Output of: cat requirements.txt 
    gunicorn==19.7.1
    honcho==1.0.1
    newrelic>=2.66,<2.67
    superdesk-core>=1.31,<2.0
    git+git://github.com/superdesk/superdesk-planning.git@0c8a402#egg=superdesk-planning

    content of settings.py:
    INSTALLED_APPS.extend([
        'apps.languages',
        'planning',
    ])

  • Output of: pip install -r requirements.txt 
    Collecting gunicorn==19.7.1
      Using cached gunicorn-19.7.1-py2.py3-none-any.whl (111 kB)
    ....
      Building wheel for icalendar (setup.py) ... done
      Created wheel for icalendar: filename=icalendar-3.11.1-py3-none-any.whl size=65947 sha256=6638ac36bb6c36527b39db1f3212248ac81b1ec9fc1efb5a07f631833017d45a
      Stored in directory: /root/.cache/pip/wheels/05/24/15/bd2ac302bca9b67d96c3bde8eec755f4702ab7d3afd9969dd2
    Successfully built superdesk-planning icalendar
    Installing collected packages: gunicorn, icalendar, jsonpickle, deepdiff, superdesk-planning
      Attempting uninstall: gunicorn
        Found existing installation: gunicorn 20.0.4
        Uninstalling gunicorn-20.0.4:
          Successfully uninstalled gunicorn-20.0.4
    Successfully installed deepdiff-3.3.0 gunicorn-19.7.1 icalendar-3.11.1 jsonpickle-1.4.1 superdesk-planning-1.33.0

    My gut feeling is that the server was successfully installed, but perhaps not the client.

  • Btw: the config in client folder had a typo. So I have corrected that one. Found out when I ran Grunt command:


  • ALso:

    I am seeing this when I run the command grunt build --webpack-no-progress

    Running "ngtemplates:index" (ngtemplates) task
    >> Template "/opt/superdesk/client/node_modules/superdesk-core//opt/superdesk/client/node_modules/superdesk-core/tasks/options/ngtemplates.js" not found.
    File ./index.html created.
  • I found there was a typo and corrected that one. running npm install does not change much. When running grunt build I get an out of memory error

  • I ran this command:

    node --max-old-space-size=4096 /opt/superdesk/client/node_modules/.bin/grunt build

    Which seams to make things work.

    Another option could be to run this command first:
     export NODE_OPTIONS=–max_old_space_size=4096

    Then I guess you have to log in and out of the session, maybe also restart server. The export command is for linux / mac only.

    On windows follow the window specific instructions here: 

    I am how ever now getting the following errors: 
    "disconnected from notification server"
    and also 
    "failed to run the query" 

    And planning is empty...

  • When I look into console and see the network error and then run the same URL I see this:

    {"_message": "","_issues": {"auth": 1},"internal_error": 401,"_status": "ERR"}

    and in console I see this:
    WebSocket connection to 'ws://0.0.0.0:5100/' failed: Error in connection establishment: net::ERR_CONNECTION_REFUSED

    I am assuming 0.0.0.0 should be changed or 5100 should be open. Trying the latter first.
  • For websocket I changed 0.0.0.0 to localhost and then ran the grunt build command again. It seemed to work.

    I am still getting internal error now on planning. Now it says 500 though.
  • The internal error is related to elastic search:

    Failed to execute [org.elasticsearch.action.search.SearchRequest@2cd2adcb] lastShard [true]
    RemoteTransportException[[Blistik][local[1]][indices:data/read/search[phase/query]]]; nested: SearchParseException[failed to parse search source [{"filter": {"or": {"filters": [{"and": {"filters": [{"term": {"type": "event"}}, {"range": {"dates.end": {"time_zone": "+02:00", "gte": "now/d"}}}]}}, {"and": {"filters": [{"term": {"type": "planning"}}, {"nested": {"filter": {"range": {"_planning_schedule.scheduled": {"time_zone": "+02:00", "gte": "now/d"}}}, "path": "_planning_schedule"}}]}}]}}, "size": 250, "query": {"bool": {"must": [], "must_not": [{"term": {"state": "spiked"}}, {"term": {"state": "killed"}}]}}, "sort": {"_planning_schedule.scheduled": {"order": "asc", "nested_path": "_planning_schedule"}}}]]; nested: QueryParsingException[[nested] failed to find nested object under path [_planning_schedule]];
    Caused by: SearchParseException[failed to parse search source [{"filter": {"or": {"filters": [{"and": {"filters": [{"term": {"type": "event"}}, {"range": {"dates.end": {"time_zone": "+02:00", "gte": "now/d"}}}]}}, {"and": {"filters": [{"term": {"type": "planning"}}, {"nested": {"filter": {"range": {"_planning_schedule.scheduled": {"time_zone": "+02:00", "gte": "now/d"}}}, "path": "_planning_schedule"}}]}}]}}, "size": 250, "query": {"bool": {"must": [], "must_not": [{"term": {"state": "spiked"}}, {"term": {"state": "killed"}}]}}, "sort": {"_planning_schedule.scheduled": {"order": "asc", "nested_path": "_planning_schedule"}}}]]; nested: QueryParsingException[[nested] failed to find nested object under path [_planning_schedule]];
    Post edited by Trond Husø at 2020-06-11 17:55:04