× Warning! This forum is in archival status. New contributions may not work.
Installing latest on 16.04
  • Here are some findings when you install superdesk latest version in 1.x branch 

    1) Login to your fresh ubuntu 16.04
    2) change to root (sudo -i is my preferred command).
    3) run the install script:

    curl -s https://raw.githubusercontent.com/superdesk/fireq/files/superdesk/install | sudo bash

    When superdesk-install comes to node installation you will see this warning:
    ================================================================================
    ================================================================================

                                  DEPRECATION WARNING                            

      Node.js 7.x is no longer actively supported!

      You will not receive security or critical stability updates for this version.

      You should migrate to a supported version of Node.js as soon as possible.
      Use the installation script that corresponds to the version of Node.js you
      wish to install. e.g.

       * https://deb.nodesource.com/setup_10.x — Node.js 10 LTS "Dubnium"
       * https://deb.nodesource.com/setup_12.x — Node.js 12 LTS "Erbium" (recommended)
       * https://deb.nodesource.com/setup_14.x — Node.js 14 LTS "Fermium"

      Please see https://github.com/nodejs/Release for details about which
      version may be appropriate for you.

      The NodeSource Node.js distributions repository contains
      information both about supported versions of Node.js and supported Linux
      distributions. To learn more about usage, see the repository:

    ================================================================================
    ================================================================================

    I decided to ignore it.

    Using the command you will get some errors when it comes to npm.
    ERROR: wooper 0.4.2 has requirement requests==2.3.0, but you'll have requests 2.23.0 which is incompatible.
    ERROR: eve 0.7.8 has requirement werkzeug<=0.11.15,>=0.9.4, but you'll have werkzeug 0.16.1 which is incompatible.
    ERROR: requests-oauthlib 1.3.0 has requirement oauthlib>=3.0.0, but you'll have oauthlib 2.1.0 which is incompatible.

    And you will get a lot of warnings when it installs npm packages which all are deprecated.
    (to many to paste)

    On 16.04 all this worked "perfectly". 
    If you are on Azure or AWS you need to open some ports in order to get access to your newly installed Superdesk. 
    I opened: 
    Inbound: 
    80, 443, 5000, 5555 and 9000 
    25, 587 (for mail)
    20,21,4242,4243 (for ftp)
    22 (for ssh)

    outbound:
    80,443,9000
    25,587