Change Superdesk Access url from "localhost"

  • Hi,
    I have installed Superdesk on Ubuntu 16.04. However,
    when i create a user the url sent to them for password creation or
    password reset has "localhost" in it instead of hostname or IP address.
    Kindly assist please. The reset link example is as follows: mso-fareast-font-family:Calibri;mso-fareast-theme-font:minor-latin;mso-ansi-language:
    EN-US;mso-fareast-language:EN-US;mso-bidi-language:AR-SA">http://localhost/#/reset-password?token
    mso-fareast-font-family:Calibri;mso-fareast-theme-font:minor-latin;mso-ansi-language:
    EN-US;mso-fareast-language:EN-US;mso-bidi-language:AR-SA">
    Post edited by Aleandre at 2019-07-29 17:52:07
  • 4 Comments sorted by
  • Hi,
    I have installed Superdesk on Ubuntu 16.04. However,
    when i create a user the url sent to them for password creation or
    password reset has "localhost" in it instead of hostname or IP address.
    Kindly assist please. The reset link example is as follows: mso-fareast-font-family:Calibri;mso-fareast-theme-font:minor-latin;mso-ansi-language:
    EN-US;mso-fareast-language:EN-US;mso-bidi-language:AR-SA">http://localhost/#/reset-password?token
  • Hi,
    Anybody experienced this before? I would be grateful if someone could assist as I still have no idea why this is happening. Is there a configuration parameter i am missing?
  • Hi, I have the same problem. Have you found the solution?
  • There is a HOST line in activate.sh that needs to be changed. I've run into a problem where the token generated doesn't seem to load correctly and it just takes me back to a sign in

    Correction, You can change the HOST environment variable which is found in activate.sh if you ran the script or you can define it in env.sh, again if you ran the script. 
    Post edited by Bryan Garland at 2020-05-22 15:46:22