problem with Installation
  • Hi everybody!!!

    i have a problem in the installation of newscoop, V 4.2.4

    In the step "database settings", after enter user and password of the database, my site keep working for a few minutes, and finally show a "http error 500". 

    Thank for your help!!!
  • 2 Comments sorted by
  • (a) the final release of Newscoop was 4.4.6 and can be downloaded from  https://github.com/sourcefabric/Newscoop/ (4.2.4 was buggy so there is almost no reason why you should use it unless you are upgrading sequentially from an earlier version)


    If you are receiving 500 errors, you should compare your vhost configuration configuration file with the example in the instructions (paying particular attention to the additional line that needs to be added for Apache 2.4, if you are installing on a VPS).

    If you are using ubantu 7/8 or Debian 14.04 (Newscoop doesn't work with 16.04 or Debian 9 as it is incompatible with PHP 7), you should also change the ownership of files you have uploaded onto your server/VPS to the default Apache user which is www-data.

    Typically, the command to run in /from your terminal, is:
    (Debian) chown -R www-data:www-data /var/www/html/newscoop/
    (Ubantu) sudo chown -R www-data:www-data /var/www/html/newscoop/

    Even more generally, if you are not upgrading, you are probably going to be better off using Wordpress or another CMS, as Newscoop is not supported or being developed any more (even when it was, Sourcefabric's support wasn't very good).


  • (a) the final release of Newscoop was 4.4.6 and can be downloaded from  https://github.com/sourcefabric/Newscoop/ (4.2.4 was buggy so there is almost no reason why you should use it unless you are upgrading sequentially from an earlier version)


    If you are receiving 500 errors, you should compare your vhost configuration configuration file with the example in the instructions (paying particular attention to the additional line that needs to be added for Apache 2.4, if you are installing on a VPS).

    If you are using ubantu 7/8 or Debian 14.04 (Newscoop doesn't work with 16.04 or Debian 9 as it is incompatible with PHP 7), you should also change the ownership of files you have uploaded onto your server/VPS to the default Apache user which is www-data.

    Typically, the command to run in /from your terminal, is:
    (Debian) chown -R www-data:www-data /var/www/html/newscoop/
    (Ubantu) sudo chown -R www-data:www-data /var/www/html/newscoop/

    Even more generally, if you are not upgrading, you are probably going to be better off using Wordpress or another CMS, as Newscoop is not supported or being developed any more (even when it was, Sourcefabric's support wasn't very good).