How to configure superdesk after installation documentation
  • After successfully install superdesk on my system following the steps given, I found nothing on the documentation whether in github / reference manual / forum that gives detail documentation how to configure it. 

    For example, how do I change the host url of image thumbnails. It always refers to http://localhost:5000/api/... . The URL creates a broken image thumbnail on client. And many other configuration issues.

    Any clue would be very appreciated. Thx 
  • 4 Comments sorted by
  • Also , as an addition, how you change the UI language to not english?

    How you setup a real email service?

  • Vote Up0Vote Down ChuxChux
    Posts: 8Member
    After successfully install superdesk on my system following the steps given, I found nothing on the documentation whether in github / reference manual / forum that gives detail documentation how to configure it. 

    For example, how do I change the host url of image thumbnails. It always refers to http://localhost:5000/api/... . The URL creates a broken image thumbnail on client. And many other configuration issues.

    Any clue would be very appreciated. Thx 


    Superdesk is made up of various components, so first thing is that you need a good config for your webserver.

    I used the automated setup, which created an nginx config like below .. this may not match the config you have if you have installed yours manually.  Notice the proxy_pass directives - they are the jump-offs to the various components, icluding the api at port 5000.

    If you are at a complete loss as to how to start, then your best bet is to use the automated install, so you can get a better grip on how the system is coupled together.

    <pre>
    location /ws {
        proxy_pass http://localhost:5100;
        proxy_http_version 1.1;
        proxy_buffering off;
        proxy_read_timeout 3600;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "Upgrade";
    }

    location /api {
        proxy_pass http://localhost:5000;
        proxy_set_header Host localhost;
        expires epoch;

        sub_filter_once off;
        sub_filter_types application/json;
        sub_filter 'http://localhost' 'http://$host';
    }

    location /contentapi {
        proxy_pass http://localhost:5400;
        proxy_set_header Host localhost;
        expires epoch;
    }

    location /.well-known {
        root /var/tmp;
    }
    location / {
        root /opt/superdesk/client/dist;

        # TODO: use "config.js:server" for user installations
        sub_filter_once off;
        sub_filter_types application/javascript;
        sub_filter 'http://localhost' 'http://$host';
        sub_filter 'ws://localhost/ws' 'ws://$host/ws';
    }
    location /mail {
        alias /var/log/superdesk/mail/;
        default_type text/plain;
        autoindex on;
        autoindex_exact_size off;
    }
    </pre>


  • Vote Up0Vote Down ChuxChux
    Posts: 8Member
    Ioannis said:

    Also , as an addition, how you change the UI language to not english?


    How you setup a real email service?



    If you have successfully logged into the UI, you should be able to change the UI language by going to the profile settings (Click the 'A' in blue circle - top right of window, then 'Profile') .. 

    In the window that opens, on the 'Overview' tab, scroll down until you see 'Language' .. then just choose your preferred language

    Mind you, I have not tried to change the language myself .. because I don't have a need rfor that.  But I can see that's where UI language is to be selected.
  • Chux said:

    Ioannis said:

    Also , as an addition, how you change the UI language to not english?


    How you setup a real email service?



    If you have successfully logged into the UI, you should be able to change the UI language by going to the profile settings (Click the 'A' in blue circle - top right of window, then 'Profile') .. 

    In the window that opens, on the 'Overview' tab, scroll down until you see 'Language' .. then just choose your preferred language

    Mind you, I have not tried to change the language myself .. because I don't have a need rfor that.  But I can see that's where UI language is to be selected.


    I did a browser cache cleaning and the language changed.